Jump to content

chrizree

Dedicated Members
  • Posts

    804
  • Joined

  • Last visited

  • Days Won

    69

Everything posted by chrizree

  1. It would be good to get a more detailed feedback on how it was solved. Other users could benefit from that when visiting and reading the forum threads.
  2. An alternative command is; udisk mount (and udisk unmount)
  3. OK, you have to dive deeper into your specific setup and configuration, it works for me.
  4. Did you try what I posted in the other thread you have active on the same subject?
  5. In: /etc/turtle/modules/dnsmasq-spoof on a new line below server=8.8.8.8 (line 18-19-ish) add: listen-address=172.16.84.1 Reboot the Turtle Try again
  6. Still, the question remains: In what way doesn't it work? Have you made every single step throughout that whole video and it still doesn't work or are you getting stuck somewhere in the process?
  7. What does df -h or sudo fdisk -l or mount tell you? Does the Bunny seem to be mounted? This shouldn't be a problem. I use my Bunnies all the time on Ubuntu/Debian based systems.
  8. In what way doesn't it work? "Problem > Help!" doesn't say much. What steps have you taken to troubleshoot it yourself?
  9. I don't think it's worth the effort though since the "technique" is more or less deprecated as it targets http. Probably why it was removed from the GitHub repo since it's an obsolete tool.
  10. You could perhaps get it working by doing a factory reset that reverts the Turtle to firmware version 5 (at least my Turtle, but it's an old one). But when you upgrade back up to fw 6.2 it will not work.
  11. What module are you asking about? The title says URLSnarf (which is broken, if not fixed recently but I don't think so since it's removed from the Hak5 GitHub repo containing modules for the Turtle), and then autossh and sshfs in the text. Is the question about all three modules or just one/some of them?
  12. You misunderstood my meaning of "spamming". I didn't mean that the Ducky is used in traditional spamming related scenarios, but the fact that the Ducky "spams" the BIOS interface with characters since it might be typing to fast for the BIOS to be able to handle. I.e. what I meant with "spamming" was that the Ducky perhaps was too fast, nothing else.
  13. Are the characters totally random or are they in some way a part of your initial and intended string of text? The Ducky is a fast writer, maybe it's "character spamming" the BIOS interface in a rate that is way too fast for it to really be able handle the input.
  14. Are you on any other keyboard language than US? If so, then you might need to use the specific language file when encoding the inject.bin. However, you mention boot, so the language might not be an issue after all if it's early in the boot process and the computer hasn't really selected any specific keyboard language to use at that point. Numbers and letters are also most often the same so it should generally work, but might differ.
  15. I normally don't use any added USB Ethernet NIC in this way with my Mk7, but I tested it out now and I experience the same issue. Tried with the following adapters: Noname USB Type A NIC 0bda:8153 Realtek Semiconductor Corp. RTL8153 Gigabit Ethernet Adapter Hak5 "branded" USB Type A NIC (i.e. bought from the Hak5 shop) 0b95:772b ASIX Electronics Corp. AX88772B Hak5 Plunder Bug (as per instructions in the Hak5 docs for the Mk7) 0b95:772b ASIX Electronics Corp. AX88772B --- Route always defaults to having the USB-C interface on top (or br-lan really) default 172.16.42.42 0.0.0.0 UG 0 0 0 br-lan The USB NIC is following the above route line and looks like this default OpenWrt.lan 0.0.0.0 UG 211 0 0 eth1 --- eth1 (the USB Type A Ethernet NIC) has received an IP address from the local network that it is connected to ping to local network = OK ping internet addresses = not OK (obviously) No computer attached to the USB-C onboard interface (just a power adapter) No wireless client mode configured for wlan2 Always getting the "Connect to the Internet?" popup when logging in to the Mk7 web GUI using this setup When clicking "USB Ethernet Adapter" in the "Connect to the Internet?" popup, it redirects to the Hak5 docs pages (which obviously fails since there is no route that allows that) Attaching the Type A USB NIC before or after booting the Mk7 doesn't matter When connecting as a wireless client using wlan2 the routing table automatically (without reboot) puts the wlan2 based address on top of the route, the same is not happening when the Type A USB Ethernet NIC is attached. So, it seems as if an attached USB Type A Ethernet NIC never gets priority over the br-lan interface when the two are "competing" about routing supremacy
  16. You can find it in the docs https://docs.hak5.org/hc/en-us/categories/360004116253-WiFi-Pineapple-Mark-VII More specifically in this video at about 2+ mins https://docs.hak5.org/hc/en-us/articles/360055134133-2-Initial-Setup
  17. With the autossh module stopped in the Turtle "text based GUI", try running the following directly from the terminal on the Turtle (change user@address to something relevant for your setup and ports as well, if not "default") autossh -M 20000 -i /root/.ssh/id_rsa -R 2222:localhost:22 user@address -p 22 -N -T If that works (it should), change the following line in /etc/turtle/modules/autossh from: uci set autossh.@autossh[0].ssh="-i /root/.ssh/id_rsa -N -T -R "$autossh_remoteport":localhost:"$autossh_localport" "$autossh_host" -p "$autossh_port" " to: uci set autossh.@autossh[0].ssh="-i /root/.ssh/id_rsa -R "$autossh_remoteport":localhost:"$autossh_localport" "$autossh_host" -p "$autossh_port" -N -T" Furthermore... to get the module itself working, change the lines in the "configure" function of the autossh module from: autossh_host=$(uci show autossh.@autossh[0].ssh | awk '{print $7}' | sed "s/'//g") autossh_port=$(uci show autossh.@autossh[0].ssh | awk '{print $9}' | sed "s/'//g") autossh_remoteport=$(uci show autossh.@autossh[0].ssh | awk '{print $6}' | sed 's/:/ /g' | awk '{print $1}') autossh_localport=$(uci show autossh.@autossh[0].ssh | awk '{print $6}' | sed 's/:/ /g' | awk '{print $3}') to: autossh_host=$(uci show autossh.@autossh[0].ssh | awk '{print $5}' | sed "s/'//g") autossh_port=$(uci show autossh.@autossh[0].ssh | awk '{print $7}' | sed "s/'//g") autossh_remoteport=$(uci show autossh.@autossh[0].ssh | awk '{print $4}' | sed 's/:/ /g' | awk '{print $1}') autossh_localport=$(uci show autossh.@autossh[0].ssh | awk '{print $4}' | sed 's/:/ /g' | awk '{print $3}') Also change the line in the "start" function of the autossh module from: autossh_host=$(uci show autossh.@autossh[0].ssh | awk '{print $7}' | sed 's/@/ /g' | awk '{print $2}') to: autossh_host=$(uci show autossh.@autossh[0].ssh | awk '{print $5}' | sed 's/@/ /g' | awk '{print $2}') Done!
  18. I think you have mixed something up and made settings that isn't needed (or shouldn't be there). 2222 has nothing to do with the local sshd on the vps. Just skip any settings for the local sshd on the vps and see it from the Turtle perspective.
  19. Was that default settings or did you change the file yourself? Why add the vps to 2222?
  20. Did you use the correct port?
  21. What is the use case? What is the antenna going to be "good" for? Directional or not?
  22. Well, as of right now, I have no ideas of what could be wrong. I run my C2 instance in the exact same way and I've never had such issues. As you run it with sudo and have nothing else already using the port and everything else looks ok, then I can't say what the trouble might be.
  23. I assume that you have verified the firewall rules that needs to be in place on the Turtle (at the end of the mentioned video)
  24. So running this from the command line does not work at all and throws that error (with a valid domain name of course) sudo ./c2-3.1.2_amd64_linux -hostname my-domain.com -https Have you set it up as a service? Do you run other things other than the C2 instance on that VPS?
  25. I know, it's a decision you have to make. I run all my Hak5 devices with Cloud C2 (that is possible), but not the Mk7 since I want to be able to access the features in the local web GUI rather than via Cloud C2.
×
×
  • Create New...