Jump to content

soh_hos

Active Members
  • Content Count

    7
  • Joined

  • Last visited

About soh_hos

  • Rank
    Newbie

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Try to ssh in and write "ATTACKMODE HID RNDIS_ETHERNET" (for a Windows host) in the KeyCrocs bash. After the command got executed successfully enter 'QUACK STRING "hello" '. If "hello" is printed out to your screen everything works fine and your payload contains the error reason. If not we will have to do further investigations.
  2. Hmmm yeah I thought something like that. Than you. The question is, which versions are supported by the KeyCroc to not break it. @Darren Kitchen can we update the KeyCroc with the current buster libraries without breaking it or is that not recommended?
  3. You can use the KeyCroc also without a Keyboard. Just remove the "Match" keyword from your payloads and the attack will be executed right after pluging in the KeyCroc at the USB Port of your Laptop
  4. Could it be a missing kernel setting like in this post? https://forums.gentoo.org/viewtopic-t-951448.html
  5. I just realized there is also no /dev/hidraw entry created after plugging in the keyboard. udevadm monitor gives the following output after pluging in the keyboard: KERNEL[6362.875459] add /devices/platform/sunxi-ohci.3/usb5/5-1 (usb) UDEV [6362.880792] add /devices/platform/sunxi-ohci.3/usb5/5-1 (usb) KERNEL[6362.883571] add /devices/platform/sunxi-ohci.3/usb5/5-1/5-1:1.0 (usb) KERNEL[6362.883767] add /devices/platform/sunxi-ohci.3/usb5/5-1/5-1:1.0/0003:046A:0023.000F (hid) KERNEL[6362.885949] add /devices/platform/sunxi-ohci.3/usb5/5-1/5-1:1.1 (usb) KERNEL[
  6. Hello, my Keycroc does not work with Cherry Keyboards. I investigated the problem, and found in "croc_framework" a line which is checking the lsusb command for the keyword "Linux". But the cherry Keyboard gets registered at the croc as "Bus 005 Device 002: ID 046a:0023 Cherry GmbH CyMotion Master Linux Keyboard G230", so it can't detect it. Could you please fix this issue or tell me how I can fix it? If I adjust the check for "Linux" it unfortunately still doesn't work.
×
×
  • Create New...