Jump to content

Modulemanager can not start / always stopped


Recommended Posts


it is my first LAN Turtle, I ordered it as Bundle from the US Store.

I did the Update to V2 with Putty & Network cable throug the LanTurtle

I am not able to install anything from the Directory.

I tryed factory Default reset with the .bin of your Website.

Stil the same Problem.

In the List of the Modules there is no X by Modulemange.

When I select it, it tells me Current Status:Stopped And Bootup Status: Enabled

When I go to configure I can select Modules from Directory but nothing is installed in the end.

I tryed everthing!

Is there a solution?

Link to comment
Share on other sites

At least in my experience, I have this same problem, and am unable to download modules. I cannot say for sure it is due to module manager not starting, but seems like may be related.

As in OP comments, I immediately checked for and downloaded updates (as instructed). This updated my firmware from v1 to v2. I could not download modules and modulemanager wouldn't start.
Since I could not download modules, I followed instructions on the wiki and reflashed. I am running version 2 as downloaded from downloads.lanturtle.com.
I successfully:
-Acquire IP Address
-SSH to Turtle
-Change Password
-Update Turtle from turtle shell
-Connect and view list of available modules
-Successfully reflash with latest firmware (though issues persist)
I cannot:
-Start the ModuleManager Service
​Selecting modules > modulemanager > start == screen indicating press OK or CTRL+C to exit...service does not start
Changing bootup status to "enabled" does not start the manager, even after performing above and/or rebooting
accessing lower-level shell and entering #start modulemanager provides a message "commands will be executed using /bin/sh" and a job is created, though modulemanager still does not run
-Download Modules
I navigate to modules > modulemanager > configure > directory > yes > [select any module, all are displayed] == message "installed modules:" and no modules are installed
I feel like this may be a firmware issue. I have a friend who received a turtle in same general time and did not update to v2. He is able to download and run modules without any problems.
Could we acquire have an official download made available of the old v1 of the firmware as a temporary fix/troublehsooting step?
Please advise, and thank you in advance for your help,
Link to comment
Share on other sites

I have a second LanTurtle i purchased and received around November 2015. I haven't used it at all yet, but seeing this thread I thought I'd try it out. My first LanTurtle worked out of the box without issues and has been deployed/operating as I need it to for a few months now.

I started out first by factory resetting the turtle using latest bin available on lanturtle.com and uploading through the web interface, just so I could be sure it was on the same bin.

I was able to go into the Module Manger-Directory and download/install all of the modules without an issue. Confirmed when I backed out of the module manager all the modules were listed and I tested out System Uptime just to be sure one was working.

it's important to note, module manger is never going to be able to start or enable. There's no reason to as everything is done in the configure.

Maybe there is something else going on, but I'm not sure where to have y'all check for errors or anything past just letting you know I have one that worked as of today on the latest firmware bin.

Link to comment
Share on other sites

Solution seems to be here


I check out if it works for me, seems to be the same Problem

Thanks for checking, I also tried but no luck

Still no solution, @ iamtags I guess it is the best for us to ask for refund :-(

The case in the link is Long time ago & does not match with our case.

I really don't want to have to request a refund but without some official support I don't know what else to do. As bored369 indicates, The problem isn't necessarily the fact that modulemanager wont start, since he can download without that "service." Our problem is that modules will not download. Possible to rename your post? I may post with a different title to see if we can get a fix. Honestly if I could get the v1 firmware I'd like to see if it works

Link to comment
Share on other sites

  • 2 weeks later...
  • 2 weeks later...
  • 1 year later...
  • 2 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...