Jump to content

WiFi Manager


Whistle Master
 Share

Recommended Posts

My router only supports:

WPA2 CCMP

PSK

I can't select CCMP (tried AES and TKIP) in the network manager.

So, the pineapple does not connect.

Tried a '[DHCP Request]'

I checked the logs. The connection does not show up

And why should you set ICS to share from none to none?

System logs:

udhcpc (v1.19.4) started
Sending discover...
Sending discover...
Sending discover...
No lease, failing

second try:

Pineapple kern.info kernel: [ 269.890000] wlan1: deauthenticating from ff:ff:ff:ff:ff:24 by local choice (reason=3)

What does that mean by local choice??

Edited by janekong
Link to comment
Share on other sites

  • Replies 255
  • Created
  • Last Reply

Top Posters In This Topic

I recently purchased a wifi pineapple, and I'm trying to instal the networkmanager module in order to connect to a wifi

After updating the package list, it seems to still not be found. Any ideas?

root@Pineapple:~# opkg install networkmanager

Unknown package 'networkmanager'.
Collected errors:
* opkg_install_cmd: Cannot install package networkmanager.
root@Pineapple:~# opkg update
Updated list of available packages in /var/opkg-lists/pineapple_packages.
root@Pineapple:~# opkg install networkmanager
Unknown package 'networkmanager'.
Collected errors:
* opkg_install_cmd: Cannot install package networkmanager.
Link to comment
Share on other sites

For now you have to download networkmanager which is now called Wifi Manager via the Pineapple Bar. Btw you have to install it to your pineapples storage not an external usb. There are some issues that are being fixed that have to do with using infusions from the usb storage.

Link to comment
Share on other sites

Okay thanks, I got wifi manager.

I'm trying to get internet access through my second interface, however after I click commit it just stays on 'Loading' for a while, and when I refresh the page the second interface is disabled. Any ideas what could be causing this? Thanks in advance

EDIT: Creating a new thread for this issue

Edited by defcon21
Link to comment
Share on other sites

i try to connect to the WPA2 router with the real internet.

What does this mean?

00:00:58 Pineapple user.info sysinit: wpa_supplicant_setup_vif(wlan1): Refusing to bridge sta mode interface
00:00:58 Pineapple user.info sysinit: enable_mac80211(radio1): Failed to set up wpa_supplicant for interface wlan1

Logs:

00:01:06 Pineapple user.info sysinit: setting up led WLAN
00:01:06 Pineapple user.info sysinit: setting up led WAN
00:01:06 Pineapple user.info sysinit: setting up led USB
00:01:06 Pineapple user.info sysinit: setting up led LAN
00:01:06 Pineapple daemon.info dnsmasq[1673]: using nameserver 8.8.8.8#53
00:01:06 Pineapple daemon.info dnsmasq[1673]: using nameserver 195.241.77.58#53
00:01:06 Pineapple daemon.info dnsmasq[1673]: using nameserver 195.241.77.55#53
00:01:06 Pineapple daemon.info dnsmasq[1673]: using nameserver 192.168.1.254#53
00:01:06 Pineapple daemon.info dnsmasq[1673]: using local addresses only for domain lan
00:01:06 Pineapple daemon.info dnsmasq[1673]: using local addresses only for domain lan
00:01:06 Pineapple daemon.info dnsmasq[1673]: started, version 2.62 cachesize 150
00:01:06 Pineapple daemon.info dnsmasq[1673]: reading /tmp/resolv.conf.auto
00:01:06 Pineapple daemon.info dnsmasq[1673]: read /etc/hosts - 1 addresses
00:01:06 Pineapple daemon.info dnsmasq[1673]: compile time options: IPv6 GNU-getopt no-DBus no-i18n no-IDN DHCP no-DHCPv6 no-Lua TFTP no-conntrack
00:01:06 Pineapple daemon.info dnsmasq-dhcp[1673]: read /etc/ethers - 0 addresses
00:01:06 Pineapple daemon.info dnsmasq-dhcp[1673]: DHCP, IP range 172.16.42.100 -- 172.16.42.249, lease time 12h
00:01:05 Pineapple user.notice root: Mobile.Keepalive: Still Redialing...
00:01:03 Pineapple user.notice dnsmasq: DNS rebinding protection is active, will discard upstream RFC1918 responses!
00:01:03 Pineapple user.notice dnsmasq: Allowing 127.0.0.0/8 responses
00:00:59 Pineapple authpriv.info dropbear[1606]: Running in background
00:00:58 Pineapple user.info sysinit: wpa_supplicant_setup_vif(wlan1): Refusing to bridge sta mode interface
00:00:58 Pineapple user.info sysinit: enable_mac80211(radio1): Failed to set up wpa_supplicant for interface wlan1
00:00:58 Pineapple cron.info crond[1587]: crond: crond (busybox 1.19.4) started, log level 5
00:00:56 Pineapple user.info sysinit: command failed: Device or resource busy (-16)
00:00:55 Pineapple user.notice root: Mobile.Keepalive: Still Redialing...
00:00:55 Pineapple user.notice ifup: Allowing Router Advertisements on wan (eth1)
00:00:55 Pineapple kern.info kernel: [ 55.600000] br-lan: port 2(wlan0) entered forwarding state
00:00:53 Pineapple kern.info kernel: [ 53.600000] br-lan: port 2(wlan0) entered forwarding state
00:00:53 Pineapple kern.info kernel: [ 53.590000] br-lan: port 2(wlan0) entered forwarding state
00:00:53 Pineapple kern.info kernel: [ 53.530000] device wlan0 entered promiscuous mode
00:00:53 Pineapple daemon.notice netifd: wan (935): Sending select for 192.168.1.39...
00:00:53 Pineapple daemon.notice netifd: wan (935): Sending discover...
00:00:53 Pineapple daemon.notice netifd: wan (935): Lease of 192.168.1.39 obtained, lease time 86400
00:00:53 Pineapple daemon.notice netifd: Interface 'wan' is now up
00:00:51 Pineapple user.notice ifup: Enabling Router Solicitations on loopback (lo)
00:00:50 Pineapple kern.info kernel: [ 50.290000] eth1: link up (100Mbps/Full duplex)
00:00:50 Pineapple daemon.notice netifd: wan (935): Sending discover...
00:00:48 Pineapple user.notice ifup: Enabling Router Solicitations on lan (br-lan)
00:00:47 Pineapple daemon.notice netifd: wan (935): Sending discover...
00:00:46 Pineapple kern.info kernel: [ 46.480000] device eth0 entered promiscuous mode
00:00:46 Pineapple daemon.notice netifd: wan (935): udhcpc (v1.19.4) started
00:00:46 Pineapple daemon.notice netifd: Interface 'loopback' is now up
00:00:46 Pineapple daemon.notice netifd: Interface 'lan' is now up
00:00:45 Pineapple user.notice root: Mobile.Keepalive: Still Redialing...
00:00:44 Pineapple user.notice usb-modeswitch: 1-1:1.0: Manufacturer=ATHEROS Product=UB91C Serial=12345
00:00:44 Pineapple user.notice root: Mobile.Keepalive: Preventing Duplicate Self.
00:00:44 Pineapple kern.info kernel: [ 44.410000] usbserial: USB Serial Driver core
00:00:44 Pineapple kern.info kernel: [ 44.410000] usbcore: registered new interface driver usbserial_generic
00:00:44 Pineapple kern.info kernel: [ 44.400000] usbcore: registered new interface driver usbserial
00:00:44 Pineapple kern.info kernel: [ 44.400000] USB Serial support registered for generic
00:00:44 Pineapple kern.info kernel: [ 44.240000] usbcore: deregistering interface driver usbserial
00:00:44 Pineapple kern.info kernel: [ 44.230000] usbcore: deregistering interface driver usbserial_generic
00:00:44 Pineapple kern.info kernel: [ 44.230000] USB Serial deregistering driver generic
00:00:43 Pineapple user.notice usb-modeswitch: 1-0:1.0: Manufacturer=Linux_3.3.8_ehci_hcd Product=Generic_Platform_EHCI_Controller Serial=ehci-platform
00:00:43 Pineapple kern.info kernel: [ 43.470000] usbserial: USB Serial Driver core
00:00:43 Pineapple kern.info kernel: [ 43.470000] usbcore: registered new interface driver usbserial_generic
00:00:43 Pineapple kern.info kernel: [ 43.460000] usbcore: registered new interface driver usbserial
00:00:43 Pineapple kern.info kernel: [ 43.460000] USB Serial support registered for generic
00:00:43 Pineapple kern.info kernel: [ 43.410000] usbcore: deregistering interface driver usbserial
00:00:43 Pineapple kern.info kernel: [ 43.400000] usbcore: deregistering interface driver usbserial_generic
00:00:43 Pineapple kern.info kernel: [ 43.400000] USB Serial deregistering driver generic
00:00:40 Pineapple kern.warn kernel: [ 0.680000] m25p80 spi0.0: found mx25l6405d, expected m25p80
00:00:40 Pineapple kern.notice kernel: [ 2.940000] Bridge firewalling registered
00:00:40 Pineapple kern.notice kernel: [ 0.750000] 0x0000007f0000-0x000000800000 : "art"
00:00:40 Pineapple kern.notice kernel: [ 0.750000] 0x000000050000-0x0000007e0000 : "firmware"
00:00:40 Pineapple kern.notice kernel: [ 0.740000] 0x0000007e0000-0x0000007f0000 : "nvram"
00:00:40 Pineapple kern.notice kernel: [ 0.740000] 0x000000650000-0x0000007e0000 : "kernel"
00:00:40 Pineapple kern.notice kernel: [ 0.730000] 0x000000590000-0x000000650000 : "rootfs_data"
00:00:40 Pineapple kern.notice kernel: [ 0.720000] mtd: partition "rootfs" set to be root filesystem
00:00:40 Pineapple kern.notice kernel: [ 0.710000] 0x000000050000-0x000000650000 : "rootfs"
00:00:40 Pineapple kern.notice kernel: [ 0.710000] 0x000000040000-0x000000050000 : "u-boot-env"
00:00:40 Pineapple kern.notice kernel: [ 0.700000] 0x000000000000-0x000000040000 : "u-boot"
00:00:40 Pineapple kern.notice kernel: [ 0.690000] Creating 7 MTD partitions on "spi0.0":
00:00:40 Pineapple kern.notice kernel: [ 0.690000] 7 cmdlinepart partitions found on MTD device spi0.0
00:00:40 Pineapple kern.info kernel: [ 39.540000] ieee80211 phy1: Atheros AR9271 Rev:1
00:00:40 Pineapple kern.info kernel: [ 39.530000] ath9k_htc 1-1:1.0: ath9k_htc: FW Version: 1.3
00:00:40 Pineapple kern.info kernel: [ 39.340000] ath9k_htc 1-1:1.0: ath9k_htc: HTC initialized with 33 credits
00:00:40 Pineapple kern.info kernel: [ 39.100000] usb 1-1: ath9k_htc: Transferred FW: htc_9271.fw, size: 51272
00:00:40 Pineapple kern.info kernel: [ 38.840000] usbcore: registered new interface driver rndis_host
00:00:40 Pineapple kern.info kernel: [ 38.610000] usbcore: registered new interface driver cdc_ether
00:00:40 Pineapple kern.info kernel: [ 38.520000] usbserial: USB Serial Driver core
00:00:40 Pineapple kern.info kernel: [ 38.510000] usbcore: registered new interface driver usbserial_generic
00:00:40 Pineapple kern.info kernel: [ 38.510000] USB Serial support registered for generic
00:00:40 Pineapple kern.info kernel: [ 38.500000] usbcore: registered new interface driver usbserial
00:00:40 Pineapple kern.info kernel: [ 38.160000] usbcore: registered new interface driver ath9k_htc
00:00:40 Pineapple kern.info kernel: [ 38.150000] usb 1-1: ath9k_htc: Firmware htc_9271.fw requested
00:00:40 Pineapple kern.info kernel: [ 37.660000] xt_time: kernel timezone is -0000
00:00:40 Pineapple kern.info kernel: [ 36.960000] nf_conntrack version 0.5.0 (458 buckets, 1832 max)
00:00:40 Pineapple kern.info kernel: [ 36.830000] NET: Registered protocol family 24
00:00:40 Pineapple kern.info kernel: [ 36.600000] ip_tables: © 2000-2006 Netfilter Core Team
00:00:40 Pineapple kern.info kernel: [ 36.340000] tun: Universal TUN/TAP device driver, 1.6
00:00:40 Pineapple kern.info kernel: [ 36.340000] tun: © 1999-2004 Max Krasnyansky
00:00:40 Pineapple kern.info kernel: [ 36.190000] PPP generic driver version 2.4.2
00:00:40 Pineapple kern.info kernel: [ 35.840000] RPC: Registered tcp NFSv4.1 backchannel transport module.
00:00:40 Pineapple kern.info kernel: [ 35.830000] RPC: Registered udp transport module.
00:00:40 Pineapple kern.info kernel: [ 35.830000] RPC: Registered tcp transport module.
00:00:40 Pineapple kern.info kernel: [ 35.820000] RPC: Registered named UNIX socket transport module.
00:00:40 Pineapple kern.info kernel: [ 35.570000] Button Hotplug driver version 0.4.1
00:00:40 Pineapple kern.info kernel: [ 35.560000] cfg80211: (5490000 KHz - 5710000 KHz @ 40000 KHz), (N/A, 2700 mBm)
00:00:40 Pineapple kern.info kernel: [ 35.550000] cfg80211: (5250000 KHz - 5330000 KHz @ 40000 KHz), (N/A, 2000 mBm)
00:00:40 Pineapple kern.info kernel: [ 35.540000] cfg80211: (5170000 KHz - 5250000 KHz @ 40000 KHz), (N/A, 2000 mBm)
00:00:40 Pineapple kern.info kernel: [ 35.530000] cfg80211: (2402000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm)
00:00:40 Pineapple kern.info kernel: [ 2.950000] VFS: Mounted root (squashfs filesystem) readonly on device 31:2.
00:00:40 Pineapple kern.info kernel: [ 2.940000] 8021q: 802.1Q VLAN Support v1.8
00:00:40 Pineapple kern.info kernel: [ 2.930000] TCP cubic registered
00:00:40 Pineapple kern.info kernel: [ 2.930000] NET: Registered protocol family 17
00:00:40 Pineapple kern.info kernel: [ 2.920000] ag71xx ag71xx.0: eth1: connected to PHY at ag71xx-mdio.1:04 [uid=004dd041, driver=Generic PHY]
00:00:40 Pineapple kern.info kernel: [ 2.370000] eth1: Atheros AG71xx at 0xb9000000, irq 4
00:00:40 Pineapple kern.info kernel: [ 1.330000] eth0: Found an AR7240/AR9330 built-in switch
00:00:40 Pineapple kern.info kernel: [ 0.780000] eth0: Atheros AG71xx at 0xba000000, irq 5
00:00:40 Pineapple kern.info kernel: [ 0.780000] ag71xx_mdio: probed
00:00:40 Pineapple kern.info kernel: [ 0.720000] mtd: partition "rootfs_data" created automatically, ofs=590000, len=C0000
00:00:40 Pineapple kern.info kernel: [ 0.680000] m25p80 spi0.0: mx25l6405d (8192 Kbytes)
00:00:40 Pineapple kern.err kernel: [ 38.730000] Error: Driver 'gpio-keys-polled' is already registered, aborting...
00:00:40 Pineapple kern.debug kernel: [ 39.550000] Registered led device: ath9k_htc-phy1
00:00:40 Pineapple kern.debug kernel: [ 39.540000] ath: doing EEPROM country->regdmn map search
00:00:40 Pineapple kern.debug kernel: [ 39.540000] ath: country maps to regdmn code: 0x37
00:00:40 Pineapple kern.debug kernel: [ 39.540000] ath: Regpair used: 0x37
00:00:40 Pineapple kern.debug kernel: [ 39.540000] ath: EEPROM regdomain: 0x833a
00:00:40 Pineapple kern.debug kernel: [ 39.540000] ath: EEPROM indicates we should expect a country code
00:00:40 Pineapple kern.debug kernel: [ 39.540000] ath: Country alpha2 being used: GB@qualcomm.com>

Link to comment
Share on other sites

Yes, I tried that tons of times. But it simply refuses to connect.

Is there any 'advanced debugging' option???

What are the instructions to manually connect?

What does this mean btw?

Pineapple kern.info kernel: [ 269.890000] wlan1: deauthenticating from (router MAC address) by local choice (reason=3)

Could you please follow the simplified usage and see if it works for you ?

Edited by janekong
Link to comment
Share on other sites

00:00:58 Pineapple user.info sysinit: wpa_supplicant_setup_vif(wlan1): Refusing to bridge sta mode interface

00:00:58 Pineapple user.info sysinit: enable_mac80211(radio1): Failed to set up wpa_supplicant for interface wlan1

[sploier]

I've had trouble with the network manager myself.

The best way I've found to connect lets say an Alfa usb card to an encrypted network is to boot up the pineapple after its booted plug in the alfa card. (I wait tell the pineapple boots before I plug it in so I know the Alfa will be on wlan1 not wlan0)

I run airmon-ng start wlan1 to bring up monitor mode (because 90% of the time I still wanna scan the area to see whats going on) I would run airodump mon0 just to wake up the card. I find if I just try to connect to my WPA2 network it doesn't always work unless I run airodump first.

Now to connect to a WPA2 network you wanna edit your WPA_supplicant.conf its located inside /etc/ with something simple like

network={

ssid=" yourssid "

psk= yourpassword

}

Once your WPA_supplicant is set up you can run wpa_supplicant. I use this little script. (I mostly stole from the forms) That will run wpa_supplicant set ipforwarding clear your iptables and set them then run udhcpc to get a dhcp request.

#!/bin/sh

wpa_supplicant -B -D nl80211 -i wlan1 -c /etc/wpa_supplicant.conf

echo 1 > /proc/sys/net/ipv4/ip_forward

iptables -F

iptables -X

iptables -A FORWARD -o wlan1 -i br-lan -s 172.16.0.0/24 -m conntrack --ctstate NEW -jACCEPT

iptables -A FORWARD -m conntrack --ctstate ESTABLISHED,RELATED -j ACCEPT

iptables -A POSTROUTING -t nat -j MASQUERADE

sleep 6

udhcpc -i wlan1

Assuming you're using the nl80211 driver that should work if not you can just look at wpa_supplicant --help to see other driver options.

[/sploier] Edited by janekong
Link to comment
Share on other sites

Yes, I tried that tons of times. But it simply refuses to connect.

Is there any 'advanced debugging' option???

What are the instructions to manually connect?

What does this mean btw?

Pineapple kern.info kernel: [ 269.890000] wlan1: deauthenticating from (router MAC address) by local choice (reason=3)

This means that the connection has dropped with your router. Which firmware are you using ? Have you tried to manually connect with the Wifi connect script ?

Link to comment
Share on other sites

WM,

First off, thank you for your most recent update fixing your modules. Was able to get them installed fine on my Mark IV on 3.0.0.

However, still having some problems with Wifi Manager. I'm trying to use my second interface to connect to an AP in order to set up ICS that way. A couple of issues I'm having:

1. After saving and committing changes, the interface seems to connect to the AP, but upon closing and opening Wifi Manager, it shows that the interface is in monitor mode. If I stop monitor mode, the interface gets disabled, and when re-enabled I go back to where I started.

2. For a brief moment, in between re-enabling and before closing Wifi Manager, the interface does not show up as being in monitor mode, but it does not give me the option to make DHCP request under Interfaces IP.

3. Additionally, Physical Interfaces shows up as having 3 radios, as opposed to two from before the updates. Not sure which one is right but I'm pretty sure it was correct before:

Physical Interfaces
radio0	wlan1	enabled	 [xx:xx:xx:xx:xx:xx] [Random Mac]
radio1	-	enabled	
radio2	wlan0	enabled	 [xx:xx:xx:xx:xx:xx] [Random Mac]

4. The reason why I think that it does manage to connect to the AP, even though it does show up as in Monitor Mode under WIfi Manager and Site Survey is the following iwconfig output from ssh:

root@Pineapple:~# iwconfig
lo        no wireless extensions.

wlan1     IEEE 802.11bg  ESSID:"xxx"
          Mode:Managed  Frequency:2.432 GHz  Access Point: xx:xx:xx:xx:xx:xx
          Bit Rate=1 Mb/s   Tx-Power=20 dBm
          RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=70/70  Signal level=-5 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:1   Missed beacon:0

eth1      no wireless extensions.

wlan0     IEEE 802.11bgn  Mode:Master  Tx-Power=18 dBm
          RTS thr:off   Fragment thr:off
          Power Management:on

eth0      no wireless extensions.

br-lan    no wireless extensions.

And finally, one last question: to get ICS working properly, do I share wlan1 to wlan0 or wlan1 to br-lan (assuming I eventually manage to get a working connection on wlan1)?

Link to comment
Share on other sites


root@Pineapple:~# cat /etc/config/wireless

config wifi-device 'radio0'

option type 'mac80211'

option channel '11'

option hwmode '11ng'

option macaddr 'XX:XX:XX:XX:XX:XX'

option htmode 'HT20'

list ht_capab 'SHORT-GI-20'

list ht_capab 'SHORT-GI-40'

list ht_capab 'RX-STBC1'

list ht_capab 'DSSS_CCK-40'

option disabled '0'

config wifi-iface

option device 'radio0'

option network 'lan'

option mode 'ap'

option ssid 'pineapple XX:XX'

option hidden '0'

config wifi-device 'radio1'

option type 'mac80211'

option hwmode '11ng'

option macaddr 'XX:XX:XX:XX:XX:XX'

option htmode 'HT20'

list ht_capab 'SHORT-GI-20'

list ht_capab 'SHORT-GI-40'

list ht_capab 'RX-STBC1'

list ht_capab 'DSSS_CCK-40'

option disabled '0'

option channel 'auto'

config wifi-iface

option device 'radio1'

option hidden '0'

option ssid 'xxxxxxxxx'

option mode 'sta'

option network 'wan'

option key 'xxxxxxxxx'

option encryption 'psk2+tkip+aes'

config wifi-device 'radio2'

option type 'mac80211'

option hwmode '11g'

option macaddr ''XX:XX:XX:XX:XX:XX''

option disabled '0'

option channel 'auto'

config wifi-iface

option device 'radio2'

option mode 'sta'

option ssid 'xxxxxxxxx'

option network 'wan'

option hidden '0'

option key 'xxxxxxxxxxxxxxx'

option encryption 'psk2+tkip+aes'
Edited by sudoman
Link to comment
Share on other sites

The WiFi Manager takes all the information from this file and your file is a bit strange. Based on the content, it appears that you have 3 physical interfaces:

config wifi-device 'radio0'
config wifi-device 'radio1'
config wifi-device 'radio2'

Moreover the radio2 section is not complete and a bit strange...

I suggest that you re-flash your pineapple. I made some tests with two external physical interfaces and did not have any issues.

Edited by Whistle Master
Link to comment
Share on other sites

WM,

Thanks, re-flashing seems to have done the trick.

However, it still shows up as being in monitor mode, not allowing me to make a DHCP request. If I click on Stop Monitor, the interface gets disabled. Upon re-enabling it, it is back on monitor mode. However, if I disable the interface and the re-enable it, I can do a DHCP request successfully -- but it show up as being in monitor mode. Just a quirk but it might bug future new users.

Thanks again for the continuing support.

Link to comment
Share on other sites

This may have been answered already. I'm a No0B at this, I just got it. I'm still not 100% sure what the wifi manager is supposed to do besides connect my mac through ICS.

So, following your instructions, I accidentally removed one of the physical interfaces and now, when I click auto-detect, nothing shows up.

Link to comment
Share on other sites

I don't have internet with tethernet so I want to manually download the network manager to connect through wifi. How can I do that?

You have to install infusions through the pineapple bar to avoid problems and issues not related to the infusions itself.

This may have been answered already. I'm a No0B at this, I just got it. I'm still not 100% sure what the wifi manager is supposed to do besides connect my mac through ICS.

So, following your instructions, I accidentally removed one of the physical interfaces and now, when I click auto-detect, nothing shows up.

I suggest that you re-flash your pineapple to get the initial configuration. I will add a confirmation message in the next version ;)

Link to comment
Share on other sites

Could you please send the content of /etc/config/wireless ?

I can't make the wifi usbcard turn into an access point....
config wifi-device radio0
option type mac80211
option channel 11
option hwmode 11ng
option macaddr 00:c0:ca:68:d0:06
option htmode HT20
list ht_capab SHORT-GI-20
list ht_capab SHORT-GI-40
list ht_capab RX-STBC1
list ht_capab DSSS_CCK-40
# REMOVE THIS LINE TO ENABLE WIFI:
# option disabled 1
config wifi-iface
option device radio0
option network lan
option mode ap
option ssid "pineapple da:9d"
option encryption none
config wifi-device radio1
option type mac80211
option channel 11
option hwmode 11ng
option macaddr 00:c0:ca:71:da:9d
option htmode HT20
list ht_capab SHORT-GI-20
list ht_capab SHORT-GI-40
list ht_capab RX-STBC1
list ht_capab DSSS_CCK-40
# REMOVE THIS LINE TO ENABLE WIFI:
# option disabled 1
config wifi-iface
option device radio1
option network lan
option mode ap
option ssid "pineapple da:9d"
option encryption none
Edited by janekong
Link to comment
Share on other sites

ALFA USB WiFi adapter not working as access point. Tried to turn it into an access point using the network manager infusion...

Did not work! How do i fix this?

How can i be sure the wifi adapter is not broken? The blue light is still working and wlan1 does show up in the network manager.

Edited by janekong
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...