Jump to content

WiFi Manager


Whistle Master
 Share

Recommended Posts

Screenshotfrom2013-05-1720_24_00.png
My Pineapple ifconfig settings:

config wifi-device 'radio0'
option type 'mac80211'
option hwmode '11ng'
option macaddr '11:22:33:44:55:66'
option htmode 'HT20'
list ht_capab 'SHORT-GI-20'
list ht_capab 'SHORT-GI-40'
list ht_capab 'RX-STBC1'
list ht_capab 'DSSS_CCK-40'
option disabled '0'
option channel '1'

config wifi-iface
option device 'radio0'
option network 'lan'
option mode 'ap'
option ssid 'theredpill'
option hidden '0'

config wifi-device 'radio1'
option type 'mac80211'
option channel '11'
option hwmode '11g'
option macaddr '00:11:22:33:44:55'
option disabled '0'

config wifi-iface
option device 'radio1'
option ssid 'Pineapple'
option mode 'ap'
option network 'lan'
option hidden '0'

Link to comment
Share on other sites

  • Replies 255
  • Created
  • Last Reply

Top Posters In This Topic

deathdealerxx, u don't have trouble getting Network Manager to recognize ur radio when u have ur macaddr set like that in the config file? I started using the option phy because everytime i changed my mac it broke Network Manager.

Link to comment
Share on other sites

O ok. Well in that case u should look at the config i posted last night. putting 'option phy phyX' in place of 'option macaddr' and then putting 'option macaddr (spoofedmac)' at the end of the section works great for me!

Link to comment
Share on other sites

19:21:45 Pineapple kern.info kernel: [ 5913.870000] br-lan: port 1(eth0) entered forwarding state
19:21:43 Pineapple kern.info kernel: [ 5911.870000] eth0: link up (1000Mbps/Full duplex)
19:21:43 Pineapple kern.info kernel: [ 5911.870000] br-lan: port 1(eth0) entered forwarding state
19:21:43 Pineapple kern.info kernel: [ 5911.870000] br-lan: port 1(eth0) entered forwarding state
19:21:41 Pineapple kern.info kernel: [ 5909.870000] eth0: link down
19:21:41 Pineapple kern.info kernel: [ 5909.870000] br-lan: port 1(eth0) entered disabled state
19:21:12 Pineapple kern.info kernel: [ 5880.710000] br-lan: port 1(eth0) entered forwarding state
19:21:10 Pineapple kern.info kernel: [ 5878.710000] eth0: link up (1000Mbps/Full duplex)
19:21:10 Pineapple kern.info kernel: [ 5878.710000] br-lan: port 1(eth0) entered forwarding state
19:21:10 Pineapple kern.info kernel: [ 5878.710000] br-lan: port 1(eth0) entered forwarding state
19:21:08 Pineapple kern.info kernel: [ 5877.210000] eth0: link down
19:21:08 Pineapple kern.info kernel: [ 5877.210000] br-lan: port 1(eth0) entered disabled state
19:20:34 Pineapple kern.info kernel: [ 5843.210000] br-lan: port 1(eth0) entered forwarding state
19:20:32 Pineapple kern.info kernel: [ 5841.210000] eth0: link up (1000Mbps/Full duplex)
19:20:32 Pineapple kern.info kernel: [ 5841.210000] br-lan: port 1(eth0) entered forwarding state
19:20:32 Pineapple kern.info kernel: [ 5841.210000] br-lan: port 1(eth0) entered forwarding state
19:20:30 Pineapple kern.info kernel: [ 5839.210000] eth0: link down
19:20:30 Pineapple kern.info kernel: [ 5839.210000] br-lan: port 1(eth0) entered disabled state

When i click [DHCP Request] :

19:23:09 Pineapple kern.info kernel: [ 5997.870000] br-lan: port 1(eth0) entered forwarding state
19:23:07 Pineapple kern.info kernel: [ 5995.870000] eth0: link up (1000Mbps/Full duplex)
19:23:07 Pineapple kern.info kernel: [ 5995.870000] br-lan: port 1(eth0) entered forwarding state
19:23:07 Pineapple kern.info kernel: [ 5995.870000] br-lan: port 1(eth0) entered forwarding state
19:23:05 Pineapple kern.info kernel: [ 5993.870000] eth0: link down
19:23:05 Pineapple kern.info kernel: [ 5993.870000] br-lan: port 1(eth0) entered disabled state

Edited by PcZerokey
Link to comment
Share on other sites

It seems like you're not associated at all with your internet connection. I don't know if you setup your wireless config file like i said last night but if u did it should be solvable in Network Manager. Under the wlan iface you're trying to use click next to SSID where it says [Avaliable AP], Click on the AP you want, Choose the security/encryption the router uses from the dropdown menu, type in the key, then scroll up and click Save, and then Commit. Then do

killall hostapd && ifconfig wlan 2 down && ifconfig wlan1 down && ifconfig wlan0 down

sleep 6

wifi

sleep 6

udhcpc -i wlanX # X being 0, 1, or 2. Whichever radio ur using to connect to the internet

If it doesn't work reboot. If it still doesn't work it'll be easier to just reflash and start from scratch. Just save ur /etc/config/wireless file on ur pc or usb and copy it back over after ur flash.

(You can just copy and paste that string of commands into the Advanced tab. Just change wlanX to wlan0 or wlan1 or wlan2)

Link to comment
Share on other sites

i reset it and my etc/config/wireless is

config wifi-device 'radio0'
option type 'mac80211'
option channel '11'
option hwmode '11ng'
option macaddr '00:c0:ca:61:13:f2'
option htmode 'HT20'
list ht_capab 'SHORT-GI-20'
list ht_capab 'SHORT-GI-40'
list ht_capab 'RX-STBC1'
list ht_capab 'DSSS_CCK-40'
option disabled '0'
config wifi-iface
option device 'radio0'
option network 'lan'
option mode 'ap'
option ssid 'pineapple 01:e7'
option hidden '0'
config wifi-device 'radio1'
option type 'mac80211'
option channel '11'
option hwmode '11g'
option macaddr '00:c0:ca:62:01:e7'
option disabled '0'
config wifi-iface
option device 'radio1'
option network 'lan'
option hidden '0'
option ssid 'Wifi'
option mode 'sta'
Link to comment
Share on other sites

Two suggestions for you PcZerokey:

First, don't forget that the Network Manager infusion does not automatically setup ICS once the wlan devices are hooked up correctly. Once you have them setup you'll need to connect them together using the ICS tab in the Network Manager infusion. I'm probably stating the obvious but it might help somone else.

Second, I had similar issues in attempting what you are trying to do. I would set the other AWUS i had plugged into the pineapple to connect to an access point but it just wouldn't give me an IP address. But it had given me one when I tried it before... So I turned off MAC address filtering on the AP and I ended up switching the Network over to nonsecured. With those settings I was able to make it work. Once that was complete I turned on the Security and it worked.

Link to comment
Share on other sites

Hi all,
I just received my Pineapple and I am trying to get Wi-Fi relay to work through Network Manager. Basically, I can't get wlan1 to associate and
get an IP address. Clicking on the [DHCP Request] link results in nothing happening, at least as far as the UI is concerned.
I cannot, for the life of me, figure out what I am doing wrong. If someone can have a look at my config and help me out, I'd much appreciate it.
And if there are any additional files/logs/config I should include, please let me know!
Thanks!
# Specs
Pineapple Mark IV v2.8.1
Network Manager 1.9
Alfa AWUS036NHA USB Adapter
Screen%20Shot%202013-05-27%20at%201.55.5
Screen%20Shot%202013-05-27%20at%202.01.2

# /etc/wireless/config
config wifi-device 'radio0'
option type 'mac80211'
option channel '11'
option hwmode '11ng'
option macaddr '00:00:00:00:00:00'
option htmode 'HT20'
list ht_capab 'SHORT-GI-20'
list ht_capab 'SHORT-GI-40'
list ht_capab 'RX-STBC1'
list ht_capab 'DSSS_CCK-40'
option disabled '0'
config wifi-iface 'wlan0'
option device 'radio0'
option mode 'ap'
option ssid 'Brownie'
option hidden '0'
option network 'lan'
config wifi-device 'radio1'
option type 'mac80211'
option channel '11'
option hwmode '11ng'
option macaddr '00:00:00:00:00:00'
option htmode 'HT20'
list ht_capab 'SHORT-GI-20'
list ht_capab 'SHORT-GI-40'
list ht_capab 'RX-STBC1'
list ht_capab 'DSSS_CCK-40'
option disabled '0'
config wifi-iface 'wlan1'
option device 'radio1'
option mode 'sta'
option ssid 'mynetwork'
option network 'wan'
option hidden '0'
# ifconfig -a
root@Pineapple:/pineapple# ifconfig -a
br-lan Link encap:Ethernet HWaddr 00:00:00:00:00:00
inet addr:172.16.42.1 Bcast:172.16.42.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:2004 errors:0 dropped:52 overruns:0 frame:0
TX packets:823 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:237283 (231.7 KiB) TX bytes:259286 (253.2 KiB)
eth0 Link encap:Ethernet HWaddr 00:00:00:00:00:00
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
Interrupt:5
eth1 Link encap:Ethernet HWaddr 00:00:00:00:00:00
inet addr:192.168.1.6 Bcast:192.168.1.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:4948 errors:0 dropped:118 overruns:0 frame:0
TX packets:3893 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:633390 (618.5 KiB) TX bytes:953623 (931.2 KiB)
Interrupt:4
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:41 errors:0 dropped:0 overruns:0 frame:0
TX packets:41 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:3538 (3.4 KiB) TX bytes:3538 (3.4 KiB)
wlan0 Link encap:Ethernet HWaddr 00:00:00:00:00:00
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
wlan1 Link encap:Ethernet HWaddr 00:00:00:00:00:00
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
# iwconfig
lo no wireless extensions.
wlan1 IEEE 802.11bgn ESSID:off/any
Mode:Managed Access Point: Not-Associated Tx-Power=20 dBm
RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
eth1 no wireless extensions.
wlan0 IEEE 802.11bgn Mode:Master Tx-Power=18 dBm
RTS thr:off Fragment thr:off
Power Management:on
eth0 no wireless extensions.
br-lan no wireless extensions.
Edited by Mr-Protocol
Spoiler Tags
Link to comment
Share on other sites

  • 3 weeks later...

WHY would you post this and NOT provide a download link? Am I missing something here? Your screen grabs are not linked to any downloads. Do I need to read through every post to see if someone else has provide the link? Or instructions to download your network manager module?

<<<a network manager for our pineapple>>>

Link to comment
Share on other sites

WHY would you post this and NOT provide a download link? Am I missing something here? Your screen grabs are not linked to any downloads. Do I need to read through every post to see if someone else has provide the link? Or instructions to download your network manager module?

<<<a network manager for our pineapple>>>

Because you don't download them yourself but rather go through the Pineapple bar directly on your pineapple.

Once there, you can see a list of available modules and download / install them.

A full list of all available infusions can be found here.

Link to comment
Share on other sites

SURE This sounds GREAT! So where are the instructions on how it works?

I've played with it for 2 days and got nothing. I'm giving up on guessing how it works!

<<<<This module give the ability to manage all wifi interfaces (e.g. connect to hotspot), internet sharing, etc.>>>

Link to comment
Share on other sites

  • 2 weeks later...

Hey Guys,

This is very silly, but I can not get the Network Manager 1.9 Infusion to work, which seem very straightforward. So what I want is not to bother with CAT5 and to say connect to my home WIFI with wifi1 and turn the Karma on wifi0.

I've got Mark IV with 2.8.1 - cache cleared and factory reset.

Pineapple automaticly wants to use my external wifi1 as AP with "pineapple 05:02".

I've adjusted the wlan1 to my WIFI settings.

Capture1.JPG

I hit [DHCP Request] . Its trying to get IP but how do I tell if it worked or not? Nothing on the page changes.

My ICS settings set too.

Capture3.JPG

When I try to add the in built wifi0 by hitting enable in Logical Interfaces, it doesn't come up and if I hit it too many times in a raw the "wlan0 disabled [Enable]" disappears and I have to refresh the page. Or is the Physical Interface radio0 [-] - HWAddr [00:0f:04:b2:48:a1] Pineapple's in built wifi? Either way "pineapple 05:02" SSID disappears , and If I unplug CAT5 I cant get to http://172.16.42.1:1471 which I assume means [DHCP Request] didnt work.

What am I missing? Is there another, way to go about this? What shoudl my /etc/config/wireless look like :/

Thanks :)

Edited by xXNirvashXx
Link to comment
Share on other sites

Hi Whistle Master,

I have experienced two issues with your network manager infusion. First, when I view all available APs, full strength says 70%. I believe this is because iwlist shows signal quality out of 70 and not 100. In my script I used expr "$QUALITY" \* 100 / 70 to get the percentage out of 100. Second I found that for some reason trying to release an IP address does not work. These aren't a big deal but I thought I would bring them to your attention.

Keep up the great work!

-SymPak

Link to comment
Share on other sites

Try booting up your pineapple without the external wifi plugged in... Then hook it up and change your settings. Also it may be obvious but you'll need to whitelist your devices that shouldn't be getting Karma'd.

Link to comment
Share on other sites

SURE This sounds GREAT! So where are the instructions on how it works?

I've played with it for 2 days and got nothing. I'm giving up on guessing how it works!

<<<<This module give the ability to manage all wifi interfaces (e.g. connect to hotspot), internet sharing, etc.>>>

It is GREAT!. The module is fairly easy to use. Just open your eyes and i'm sure you'll figure it out.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...