Jump to content

WiFi Manager


Whistle Master
 Share

Recommended Posts

  • Replies 255
  • Created
  • Last Reply

Top Posters In This Topic

I'm having some trouble. I am using networkmanager v1.9 and the pineapple is on 2.8.0.

Everything for client mode is setup and I do a save and commit. But once I try to do a DHCP Request nothing happens. I have tried with an open, wep, and wpa network.

When I do a "iwconfig wlan1" it says the adapter is still in managed access point mode but networkmanager after a auto-detect still is showing that it is in client mode.

Any help would be greatly appreciated.

Link to comment
Share on other sites

Thanks SymPak for the reply.

I have checked my log. It is showing nothing. It is not even showing that there were changes to the interface. I have even tried reflashing and reinstalling network manager.

I have also tried installing networkmanager on internal storage and USB. Doesn't seem to make a difference either way.

Is there any other way to set the adapter in client mode? possibly some commands?

Or should I still try 2.8.1 open beta 2?

Link to comment
Share on other sites

Upgrade to 2.8.1, which is now out of beta! If your still having problems try these commands:

uci set wireless.@wifi-iface[1].ssid="Your SSID"
uci set wireless.@wifi-device[1].channel="Your channel"
uci set wireless.@wifi-iface[1].network=wan
uci set wireless.@wifi-iface[1].mode=sta
uci commit wireless
wifi

udhcpc -i wlan1

Note, this is for open wifi.

Hope this helps

Link to comment
Share on other sites

If all those uci commands are tough to remember, just ssh/scp into /etc/config/ and open up the "wireless" file. That's the config file that all those uci commands are being sent to.

I keep

"killall hostapd && ifconfig wlan1 down && ifconfig wlan0 down"

"sleep 6"

"wifi"

without the ""s in my WPS button script to reload my wifi interfaces after i edit my configs

u can always add

"sleep 6"

"udhcpc -i wlan1" or "udhcpc -i wlan0"

at the end if you don't use a static ip

Link to comment
Share on other sites

You should SSH or SCP in and go to /etc/config/ and open ur wireless file.

First section should begin with "config wifi-device 'radio0'"

Second section should begin with "config wifi-iface 'wlan0'"

"option device 'radio0'"

Third should begin with "config wifi-device 'radio1'"

Fourth should begin with "config wifi-iface 'wlan1'
"option device 'radio1'"

I don't know where that 3rd radio (radio2) is coming from. I usually share "wlan1" to "wlan0". I don't know which is right. My setup works great for me though

Edited by kpoeticg
Link to comment
Share on other sites

Oh. In that case all the details or the correct details for it might be missing from your wireless file. Sometimes Network Manager has issues setting up ur external adapters and u need to set it up urself in the config file to get the Infusion to recognize it properly.

Link to comment
Share on other sites

Execute: ifconfig
br-lan Link encap:Ethernet HWaddr 00:C0:CA:61:13:F1
inet addr:172.16.42.1 Bcast:172.16.42.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:48728 errors:0 dropped:10817 overruns:0 frame:0
TX packets:19896 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:21381882 (20.3 MiB) TX bytes:4281681 (4.0 MiB)

eth0 Link encap:Ethernet HWaddr 00:C0:CA:61:13:F1
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:88833 errors:0 dropped:0 overruns:0 frame:0
TX packets:58185 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:79156928 (75.4 MiB) TX bytes:8626441 (8.2 MiB)
Interrupt:5

eth1 Link encap:Ethernet HWaddr 00:C0:CA:61:13:F0
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
Interrupt:4

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:603 errors:0 dropped:0 overruns:0 frame:0
TX packets:603 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:50799 (49.6 KiB) TX bytes:50799 (49.6 KiB)

wlan1 Link encap:Ethernet HWaddr 00:C0:CA:61:13:F2
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:48197 errors:0 dropped:0 overruns:0 frame:0
TX packets:77309 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:6752373 (6.4 MiB) TX bytes:71076681 (67.7 MiB)

Edited by PcZerokey
Link to comment
Share on other sites

I said to go into /etc/config and open ur wireless file. Not bash the /etc/config folder =]. /etc/config/wireless is the file that handles ur wireless radios

cd /etc/config

nano wireless

although it's easier to scp in with WinSCP and just double click the file. That way it opens it like a normal txt document

Edited by kpoeticg
Link to comment
Share on other sites

config wifi-device 'radio0'

option type 'mac80211'

option channel '11'

option hwmode '11ng'

option macaddr '00:c0:ca:61:13:f2'

option htmode 'HT20'

list ht_capab 'SHORT-GI-20'

list ht_capab 'SHORT-GI-40'

list ht_capab 'RX-STBC1'

list ht_capab 'DSSS_CCK-40'

option disabled '0'


config wifi-iface

option device 'radio0'

option network 'lan'

option mode 'ap'

option ssid 'NAME'

option hidden '0'

.... ok now what
Link to comment
Share on other sites

where it says " config wifi-iface " change it to " config wifi-iface 'wlan0' " That will make a complete section for just your internal radio. You need to make a radio1/wlan1 section for ur 2nd and a radio2/wlan2 section for ur third.

I personally find if u replace all the "option macaddr" with " option phy 'phy0' " or "option phy 'phy1' " or option phy 'phy2' " then put "option macaddr" underneath where it says "option disable '0' " it makes it alot easier for the purposes of being able to change ur macs and the system still recognizing your radio by the phy option. Hold on I'll give u an example of what my wireless file looks like...

Link to comment
Share on other sites

Here is my /etc/config/wireless file


config wifi-device 'radio0'
option type 'mac80211'
option channel '11'
option hwmode '11ng'
option phy 'phy0'
option htmode 'HT20'
list ht_capab 'SHORT-GI-20'
list ht_capab 'SHORT-GI-40'
list ht_capab 'RX-STBC1'
list ht_capab 'DSSS_CCK-40'
option disabled '0'
option macaddr '00:11:22:33:44:55'

config wifi-iface 'wlan0'
option device 'radio0'
option network 'lan'
option mode 'ap'
option ssid 'AndroidAP'
option hidden '0'

config wifi-device 'radio1'
option type 'mac80211'
option channel '11'
option hwmode '11ng'
option phy 'phy1'
option htmode 'HT20'
list ht_capab 'SHORT-GI-20'
list ht_capab 'SHORT-GI-40'
list ht_capab 'RX-STBC1'
list ht_capab 'DSSS_CCK-40'
option disabled '0'
option macaddr '66:55:44:33:22:11''

config wifi-iface 'wlan1'
option device 'radio1'
option ssid 'H0m3WiFi'
option mode 'sta'
option network 'wan'
option hidden '0'
option key 'thisisthekey''
option encryption 'psk2+ccmp'

That's just for 2 radio's though. You'll need to duplicate for a third and change in the obvious places.

Link to comment
Share on other sites

So for your third radio you should copy the radio0 and wlan0 sections and paste them under the second radio.

Then go through and change radio0, phy0, wlan0, and radio0 to radio2, phy2, wlan2, radio2. Then give it it's own macaddr. Then change AndroidAP to it's own AP name. After all that make sure u make a backup of ur new wireless file. Then reinstall Network Manager and it should register everything succesfully. If not u might just need to reboot. Then make sure u "ifconfig wlan1 up && ifconfig wlan2 up" and then try opening Network Manager again

Hope this solves ur issue...

Link to comment
Share on other sites

Well i made it a little more complicated than it had to be by trying to explain it before i pasted my config. =P

If u just copy my wireless file and paste it in yours, then follow the post i wrote after it u should be good to go.

U should definitely take my advice on keeping a couple backup copies around. They come in real handy when u need to configure ur wireless setup.

And u can change those mac addresses to anything u want as long as u keep the phy option where i showed u.

Edited by kpoeticg
Link to comment
Share on other sites

ik how to change mac addressed but i dont think the file is the problem , i dont know if anyone checked the pictures i provided if i set any options wrong like the ICS tab , all im trying to do is have the wifipineapple with internet so i dont have to keep the ethernet cable connected to my computer for internet sharing

Link to comment
Share on other sites

Yeah i replied to that too. The wireless file is why the top of that picture is all messed up. I don't know how to get ur ICS set correctly if ur wireless radio's aren't setup first...

It should look something like

Physical Interfaces

radio0 wlan0 Enabled [Random Mac]

radio1 wlan1 Enabled [Random Mac]

radio2 wlan2 Enabled [Random Mac]

Logical Interfaces

wlan0 Enabled [Disable]

wlan1 Enabled [Disable] [DHCP Release]

wlan2 Enabled [Disable]

Then set ur ICS to share from wlan1 to "" (i use wlan0)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...