Jump to content

Recommended Posts

Nope. Logs are saved in the infusion folder directly. No symbolic links. For bully, session run are saved by bully itself in /root/.bully but this is bully mechanism to be able to restaure previous sessions. This is managed by the binary, not by the infusion itself.

Did you format the SD card with the pineapple ?

To be honest I don't understand your issue... I tried again today to play around with the infusion, the logs and I don't have any issue. Could you please post a screenshot and more precise description of what you are doing and what you get ?

Edited by Whistle Master
Link to comment
Share on other sites

  • Replies 436
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Posted Images

Hi buddy

Thanks for the update, i have bought a new SD card and formatted it using my pinapple, Reaver loads the logs fine as you can see in the pictures, bully will not get past 63.5KB or 64.00KB

http://share.pho.to/5J0sN

I load WPS scan for the AP disable wlan1 start monitor mode put the settings -v 3 chose mon0 and make sure autorefresh is @ 1sec and on it then runs for a bit then wont get any further.

Bully also says loading interface and at the bottom there is a X and it wont let you view the log as shown in the picture

Reaver on the other hand works 100% just not Bully

im currentley pulling my hair out with this issue lol

Regards

Raz0r

Edited by raz0r
Link to comment
Share on other sites

Hi

thesugarat

yea seams to work just fine if i ssh into it, problem is i need it to be runnning it when im not in the office, iv tried flashing it bought a new SD card but still no luck i know you can use Screen to resume the session but thats not what i want :( any way hope this gets sorted soon as Bully seams to do a much better job.

many thanks

Raz0r

Link to comment
Share on other sites

Hey

Its version 1.3.0 Firmware

Bully 1.0-22

Reaver r113-1

Also checked to make sure all the dependicies were there to one of which wasnt i was hopeing that would sort the issue but it didnt.

What im gonna do is get SSH sorted then ill send you the ip maybe if you have time you could take a look. ?

Kind Regards

Raz0r

Link to comment
Share on other sites

Well, I think I found the issue: this is due to the way I capture bully's output to redirect it to the file. Bully, unfortunately, uses block-buffering to output information (to stdout or with the -o option). This means that no data is output or redirect to a file until the process has terminated. I'm therefore using a trick to have bully output in "real time" in the infusion and also have it stored in a file.

But it seems that the method I'm using is blocked after reaching 64Ko... I have to figure out another way to capture bully output in real time and will fix the infusion.

Link to comment
Share on other sites

Whistle Master

You are a legend, many thanks for this m8 i really appreciate this like BIG time fella, thanks sooo much for taken the time to look at this buddy.

This is one of the reasons i bought my wifi pinapple as beaing able to deploy it somewhere and leave it :)

Thanks once again :)

Also in terminall just like in kali linux i have to press ctrl ^c x2 befor it saves the session this is what i was trying to look for in the source code

But i could not find the command like i said im rubbish in php but i do know a little perl and python , never have written my own code but i know what to look for im sorry i should have mentioned what i already found already

Kind Regards

Raz0r

Edited by raz0r
Link to comment
Share on other sites

  • 2 weeks later...

Just got my pineapple, updated to 1.3 and installed a few infusions (including WPS).

I've been having trouble within the WPS GUI (waits for beacons forever) so I dropped to console to start eliminating possibles and my trouble seems to be with something other than the GUI.

I have a wifi router setup as my target with WPS enabled.

First I down the interface (never works with it up and even through the GUI I have to manually down it).

After I start with airmon-ng:

airmon-ng start wlan0

Found 1 processes that could cause trouble.

If airodump-ng, aireplay-ng or airtun-ng stops working after

a short period of time, you may want to kill (some of) them!

PID Name

2936 root

Process with PID root ( PID USER VSZ STAT COMMAND

1 root 1524 S init

2 root 0 SW [kthreadd]

3 root 0 SW [ksoftirqd/0]

5 root 0 SW [kworker/u:0]

6 root 0 SW< [khelper]

61 root 0 SW [sync_supers]

63 root 0 SW [bdi-default]

65 root 0 SW< [kblockd]

94 root 0 SW [kswapd0]

143 root 0 SW [fsnotify_mark]

155 root 0 SW< [ath79-spi]

166 root 0 SW [mtdblock0]

171 root 0 SW [mtdblock1]

176 root 0 SW [mtdblock2]

181 root 0 SW [mtdblock3]

186 root 0 SW [mtdblock4]

191 root 0 SW [mtdblock5]

232 root 0 SW [kworker/0:1]

422 root 0 SWN [jffs2_gcd_mtd3]

424 root 0 SW [flush-mtd-unmap]

448 root 0 SW [khubd]

459 root 0 SW [scsi_eh_0]

460 root 0 SW [usb-storage]

461 root 0 SW [kworker/0:2]

462 root 0 SW [kworker/u:2]

481 root 1524 S init

516 root 0 SW< [cfg80211]

558 root 0 SW< [rpciod]

568 root 0 SW< [nfsiod]

660 root 1528 S /sbin/syslogd -C16

662 root 1512 S /sbin/klogd

664 root 860 S /sbin/hotplug2 --override --persistent --set-rules-f

676 root 876 S /sbin/ubusd

745 root 1856 S {mobile-keepaliv} /bin/bash /etc/pineapple/mobile-ke

860 root 1488 S /sbin/netifd

1269 root 0 SW [jbd2/sda1-8]

1270 root 0 SW< [ext4-dio-unwrit]

1376 root 1520 S /sbin/watchdog -t 5 /dev/watchdog

1549 root 0 SW [flush-8:0]

1634 nobody 788 S /usr/sbin/atd

1642 root 1536 S /usr/sbin/crond -c /etc/crontabs -l 5

1648 root 2864 S /usr/sbin/sshd

1671 root 1136 S /usr/sbin/uhttpd -f -h /www -r Pineapple -x /cgi-bin

1677 root 1160 S /usr/sbin/uhttpd -f -h /pineapple -r Pineapple -c /e

1715 nobody 956 S /usr/sbin/dnsmasq -C /var/etc/dnsmasq.conf

1731 root 1520 S /usr/sbin/ntpd -n -p 0.openwrt.pool.ntp.org -p 1.ope

2936 root 1624 S wpa_supplicant -B -P /var/run/wifi-wlan1.pid -D nl80

2963 root 1528 S udhcpc -p /var/run/udhcpc-wlan1.pid -s /lib/netifd/d

3647 root 5488 S {sshd} sshd: root@pts/0

3660 root 1524 S -ash

3692 root 1508 S sleep 10

3702 root 1540 S {airmon-ng} /bin/sh /usr/sbin/airmon-ng start wlan0

3703 root 0 SW [kworker/u:1]

3743 root 1516 R ps -o comm= -p root) is running on interface wlan1

Process with PID root ( PID USER VSZ STAT COMMAND

1 root 1524 S init

2 root 0 SW [kthreadd]

3 root 0 SW [ksoftirqd/0]

5 root 0 SW [kworker/u:0]

6 root 0 SW< [khelper]

61 root 0 SW [sync_supers]

63 root 0 SW [bdi-default]

65 root 0 SW< [kblockd]

94 root 0 SW [kswapd0]

143 root 0 SW [fsnotify_mark]

155 root 0 SW< [ath79-spi]

166 root 0 SW [mtdblock0]

171 root 0 SW [mtdblock1]

176 root 0 SW [mtdblock2]

181 root 0 SW [mtdblock3]

186 root 0 SW [mtdblock4]

191 root 0 SW [mtdblock5]

232 root 0 SW [kworker/0:1]

422 root 0 SWN [jffs2_gcd_mtd3]

424 root 0 SW [flush-mtd-unmap]

448 root 0 SW [khubd]

459 root 0 SW [scsi_eh_0]

460 root 0 SW [usb-storage]

461 root 0 SW [kworker/0:2]

462 root 0 SW [kworker/u:2]

481 root 1524 S init

516 root 0 SW< [cfg80211]

558 root 0 SW< [rpciod]

568 root 0 SW< [nfsiod]

660 root 1528 S /sbin/syslogd -C16

662 root 1512 S /sbin/klogd

664 root 860 S /sbin/hotplug2 --override --persistent --set-rules-f

676 root 876 S /sbin/ubusd

745 root 1856 S {mobile-keepaliv} /bin/bash /etc/pineapple/mobile-ke

860 root 1488 S /sbin/netifd

1269 root 0 SW [jbd2/sda1-8]

1270 root 0 SW< [ext4-dio-unwrit]

1376 root 1520 S /sbin/watchdog -t 5 /dev/watchdog

1549 root 0 SW [flush-8:0]

1634 nobody 788 S /usr/sbin/atd

1642 root 1536 S /usr/sbin/crond -c /etc/crontabs -l 5

1648 root 2864 S /usr/sbin/sshd

1671 root 1136 S /usr/sbin/uhttpd -f -h /www -r Pineapple -x /cgi-bin

1677 root 1160 S /usr/sbin/uhttpd -f -h /pineapple -r Pineapple -c /e

1715 nobody 956 S /usr/sbin/dnsmasq -C /var/etc/dnsmasq.conf

1731 root 1520 S /usr/sbin/ntpd -n -p 0.openwrt.pool.ntp.org -p 1.ope

2936 root 1624 S wpa_supplicant -B -P /var/run/wifi-wlan1.pid -D nl80

2963 root 1528 S udhcpc -p /var/run/udhcpc-wlan1.pid -s /lib/netifd/d

3647 root 5488 S {sshd} sshd: root@pts/0

3660 root 1524 S -ash

3692 root 1508 S sleep 10

3702 root 1552 S {airmon-ng} /bin/sh /usr/sbin/airmon-ng start wlan0

3703 root 0 SW [kworker/u:1]

3744 root 1516 R ps -o comm= -p root) is running on interface wlan1

Interface Chipset Driver

wlan1 RTL8187 rtl8187 - [phy1]

wlan0 Atheros ath9k - [phy0]

(monitor mode enabled on mon0)

Many other things seem to work on mon0.

When I run reaver, its failing badly:

root@Pineapple:~# reaver -i mon0 -b C0:C1:C0:8F:E0:91 -c 6 -vv

Reaver v1.4 WiFi Protected Setup Attack Tool

Copyright © 2011, Tactical Network Solutions, Craig Heffner <cheffner@tacnetsol.com>

[+] Switching mon0 to channel 6

[+] Waiting for beacon from C0:C1:C0:8F:E0:91

[+] Associated with C0:C1:C0:8F:E0:91 (ESSID: SPickens)

[+] Trying pin 12345670

[+] Sending EAPOL START request

[+] Received identity request

[+] Sending identity response

[+] Received identity request

[+] Sending identity response

[+] Received identity request

[+] Sending identity response

[!] WARNING: Receive timeout occurred

[+] Sending WSC NACK

[!] WPS transaction failed (code: 0x02), re-trying last pin

[+] Trying pin 12345670

[+] Sending EAPOL START request

[+] Received identity request

[+] Sending identity response

[+] Received M1 message

[+] Sending M2 message

[+] Received M1 message

[+] Sending WSC NACK

[+] Sending WSC NACK

[!] WPS transaction failed (code: 0x03), re-trying last pin

[+] Trying pin 12345670

[+] Sending EAPOL START request

[+] Received identity request

[+] Sending identity response

[+] Received identity request

[+] Sending identity response

[+] Received identity request

[+] Sending identity response

[!] WARNING: Receive timeout occurred

[+] Sending WSC NACK

[!] WPS transaction failed (code: 0x02), re-trying last pin

[+] Trying pin 12345670

[+] Sending EAPOL START request

[+] Received identity request

[+] Sending identity response

[+] Received identity request

[+] Sending identity response

[+] Received identity request

[+] Sending identity response

[+] Received identity request

[+] Sending identity response

[+] Received identity request

[+] Sending identity response

[+] Received identity request

[+] Sending identity response

^C

[+] Nothing done, nothing to save.

It will just do that forever if I'd let it. Sometimes, like 1 in 100, it will make it to M3/4 but still fails.

The pineapple and the target router are separated by about 18-20 feet. I have no trouble with brute forcing this router with a crumby USB wifi stick and kali in a VMware session except the occasional dropping of the mon0 interface, but it shows no WPS transactions failing until it abruptly stops with the mon0 interface.

I have yet to get a single successful WPS transaction... What am I missing?

Link to comment
Share on other sites

Also, that PID that it calls out 2936 is the wpa supplicant on wlan1. Which means your Client Mode is probably active or was and that PID will definitely interfere with reaver. It is very picky on the PIDS that are running. If airmon-ng recommends shutting it off I usually do when using a Kali machine, on the pineapple I'm a little more cautious on what I shut down but that wpa supplicant I would definitely kill.

Link to comment
Share on other sites

Sorry, didn't mean to imply it wouldn't work at all on wlan0. If you use wlan0 you can't logon to the pineapple's Access Point that runs on wlan0. You can certainly use wlan0 with a few tweaks as long as you are using the eth0 port. Same thing about killing pids applies though...

Link to comment
Share on other sites

you could add a usb wifi to make wlan2. if it can do moniter mode. that might help your dream

I have a RTL2870 based USB stick (works in kali) and RTL8188CUS based USB stick (not tried in kali). I have yet to get any of them to show up beyond an entry in lsusb until I get done with playing on the internal hardware.

Also have a Pantec UML290 USB 4G modem that I know took some real fandangling to get working with my BeagleBoard xM that is waiting for its chance at ifup. That will eventually be my "way in".

Thanks for the help everyone!

Link to comment
Share on other sites

Hey guys, just wanted test reaver on my own network, and got this :

http://gyazo.com/0d96b53bd19b0f19cdc65fb24ab21219

It is extremely slow, and only re-tries 1 pin

Whats am I doing wrong?

maybe I have connection problems? WEB UI said No internet connection, I dont know why because I have. When I try to reconnect,it says Warning: Channel conflict between WiFi Pineapple and selected network.

Infos with my connection:

I only have 1 ethernet slot on my computer , so the wifi pineapple connect to my pc via cat

my pc has internet via Wifi (ssid=deef45)

my pineapple client mode also connects to deef45

Is there anything wrong?

Please help! Thank you

Link to comment
Share on other sites

Well if your using wlan1 for reaver then you aren't using it for client mode....

Try connecting a device to control the Pineapple via the Pineapples wlan0 broadcasted AP. Then use wlan1 for reaver... I'm not saying you can't connect to it using eth0 but why would you if wlan0 is already there?

Link to comment
Share on other sites

Hey guys, just wanted test reaver on my own network, and got this :

http://gyazo.com/0d96b53bd19b0f19cdc65fb24ab21219

It is extremely slow, and only re-tries 1 pin

Whats am I doing wrong?

maybe I have connection problems? WEB UI said No internet connection, I dont know why because I have. When I try to reconnect,it says Warning: Channel conflict between WiFi Pineapple and selected network.

Infos with my connection:

I only have 1 ethernet slot on my computer , so the wifi pineapple connect to my pc via cat

my pc has internet via Wifi (ssid=deef45)

my pineapple client mode also connects to deef45

Is there anything wrong?

Please help! Thank you

the red channel warning can be fixed in config infusion access point change channle so there is no conflict

to use reaver you dont need internet access

so if i understand right your running ics on your laptop giving your wireless on your laptop ics to eth0

at the same time your pineapple is getting net from eth0 and wlan1 i would suggest one or the other

try this boot pineapple connect to your pineapple ap goto network disconnect then goto wps and try reaver wlan1 to mon0

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.

×
×
  • Create New...