Jump to content

Mk3: Atheros Based Files To Flash

Recommended Posts


Thank you.

It is strange that you were not successful on flashing 1.9 to your router at first. Glad that you got it working.

The "stock" webinterface, I am guessing you mean LuCI. If you wan't to install that you can by simply downloading the package using opkg install <package name>.

I do not recommend doing that though as it is rather large and you may loose space you want for other things.

About ssh over private key, I am sure you can find tutorials on how to do it on dropbear. I will take a look and post back later.

Regarding the LED, I currently do not support USB, but it is something which I am working on. Once I finish the led will work correctly. Sorry about that.

You do not need those packages. The 1.9 firmware includes everything you need for the pineapple.

About that error message, I intentionally kept it .html instead of .php as people got confused because they turned on DNS spoof and said that they keep getting sent back to nowhere.

I have changed this in the upcoming 2.0 release. To make it work you simply need to change the .html to .php.



Link to comment
Share on other sites

  • Replies 164
  • Created
  • Last Reply

Top Posters In This Topic

Well i think something is not working as intended.

As I have a 2202 Fonera there is a wan port which is connected to my local networks router to provide internet access.

Br-lan is set to statically and wan port uses dhcp, it gets ip from my local network.

Dhcp is configured to provide gw @ as this is my routers ip.

If a client connects dhcp provides all needed addresses incl. gw, dns and netmask but internet connection is not working,

when using wlan or eth port on my fon. maybe a routing table problem?

In fw-standard setting the gw is in the same network as the 2202's primary ip (gw / eth

So i thought it should be possible to adapt these settings to suit my local network. (0.0) but this is not working either,

Any ideas Guys?

Link to comment
Share on other sites

Something Offtopic > where is the edit button for my posts? *confused*

Ok back to Topic

@sebkinne: Thanks for your answer, the available space may be a problem, so i understand your point regarding to the original webif.

The question about the packages is now clear too, it was intended for ppl who just want to install the packages without reflashing, right?

Now i have to investigate why the internet connection isn't routed correctly to the clients. the spoofing attempt works when plugging a client

in the eth jack or by connecting directly to the "internet" essid, but currently it looks like karma is NOT associating a wireless client correctly,

there are some association entries but they are cleared after a few secs.

I'm short before starting over again...

thx & cheers phk

Edited by 0xPHK
Link to comment
Share on other sites

After some further investigation I'm still not able to get Internet working over lan & wlan.

Maybe the WAN port must be added to the br-lan bridge as the 2100 and other devices only have one eth-port?

Currently the following 2 interfaces are bridged - eth0.1 (computer-eth-jack) & wlan per default.

As Karma fails to associate probing clients (in this case my last known ap's radio is still on),

I think the last known ap is a little bit faster answering the probing requests, than my pineapple?

Will try disabling my ap tonight to see if this works.

cheers phk

Link to comment
Share on other sites

Looks like I'm a few steps further into getting things running...

My current status:

disabled the wan port to "emulate" a mesh/ap51/2100 with just one eth port - internet, spoofing and url snarf works as well as ngrep.

only karma won't work as it should be. in the control centers status window association switchtes from enabled to empty,

ss well as showing some association info (passing through...) - but but switches after ~10secs to empty and vice versa.

the association log shows associated clients even if karma is not enabled ?!? enabling/disabling doesn't seem to make a difference,

so i think something is still screwed up.

BTW: ngrep causes the 2202 to reboot after aprox. 30-40secs

Maybe Darren, Sebastian or someone else could please help troubleshooting my issues?

Is there a mk3 user running it stable on a 2202?

Usb for logs & paylods and second eth-port would extend the possibilities of the pineapple a lot.

One jack in, one jack out - no karma though, but still suitable for mitm using spoof and snarf features.

sorry for spamming this thread but can't edit existing posts - dunno why (EDIT 5 posts rule)

cheers phk

Edited by 0xPHK
Link to comment
Share on other sites

First of all thanks for providing the files to flash the Atheros based devices.

I did that with my old Fonera 2100 with its only 16MB flash.

I did no really test with clients etc. for now i just wanted it to boot and look at the admin interface.

The problem i have that it is instantly rebooting when firing up URLsnarf, this could be a problem because of the low amount of RAM.

I watch it via a SSH Sessing, after boot there is only approx 1400kb RAM free, after starting Karma i hav approx. 700kb free.

Funny when i now start ngrep it free's me up some RAM, after ngreps start i got 1400kb free.

When i start URLSnarf, boom reboot. Also when i start URLSnarf alone after the reboot, the fon crashes.

No clue why.

Maybe i am brave enough to try a RAM upgrade on the little box, or an SD-Card Mod to give it a little bit Swap.

Nevertheless thanks for your work Sebkinne.

Link to comment
Share on other sites

Sorry for the short reply, did you say you made changes to the IP of the pineapple?

Well I have tested all the things that came up to my mind, including several IP changes.

I was using your IP range on my first attempts to get it running.

Currently my 2202 is configured @, spoofing lists were modified as well.

My major problem is getting Internet connection to work on Lan port and over Wlan,

the connection itself comes via Wan port from my local network router.

I want to get this running first before doing further investigation why karma is not running too.

My intention was to use my 2202 as generic wired mitm device between my router and and the switch

that serves all local network clients, to use the snarfing and spoofing capabilities.

Maybe I'm thinking into the wrong direction, please correct me if this theoretical scenario won't work at all.

Karma is primarily for mobile usage, but as there are wireless clients in my network and my neighbourhood too,

so a working Karma would more than just be nice.

EDIT: forgot to say private key auth works, dropbear expects authorized_keys in /etc/dropbear

Greetings from Germany


Edited by 0xPHK
Link to comment
Share on other sites

I am not sure if I understood correctly.

To make the pineapple work correctly, the interface of your computer ("facing" the pineapple) should have the IP

If that is the case and you run the wp3.sh script, everything should work.

If you want to change the IP range, there are numerous steps that you need to take first, but I don't see why you would.

Greetings from Munich,


Link to comment
Share on other sites

Maybe this idea is dumb, but sorry i am no Kernel hacker.

Would it be possible to use something like compcache to save valuable ram on the old fon's.

This was the reason of my decision to take a 2202 because of the 32MiB and the USB Port for extra storage,

but unfortunately it's not working yet as it should.

cheers phk

Edited by 0xPHK
Link to comment
Share on other sites

I recently saw an updated 2.01 firmware on wifipineapple.com

Is this a generic atheros based fw like the version on the first post or is this special for a MK3?

Tried flashing it to my 2202 but it hangs at redboot and won't boot up.

cheers phk

Link to comment
Share on other sites

I have also flashed a couple of the ALFA AP51's as well. I also have been having problems with URL Snarfer not listing anything on the STATUS page.

I am new to the Mark III, and have attempted to locate the problem, as of yet, to no avail.

The Mark III that I purchased from Hak5 initially did display data with regard to URL Snarfer, but that ceased shortly after the first or seccond session of running it under Backtrack 5 Rev 1, from a 32 gig flashdrive.

I don't know if my tweaking any settings caused this or not. Still attempting to resolve the problem.


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...