Jump to content

[Official] nmap

Whistle Master

Recommended Posts

  • 4 weeks later...

So here I was last night, after getting my new pineapple ( I was enjoying the new car feeling ) I decided to start loading modules. First one was wrote internally, including dependencies. Afterward I slapped in my 4 gig card and pulled for the remaining modules. 2nd, 3rd and 4th dependent files download was fine. Selected to write to Sd card, seemingly no problem. Then the remaining downloads would not. Am I doing something wrong?

Link to comment
Share on other sites


I have installed and executed the module, with the latest firmware (1.0.5). When executing it, after a while that it runs the page is cleared (only the Controls section is partially shown), the page is loaded again presumably when the execution finishes, and the output is cleared. I can find the report in /tmp/nmap.scan in the Nano, but I would show show in the interface also, or at least I would say where it can be found.

Link to comment
Share on other sites

nmap is literally the only module I cannot get to work correctly. I have the latest 1.0.5 firmware, installed the module to the SD card, then installed the dependencies to the SD card. When I try to start the module it just stops itself with no indicator as to why.

Any ideas on what I should do?

I already tried resetting the Nano back to factory, and formatted the SD card multiple times.

I would love to get nmap running. Should I have installed the module to internal, and the dependencies to SD, or both to SD?

Help/suggestions appreciated.

Link to comment
Share on other sites

The exact order in which I did things:

Factory reset Nano.

Format MicroSD card.

Firmware update to 1.0.5.

Insert MicroSD card.

Install nmap Module to SD card.

Open nmap Module.

Press the button to install dependencies to MicroSD card.

Press Start. Nothing.


Open module. Press start.

It says Starting... in yellow.

Then nothing. It just goes back to being green and saying Start. There is nothing in the history. It just says nmap is not running. I even tried uninstalling and reinstalling, and rebooting.

Link to comment
Share on other sites

Normally as soon as the scan is finished, the file is move to the scan folder and then you can view the scan in the history. What can happen, is that nmap crashed, causing the NANO to reboot.

Could you post here the full command that you used ?

Nevermind: now it seems to work. I just suppose that I had to restart the Nano.

Link to comment
Share on other sites

AeonDez, if you just start nmap without giving some options and targets, like the command line, nmap will simply not do nothing. It comes as lunching nmap that's it.

Therefore, you have to go in the sections below and give nmap some instructions such as a subnet to scan, etc.

In summary, this module is a GUI for nmap and you have to use it like you would use the command line version.

I will change the behavior in the next version to disable the Start button suntil people provide parameters.

Link to comment
Share on other sites


I realize now that the header titled options was expandable, and not just a header for output and history. It seems to be working fine. I had figured that it would give me the options after I pressed start.

I will go back to my corner now.

Thank you.

Link to comment
Share on other sites

  • 2 weeks later...

Hey WM, There is an issue where on the TETRA, you can choose to install the depends to the SD card, and when you choose to do so it tries to install then fails silently. Obviously you can't install to the SD card as the TETRA don't got one.

I don't know if this applies to the other modules you have (assuming they install dependencies the same way)

Edited by Foxtrot
Link to comment
Share on other sites

  • 1 month later...

hello, on the latest tetra firmware nmap always results in 'host down' no matter what I scan, not sure if it's a bug or I'm using it wrong. i may try terminal to check for nmap that way and see what results, but the host is still 'up' when the result gives me that message.

Link to comment
Share on other sites

  • 5 months later...
On 4/3/2016 at 3:14 AM, Whistle Master said:

The module is an interface for nmap. Try the command through SSH to see if you get the same results.

Late reply but i tried this and nmap states the host is down.

Process as follows:

Connect my phone to the TETRA Open AP and while it's connected, run nmap on the IP and hostname, both through SSH and the module. Device shows as connected through the Clients page the entire time. Maybe this isn't intended for devices connected, or I'm missing something?

Link to comment
Share on other sites

  • 2 months later...

I hate to dig up an old thread but i am having a similar issue. Almost all the other modules work perfectly except nmap. I delete and redownload to sd card, then install dependencies on sd card and it will have the green start bar but will not let me click on it. It just shows a red circle with a slash though it when i hover over start. I have performed the factory reset and attempted to install nmap with the old firmware and then reflashed with the new firmware and neither work. any idea what may be the cause? 

Link to comment
Share on other sites

  • 5 months later...

Trying to use nmap on a nano to map LAN when connected wifi in a captive portal config.  The initial wifi connection is open, and I have creds to give the captive portal web site, but I am not sure how to get to that point.  web/http traffic should be directed to the captive portal.  Suggestions?  A scan of the entire range without entering any creds yields nothing


Command:  nmap -sV -T4 -O -F --version-light -oN /tmp/nmap.scan

Link to comment
Share on other sites

  • 7 months later...

Missing frmware (2.0.0+) lib link for nmap to run.

nmap: can't load library 'libpcap.so.1.3'

Just run from terminal to fix

ln -s /usr/lib/libpcap.so.1 /usr/lib/libpcap.so.1.3

EDIT - If that does not work try -

I just reset mine a min ago using firmware recovery 2.0.2 on my nano and installed only the nmap module to sd - I found it was missing the link

ln -s /sd/usr/bin/nmap /usr/bin/nmap

Im going to try some things then will firmware recover my nano so will test again to see if its repeatable.

Edited by Just_a_User
  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...