Jump to content

[Official] nmap


Whistle Master
 Share

Recommended Posts

8 minutes ago, Just_a_User said:

try

opkg update && opkg install nmap --dest sd

I brought this up in the NANO section, but even after installing to the sd, ive found that via shell from the root directory you cant just call nmap without going to the directory and /sd/usr/xxx/./nmap and running it from where it was installed to.  how do we symlink or export the path to run it globally? 

Link to comment
Share on other sites

3 minutes ago, marbaa said:

done.

get the Message : "Package nmap (6.47-2) installed in sd is up to date."

reinstall the nmap Module , reboot Nano, same problem, "Start" is not available.

 

Humm maybe try

ln -s /usr/lib/libpcap.so /usr/lib/libpcap.so.1.3

and

mkdir /sd/pineapple/modules/nmap/scan

or is it /sd/modules/nmap/scan i forget and dont have my nano to hand...

Link to comment
Share on other sites

2 minutes ago, Just_a_User said:

it would be

ln -s /sd/usr/bin/nmap /usr/bin/nmap

i think

off topic but that worked for git, which is what ive had a problem with.  working on the same issue with installing .ipk to the nano sd.  going to give it a try also.  not to great with linux filesystems but been learning the last couple days   thank you sir!!

  • Like 1
Link to comment
Share on other sites

  • 4 months later...

I also have my problems installing nmap.

I'm on Nano-Firmware 2.4.2, made factory settings and installed nmap after setup and reinstalled dependencies. But the start button is not active (pale green).

Solution as described here:

1. SSH on Nano, on the command line nmap was not found, I set up the symbolic link to /sd/usr/bin/nmap

2. link to libpcap.so adapted: nmap works on the command line, but still not on the web interface.

3. Reboot Nano - no effects

4. opkg update && opkg install nmap --dest sd results:

...
Package nmap (6.47-2) installed in sd is up to date.

5. nmap on web interface uninstalled and reinstalled as described in 4:
...
Installing nmap (6.47-2) to sd...
Downloading https://downloads.openwrt.org/chaos_calmer/15.05/ar71xx/generic/packages/packages/nmap_6.47-2_ar71xx.ipk.Configuring nmap.
grep: /usr/lib/opkg/info/nmap.control:  No such file or directory
cat: can't open '/usr/lib/opkg/info/nmap.list':  No such file or directory

Any ideas?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...