Jump to content

[Support] urlsnarf


Recommended Posts

How can I get urlsnarf to work?

I've tried to factory reset 3 times, wipe the sd and all I get is this: urlsnarf output_74.log [January 01 1970 00:01:14]
nothing else is logged.

Please can someone help me here?

Im kinda regretting having bought the pineapple :(

my third day trying to find a solution and nothing so far.

If I use the Pineapple connect in my MacBook via eth0 than snarf the traffic with my Kali linux I'm able to see all the logs in urlsnarf like it is supposed to work, but on my brand new Mark V i've got nothing at all..

When I first installed I was prompted with the dependencies request to be installed.. but whenever i'm doing a factory reset or even setting the unbrick mode and doind a re-flashing I don't see that again..

How i'm able to re-install urlsnarf to see if that fix it?


Link to comment
Share on other sites

  • 5 weeks later...

Hi Everybody,

I've done some searching but haven't been able to find what format the URL Snarf and SSL Strip infusion uses for log file names. I presume it's some kind of date/time format.

The actual file time stamp is in local time, as are the log file contents... but the infusions show UTC time when you click on the history tab. It would be nice if the date/time in the history tab could take the system UTC offset into account when being displayed.

eg :-

URL Snarf History tab shows :-

2014-11-16 23-18-10

File in /sd/infusions/urlsnarf/includes/log/ is :-

Nov 17 11:29 output_1416179890.log

Bear in mind that the file date stamp shows when it was last modified/updated... I am at UTC +1030 at the moment.

How does the infusion turn "1416179890" into a date and time... or vice versa?



Edited by lunokhod
Link to comment
Share on other sites

Yeah it's Unix time stamp :tongue:

The infusion creates the log based on PHP time(); function.

I'll have a look to see how to fix it.

Now I know... I don't mind the log file name being a Unix time stamp of when the file was created.

I can always refer to the file system time stamp as to when the log file was last modified, this will be in local time.

If you could change the infusion to show local time instead of UTC in the log history tab... that would be fantastic!

Link to comment
Share on other sites

Hi there,

I am having a similar issue to TheZakMan. I'm using the lastest firmware on my Mark V (ver. 2.0.4) and urlsnarf infusion installed (1.7).

wlan0 is a wifi AP, and wlan1 is connected to my home router. That;s is my configuration in a few words.

After starting the urlsnarf infusion, it displays a message that says the information will be logged into a file.

But nothing else happens.

I tried all network interfaces with no success.

- Am I missing anything to make urlsnarf infusion works?

- Is there another infusion or another way to sniff urls on a network?

Link to comment
Share on other sites

  • 2 months later...
  • 2 months later...

hi i have a question regarding urlsnarf on the small tile its default device to use is lo when i open the big tile its default device is br-lan

is this just the way the infusion works or do i need to set both small tile and big tile to br-lan or just leave as default small tile lo big tile br-lan

Thanks in advance

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Create New...