Jump to content

Recommended Posts

  • Replies 157
  • Created
  • Last Reply

Top Posters In This Topic

I have run reaver with my /etc/config/wireless set to all sorts of different modes, so I don't think that would be the issue. I have noticed that if you don't have a strong signal to the ap it might fail to associate.

-SymPak

Link to comment
Share on other sites

What is the strength of your AP?
I'm going to assume that this AP is yours, so have you tried moving closer to it?

I don't have my Pineapple with me, but if your having a problem associating to the channel with reaver, you could try setting your pineapples channel to the same as the AP itself. In theory this would allow you to exclude the channel selection at reaver run-time, while still confining you for efficiency purposes to the single channel. Yes?

iwconfig mon0 channel <11>
Have you tried running aireplay-ng to generate some packet traffic?
aireplay-ng mon0 -1 120 -a <BSSID> -e <SSID>
Looking over the reaver site, try using the following as well instead of what you have above. It probably won't make much of a difference, then again it just may.
reaver -i mon0 -A -b <BSSID> -v

Keep us posted,

HTK

Edited by HighOnTek
Link to comment
Share on other sites

Output of wash is as follows:

BSSID              Channel  RSSI  WPS Version  WPS Locked  ESSID
--------------------------------------------------------------------------------------
XX:XX:XX:XX:XX:XX    11       -52   1.0          No          XXXX

This is while sitting in the same room as the AP using the alfa panel 7db antenna.

So I may have made a small error. When I tried to run aireplay to generate traffic it kept erroring out with a WPA error. But it seems to be case sensitive. When I did my ESSID exactly as listed it was showing as connected. When I tried running reaver in a seperate terminal it started cracking. I will edit this post after a successful test with all the commands I used in order, but it seems to be working now. Thank you for all your help.

Link to comment
Share on other sites

I love that the Pineapple has a Reaver module but I don't tend to use it all that often. I do however use it from a BackTrack 5 machine that I have combined with an AWUS036H and a Hawking booster with a good antenna. I've found that Reaver can be a very finicky program. I was having varying results when using it and I couldn't figure out why at first. It would run for a bit and shut down or work one minute on a router and not the next. Also, it would crack away for a while then get to one pin that it just repeats over and over.... Very frustrating but, I've found a process that seems to work and provides fairly consistent results. ( I believe that was my problem, I kinda knew what I was doing but I never did anything the same way twice. Which is why it would work sometimes but not consistently.)

First:

ifconfig wlanX down

Then:

airmon-ng start wlanX

When it starts mon0 airmon-ng sometimes warns of PIDs that might interfere, I reccomend killing the listed processes.

kill pid XXXX

kill pid YYYY

Then:

wash -i mon0

Pick your AP Then:

reaver -i mon0 -b XX:XX:XX:XX:XX:XX -a -vv

Never use the ifconfig wlanX UP command. You don't need it and I believe it actually causes problems. I follow those listed steps each time and have gotten the best (most stable) results so far. Also, learn what the extra options do... They come in really handy at times. Hope this helps someone else.

Edited by thesugarat
Link to comment
Share on other sites

  • 2 months later...

Does anyone else get on 2.8.1

wash: can't load library 'libpcap.so.1.3' and reaver: can't load library 'libpcap.so.1.3' problems?

If I upgrade libpcap , I cant turn the DNSSpoof on. dnsspoof: can't load library 'libpcap.so.1.1'

Nevermind, found this incase anyone needs this.

https://forums.hak5.org/index.php?/topic/29299-cant-load-library-libpcapso11/

Edited by xXNirvashXx
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...