Whistle Master

[Official] DNSspoof

52 posts in this topic

Module: DNSspoof


Version: 1.3


Features:


  • Manage dependencies
  • Configure hosts file
  • Live output
  • Run History

Change log:



1.3


  • Bug fixes

hc29f9r2tyw22bj4g.jpg


Edited by Whistle Master
1

Share this post


Link to post
Share on other sites

Under what condition would dns spoofing work? It doesn't work for websites such as Google and Facebook.

0

Share this post


Link to post
Share on other sites

Installing dependencies just hangs on "Installing..." forever, I've rebooted and removed/reinstalled the module and it does that every time. Any thoughts?

0

Share this post


Link to post
Share on other sites

I've got the same problem as purrball. The module just freezes when installing dependencies. Just says "Installing...". Tried uninstalling and reinstalling module, no luck.

0

Share this post


Link to post
Share on other sites

To the two users above, try installing the dependencies on a SD Card if you're not already doing so.

0

Share this post


Link to post
Share on other sites

To the two users above, try installing the dependencies on a SD Card if you're not already doing so.

Still waiting for UPS to deliver it lol. I will give update after getting SD card.

0

Share this post


Link to post
Share on other sites

got the same error

I make thIs tries

both installs in sd card = stuck installing

Install in internal storage and dependencies in sd card = stuck installing

Install in sd card and dependencies in internal storage = stuck installing

both in internal storage = stuck installing

0

Share this post


Link to post
Share on other sites

Awesome work on this, I've been hanging out for it.

Installed and running well, but Im getting a bit lost on file structure / scope etc.

Just to experiment, I'm DNSspoofing the br-lan, capturing everything like this:

172.16.42.1 *

At random, on a test device, I get the Landing page. So I know it is working.

I'm hoping to redirect to some pages hosted on the Nano. I've already made the pages, they process when called from /www/rickRoll/ (location on the Nano) in the browser (http://172.16.42.1/rickRoll/).

How do I get DNSspoof to point to those pages? Are any of these supposed to work?

172.16.42.1/rickRoll *
172.16.42.1/rickRoll *facebook.com
/sd/rickRoll/test.php *

Should I move them elsewhere? I'd prefer to have them on the SD card... is that workable?

How can I use the landing page to point to it? .. This works, but feels a bit clumsy, surely there is a better solution.

<?php
header('Location: http://172.16.42.1/rickRoll/index.php');
die(); 
?>

Any insights would be very helpful.

Cheers!

Edited by MunkVsTheWorld
1

Share this post


Link to post
Share on other sites

I'll have a look at the install process. It's weird that it works for some and not for others.

0

Share this post


Link to post
Share on other sites

i have experienced this install dependencies freeze issue at one time with all Modules that have the option. How did i get it to work?

hell if i know a couple of reboots and tried it the next morning and it seemed to start letting me install them on all modules that req'd them.

0

Share this post


Link to post
Share on other sites

On my nano, it installs fine. But when trying to spoof a domain, the device does not get spoofed. Still shows the actual domain that is being spoofed.

1

Share this post


Link to post
Share on other sites

Finally got the dependencies to install - don't know if there was an update or not, but now it's running at least. However anything spoofed results in 'Error Detected HTTP 404 - Resource Not Found', with Get running. It does nothing otherwise :wacko:

Edited by purrball
0

Share this post


Link to post
Share on other sites

I got the dependencies installed to an SD card, and dnsspoof seems to work well, however in some cases the website will just fail to load. (I know it is supposed to do this for https) Specifically, www.google.com will just get stuck loading. Not sure if Chrome has some way of knowing if you're going to the real google or if somehow it is redirecting to https. Will investigate.

0

Share this post


Link to post
Share on other sites

So close.... Just when I get it working, it stops working. It will redirect perfectly, then I'll edit an image or something, and it stops working. it's extremely temperamental.

It would be great to get a simple DNSspoof workflow/tutorial specific to the Nano. Maybe one for Pineapple University?

An example of a working setup would help immensely, I've found following online linux CLI tutorials isn't really directly applicable to this environment.

Just throwin' my 2 cents all over the joint. :) Great work on getting these out and updated so quickly.

Edited by MunkVsTheWorld
2

Share this post


Link to post
Share on other sites

Anyone else having issues with DNSSpoof?

I set up my hosts to

172.16.42.1 *

Then enable DNSSpoof, connect to my nano network with mobile phones... Neither will get redirected to the nano's index.php page.

Anyone else encountering this?

3

Share this post


Link to post
Share on other sites

dustbyter stop messing around with the nano and get the tetra finally :P

:) No tetra at the moment. not sure when I'll get one... but either way, the dns issue still remains.

0

Share this post


Link to post
Share on other sites

On which interface are you running it ? Can you start it and then issue a "ps" with ssh on the pineapple and paste it here ?

0

Share this post


Link to post
Share on other sites

On which interface are you running it ? Can you start it and then issue a "ps" with ssh on the pineapple and paste it here ?

I have it running on br-lan.

the output from ps is below:

root@Pineapple:/# ps

PID USER VSZ STAT COMMAND

1 root 1412 S /sbin/procd

2 root 0 SW [kthreadd]

3 root 0 SW [ksoftirqd/0]

5 root 0 SW< [kworker/0:0H]

7 root 0 SW< [khelper]

59 root 0 SW< [writeback]

62 root 0 SW< [bioset]

64 root 0 SW< [kblockd]

66 root 0 SW [kswapd0]

67 root 0 RW [kworker/0:1]

68 root 0 SW [fsnotify_mark]

70 root 0 SW [spi0]

243 root 0 SW< [deferwq]

327 root 0 SWN [jffs2_gcd_mtd3]

385 root 892 S /sbin/ubusd

435 root 772 S /sbin/askfirst /bin/ash --login

780 root 0 SW< [kworker/0:1H]

854 root 0 SW< [cfg80211]

883 root 0 SW< [rpciod]

914 root 0 SW< [nfsiod]

1152 root 0 SW [kworker/0:3]

1291 root 1044 S /sbin/logd -S 16

1376 root 1564 S /sbin/netifd

1554 nobody 792 S /usr/sbin/atd

1599 root 1380 S /usr/sbin/crond -f -c /etc/crontabs -l 5

1716 root 3436 S nginx: master process /usr/sbin/nginx

1718 root 3888 S nginx: worker process

2060 root 0 SW [scsi_eh_3]

2064 root 0 SW< [scsi_tmf_3]

2065 root 0 SW [usb-storage]

2566 root 11116 S php-fpm: master process (/etc/php5-fpm.conf)

2606 root 3296 S /usr/sbin/sshd -D

2613 root 0 SW [jbd2/sda1-8]

2614 root 0 SW< [ext4-rsv-conver]

2863 root 1384 S /usr/sbin/ntpd -n -S /usr/sbin/ntpd-hotplug -p 0.openwrt.pool.ntp.org -p 1.openwrt.pool.ntp.org -p 2.openwrt.pool.ntp.org -

2879 root 784 S log_daemon /tmp/pineap.log 30

3036 root 1872 S /usr/sbin/hostapd -P /var/run/wifi-phy0.pid -B /var/run/hostapd-phy0.conf

3212 root 1816 S /usr/sbin/wpa_supplicant -B -P /var/run/wpa_supplicant-wlan1.pid -D nl80211 -i wlan1 -c /var/run/wpa_supplicant-wlan1.conf

3324 nobody 944 S /usr/sbin/dnsmasq -C /var/etc/dnsmasq.conf -k -x /var/run/dnsmasq/dnsmasq.pid

3684 nobody 796 S /usr/sbin/atd

3685 root 1380 S N sh

3686 root 1380 S N {urlsnarf.sh} /bin/sh /pineapple/modules/urlsnarf/scripts/urlsnarf.sh start

3689 root 4072 S N urlsnarf -i br-lan

3736 root 0 SW [kworker/u2:2]

4500 root 0 SW [kworker/u2:0]

5927 root 11420 S php-fpm: pool www

5946 root 11484 S php-fpm: pool www

6109 root 11420 S php-fpm: pool www

6338 root 0 SW [kworker/u2:1]

6437 root 5892 R sshd: root@pts/0

6439 root 1384 S -ash

6536 root 1380 R ps

9026 nobody 796 S /usr/sbin/atd

9027 root 1380 S N sh

9028 root 1380 S N {dnsspoof.sh} /bin/sh /pineapple/modules/DNSspoof/scripts/dnsspoof.sh start

9031 root 3296 S N dnsspoof -i br-lan -f /etc/pineapple/spoofhost

26025 root 1380 S udhcpc -p /var/run/udhcpc-wlan1.pid -s /lib/netifd/dhcp.script -f -t 0 -i wlan1 -C

0

Share this post


Link to post
Share on other sites

I am wondering as well if there was a solution. I am having the same issue. I start my DNSspoof module on br-lan then connect a client and attempt to navigate to any website and I do not get redirected at all.

My host file is 172.16.42.1 *.*

0

Share this post


Link to post
Share on other sites

tetra on 1.0.2 . tried install to storage would just freeze on installing. removed dnsspoof prior update.

0

Share this post


Link to post
Share on other sites

The problem is still the same guys, the issue is not with the module.

Edited by Whistle Master
0

Share this post


Link to post
Share on other sites

I have the same problem. Dnsspoof is running and I see the packets in the log, but the dns reply is just not faked,

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.