Jump to content

[Official] DNSspoof

Whistle Master

Recommended Posts

got the same error

I make thIs tries

both installs in sd card = stuck installing

Install in internal storage and dependencies in sd card = stuck installing

Install in sd card and dependencies in internal storage = stuck installing

both in internal storage = stuck installing

Link to comment
Share on other sites

i have experienced this install dependencies freeze issue at one time with all Modules that have the option. How did i get it to work?

hell if i know a couple of reboots and tried it the next morning and it seemed to start letting me install them on all modules that req'd them.

Link to comment
Share on other sites

Finally got the dependencies to install - don't know if there was an update or not, but now it's running at least. However anything spoofed results in 'Error Detected HTTP 404 - Resource Not Found', with Get running. It does nothing otherwise :wacko:

Edited by purrball
Link to comment
Share on other sites

I got the dependencies installed to an SD card, and dnsspoof seems to work well, however in some cases the website will just fail to load. (I know it is supposed to do this for https) Specifically, www.google.com will just get stuck loading. Not sure if Chrome has some way of knowing if you're going to the real google or if somehow it is redirecting to https. Will investigate.

Link to comment
Share on other sites

  • 2 weeks later...

On which interface are you running it ? Can you start it and then issue a "ps" with ssh on the pineapple and paste it here ?

I have it running on br-lan.

the output from ps is below:

root@Pineapple:/# ps


1 root 1412 S /sbin/procd

2 root 0 SW [kthreadd]

3 root 0 SW [ksoftirqd/0]

5 root 0 SW< [kworker/0:0H]

7 root 0 SW< [khelper]

59 root 0 SW< [writeback]

62 root 0 SW< [bioset]

64 root 0 SW< [kblockd]

66 root 0 SW [kswapd0]

67 root 0 RW [kworker/0:1]

68 root 0 SW [fsnotify_mark]

70 root 0 SW [spi0]

243 root 0 SW< [deferwq]

327 root 0 SWN [jffs2_gcd_mtd3]

385 root 892 S /sbin/ubusd

435 root 772 S /sbin/askfirst /bin/ash --login

780 root 0 SW< [kworker/0:1H]

854 root 0 SW< [cfg80211]

883 root 0 SW< [rpciod]

914 root 0 SW< [nfsiod]

1152 root 0 SW [kworker/0:3]

1291 root 1044 S /sbin/logd -S 16

1376 root 1564 S /sbin/netifd

1554 nobody 792 S /usr/sbin/atd

1599 root 1380 S /usr/sbin/crond -f -c /etc/crontabs -l 5

1716 root 3436 S nginx: master process /usr/sbin/nginx

1718 root 3888 S nginx: worker process

2060 root 0 SW [scsi_eh_3]

2064 root 0 SW< [scsi_tmf_3]

2065 root 0 SW [usb-storage]

2566 root 11116 S php-fpm: master process (/etc/php5-fpm.conf)

2606 root 3296 S /usr/sbin/sshd -D

2613 root 0 SW [jbd2/sda1-8]

2614 root 0 SW< [ext4-rsv-conver]

2863 root 1384 S /usr/sbin/ntpd -n -S /usr/sbin/ntpd-hotplug -p 0.openwrt.pool.ntp.org -p 1.openwrt.pool.ntp.org -p 2.openwrt.pool.ntp.org -

2879 root 784 S log_daemon /tmp/pineap.log 30

3036 root 1872 S /usr/sbin/hostapd -P /var/run/wifi-phy0.pid -B /var/run/hostapd-phy0.conf

3212 root 1816 S /usr/sbin/wpa_supplicant -B -P /var/run/wpa_supplicant-wlan1.pid -D nl80211 -i wlan1 -c /var/run/wpa_supplicant-wlan1.conf

3324 nobody 944 S /usr/sbin/dnsmasq -C /var/etc/dnsmasq.conf -k -x /var/run/dnsmasq/dnsmasq.pid

3684 nobody 796 S /usr/sbin/atd

3685 root 1380 S N sh

3686 root 1380 S N {urlsnarf.sh} /bin/sh /pineapple/modules/urlsnarf/scripts/urlsnarf.sh start

3689 root 4072 S N urlsnarf -i br-lan

3736 root 0 SW [kworker/u2:2]

4500 root 0 SW [kworker/u2:0]

5927 root 11420 S php-fpm: pool www

5946 root 11484 S php-fpm: pool www

6109 root 11420 S php-fpm: pool www

6338 root 0 SW [kworker/u2:1]

6437 root 5892 R sshd: root@pts/0

6439 root 1384 S -ash

6536 root 1380 R ps

9026 nobody 796 S /usr/sbin/atd

9027 root 1380 S N sh

9028 root 1380 S N {dnsspoof.sh} /bin/sh /pineapple/modules/DNSspoof/scripts/dnsspoof.sh start

9031 root 3296 S N dnsspoof -i br-lan -f /etc/pineapple/spoofhost

26025 root 1380 S udhcpc -p /var/run/udhcpc-wlan1.pid -s /lib/netifd/dhcp.script -f -t 0 -i wlan1 -C

Link to comment
Share on other sites

I have the same problem tried to debug and ssh to the pineapple in fact site are intercepted correctly ( be careful to flush dos cash) but redirect is not working for me (maybe process need to find the redirect site on a specific directory or it will stop ?) . will be great to have the module writer helping. Will continue to investigate...

Link to comment
Share on other sites

  • Foxtrot locked, unlocked and locked this topic

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...