Jump to content
The Power Company

Alfa AWUS036ACH Kali Configuration Guide

Recommended Posts

 

Like many others, I bought myself an Alfa AWUS036ACH, only to find its drivers are not set up by default on the latest version of Kali (despite many if its more recent reviews pointing out this fact). I found that there are few guides on how to get this sexy dual-band interface going, so I made a quick shell script to do everything in one shot. A few things to note before we begin:

  1. You need an internet connection for this to work
  2. This script works great on a fresh installation of the latest version of Kali Linux (2018.1). I tried running the script on a live boot, but the kernel yelled at me when I was modprobe-ing. If you want this to work with live boot, you will probably need to set up persistence or a custom image. Neither of those options are that difficult.
  3. Some of the commands towards the end are not necessary for installation, but I used them while I was figuring out how to set everything up, so I left them in there in case anything breaks.
  4. If you are anything like me, you may have a few broken drivers polluting your /usr/src folder from previous failed attempts. Delete them before attempting.
  5. Once script has run, I recommend you add the following lines to your NetworkManager.conf
[keyfile]
unmanaged-devices=interface-name:wlan1;interface-name:wlan2

This prevents NetworkManager from trying to resolve the interface using its own stuff when you reboot again (real men keep NetworkManager disabled anyway, but whatever). If your PC already has a wlan0 assigned by default (i.e. is a laptop with built-in wifi),  the keyfile above should work fine. Otherwise, just add interface-name:wlan0; before interface-name:wlan1; The reason I also disabled a second, nonexistent wlan2 at the end is because sometimes, if I unplug the interface and replug it into a different USB port, it will be assigned one number up. This measure adds one get-out-of-NetworkManager-free card to your hand, increasing your chance to pass go and collect that sweet $200.

       6. Once you have gotten the interface set up, I would recommend using ifconfig to put it into monitor mode, instead of airmon-ng. I've found that airmon-ng tends to have issues with manually installed drivers on occasion. In case you don't know, here is how its done (assuming your Alfa is assigned wlan1):

ifconfig wlan1 down
iwconfig wlan1 mode monitor
ifconfig wlan1 up

Anyway, here is the script in question. As you probably already know, you can copy it to a text file called coolfilename.sh, set it to executable, and give that baby a run from the terminal. Or you could always just manually run the following commands one at a time.

#!/bin/sh

# Shell script to set up drivers for Alfa AWUS036ACH
# You must have an internet connection.

# update your repositories
apt-get update

# install dkms if it isn't already
apt-get install dkms

# change directory to /usr/src
cd /usr/src

# if you have any other drivers installed,remove them like so:
rm -r rtl8812AU-4.3.22/

# get latest driver from github
# used to be: git clone https://github.com/aircrack-ng/rtl8812au
git clone https://github.com/gordboy/rtl8812au.git

# move into downloaded driver folder
cd rtl8812au/

# update files in working tree to match files in the index 
# this step doesn't seem to be necessary anymore, commented out
# git checkout --track remotes/origin/v5.2.20

# make drivers
make

# move into parent directory
cd ..

# debugging
dkms status

# rename file for use with dkms
mv rtl8812au/ rtl8812au-5.2.20

# dkms add driver
dkms add -m rtl8812au -v 5.2.20 

# build drivers
dkms build -m rtl8812au -v 5.2.20

# install drivers
dkms install -m rtl8812au -v 5.2.20

# debugging
lsmod

# summon new interface from the depths of the kernel
modprobe 8812au

# wifi interface should now appear.
ip link

 

EDIT 10-17-2018

As per the driver's Github page, added the following line to dkms build steps: dkms add -m rtl8812au -v 5.2.20

Script was successful for Debian, should now work again for any Debian-based linux distro.

Edited by The Power Company
  • Like 1
  • Upvote 2

Share this post


Link to post
Share on other sites

modprobe: FATAL: Module 8812au not found in directory /lib/modules/4.15.0-kali2-amd64
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN mode DEFAULT group default qlen 1000
    link/ether 00:21:cc:6b:a7:c5 brd ff:ff:ff:ff:ff:ff
3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP mode DORMANT group default qlen 1000
    link/ether 08:11:96:88:db:ac brd ff:ff:ff:ff:ff:ff


Got this as output please  help

Share this post


Link to post
Share on other sites
On 7/20/2018 at 2:58 PM, croberts1290 said:

modprobe: FATAL: Module 8812au not found in directory /lib/modules/4.15.0-kali2-amd64

Check that your module is actually saved in a directory called /lib/modules/4.15.0-kali2-amd64 (i.e. try to cd into it). The directory may have a different name due to kali updates, in which case you simply must change the directory to the current one.

Share this post


Link to post
Share on other sites

Nicely done, I'll have to try this as I bought mine for use with Kali/Nethunter but never got it working. I used similar methods to you and did hours of Googling but to no avail. Hopefully this works!

Share this post


Link to post
Share on other sites
1 hour ago, hxmidnight said:

remote: Repository not found.

fatal: repository 'https://github.com/aircrack-ng/rtl18812au/' not found

 

HELP

look for

git clone https://github.com/aircrack-ng/rtl18812au/

edit to

git clone https://github.com/aircrack-ng/rtl8812au.git

 

  • Like 1

Share this post


Link to post
Share on other sites
On 9/20/2018 at 5:28 AM, Just_a_User said:

look for


git clone https://github.com/aircrack-ng/rtl18812au/

edit to


git clone https://github.com/aircrack-ng/rtl8812au.git

 

 

You right, you right. I changed the script to reflect this change, the old line is commented out just in case

Share this post


Link to post
Share on other sites

Everything works perfectly until make.

make ARCH=x86_64 CROSS_COMPILE= -C /lib/modules/4.15.0-kali2-amd64/build M=/usr/src/rtl8812au  modules
make[1]: *** /lib/modules/4.15.0-kali2-amd64/build: No such file or directory.  Stop.
Makefile:1732: recipe for target 'modules' failed
make: *** [modules] Error 2

when I go to /lib/modules/4.15.0 etc. there's no build file

Not sure what to do. Help would be appreciated.

Share this post


Link to post
Share on other sites

uname -a

May need to change script to match your version of kali.

Share this post


Link to post
Share on other sites
On 10/6/2018 at 1:49 PM, thebighadron said:

Just did this now, but

change the git repo to https://github.com/gordboy/rtl8812au.git

change the 4.3.22 in following lines to 5.2.20: 


# rename file for use with dkms
mv rtl8812au/ rtl8812au-4.3.22

# build drivers
dkms build -m rtl8812au -v 4.3.22

# install drivers
dkms install -m rtl8812au -v 4.3.22

 

Got it, script updated. I don't have my Alfa card on me atm, I'll test whether it works later.

EDIT: Just tested it, updated script. It should work fine now.

Edited by The Power Company

Share this post


Link to post
Share on other sites

Hi,

I`m struggeling to get my AWUS036ACH to work. I`m using Oracle VM and Kali 4.17.0 and the moment I start the VM the blue LED goes off (no wifi adapter found). I run the script but I get some errors. Please help, I`m new to Linux (sorry).

Script result:

Hit:1 http://ftp2.nluug.nl/os/Linux/distr/kali kali-rolling InRelease
Reading package lists... Done
Reading package lists... Done
Building dependency tree       
Reading state information... Done
dkms is already the newest version (2.6.1-1).
0 upgraded, 0 newly installed, 0 to remove and 143 not upgraded.
rm: cannot remove 'rtl8812AU-4.3.22/': No such file or directory
Cloning into 'rtl8812au'...
remote: Enumerating objects: 829, done.
remote: Total 829 (delta 0), reused 0 (delta 0), pack-reused 829
Receiving objects: 100% (829/829), 2.76 MiB | 1.88 MiB/s, done.
Resolving deltas: 100% (412/412), done.
make ARCH=x86_64 CROSS_COMPILE= -C /lib/modules/4.17.0-kali1-amd64/build M=/usr/src/rtl8812au  modules
make[1]: *** /lib/modules/4.17.0-kali1-amd64/build: No such file or directory.  Stop.
make: *** [Makefile:1849: modules] Error 2
realtek-rtl88xxau, 5.2.20.2~20180812: added
rtl8812au, 5.2.20: added
Error! DKMS tree already contains: rtl8812au-5.2.20
You cannot add the same module/version combo more than once.
Error! echo
Your kernel headers for kernel 4.17.0-kali1-amd64 cannot be found at
/lib/modules/4.17.0-kali1-amd64/build or /lib/modules/4.17.0-kali1-amd64/source.
Error! echo
Your kernel headers for kernel 4.17.0-kali1-amd64 cannot be found at
/lib/modules/4.17.0-kali1-amd64/build or /lib/modules/4.17.0-kali1-amd64/source.
Module                  Size  Used by
fuse                  118784  3
snd_intel8x0           45056  4
crct10dif_pclmul       16384  0
snd_ac97_codec        143360  1 snd_intel8x0
ac97_bus               16384  1 snd_ac97_codec
crc32_pclmul           16384  0
ghash_clmulni_intel    16384  0
snd_pcm               118784  2 snd_intel8x0,snd_ac97_codec
snd_timer              36864  1 snd_pcm
joydev                 24576  0
snd                    94208  12 snd_intel8x0,snd_timer,snd_ac97_codec,snd_pcm
intel_rapl_perf        16384  0
pcspkr                 16384  0
evdev                  28672  17
vboxvideo              45056  3
soundcore              16384  1 snd
serio_raw              16384  0
binfmt_misc            20480  1
sg                     36864  0
ttm                   131072  1 vboxvideo
drm_kms_helper        192512  1 vboxvideo
ac                     16384  0
vboxguest              45056  0
video                  45056  0
drm                   462848  6 drm_kms_helper,vboxvideo,ttm
button                 16384  0
ip_tables              28672  0
x_tables               45056  1 ip_tables
autofs4                49152  2
ext4                  737280  1
crc16                  16384  1 ext4
mbcache                16384  1 ext4
jbd2                  118784  1 ext4
crc32c_generic         16384  0
fscrypto               32768  1 ext4
ecb                    16384  0
hid_generic            16384  0
usbhid                 57344  0
hid                   135168  2 usbhid,hid_generic
sd_mod                 53248  3
sr_mod                 28672  0
cdrom                  69632  1 sr_mod
ata_generic            16384  0
crc32c_intel           24576  2
xhci_pci               16384  0
aesni_intel           200704  0
xhci_hcd              262144  1 xhci_pci
usbcore               290816  3 xhci_hcd,usbhid,xhci_pci
usb_common             16384  1 usbcore
ata_piix               36864  2
aes_x86_64             20480  1 aesni_intel
i2c_piix4              24576  0
crypto_simd            16384  1 aesni_intel
libata                278528  2 ata_piix,ata_generic
cryptd                 28672  3 crypto_simd,ghash_clmulni_intel,aesni_intel
glue_helper            16384  1 aesni_intel
psmouse               167936  0
e1000                 155648  0
scsi_mod              253952  4 sd_mod,libata,sg,sr_mod
modprobe: FATAL: Module 8812au not found in directory /lib/modules/4.17.0-kali1-amd64
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP mode DEFAULT group default qlen 1000
    link/ether 08:00:27:cc:c9:08 brd ff:ff:ff:ff:ff:ff

 

Share this post


Link to post
Share on other sites

Ok I dis a clean install, followed this video and now my AWUS036ACH is working (blue led on).

Unfortunately my Airgeddon isnt working so I opened an issue at the Github repo for this.

I do have another strange issue when I do:

root@kali:~# airmon-ng

PHY	Interface	Driver		Chipset

phy0	wlan0		8812au		Realtek Semiconductor Corp. RTL8812AU 802.11a/b/g/n/ac WLAN Adapter

root@kali:~# airmon-ng start wlan0


PHY	Interface	Driver		Chipset

phy0	wlan0		8812au		Realtek Semiconductor Corp. RTL8812AU 802.11a/b/g/n/ac WLAN Adapter

		(mac80211 monitor mode already enabled for [phy0]wlan0 on [phy0]10)
root@kali:~# 

See, my wlan0 wont rename to wlan0mon which it did with my old AWUS036H. i think this is also causing Airgeddon not to work since it relies on wlan0mon etc. Any hints?

Share this post


Link to post
Share on other sites

Ok another clean install, this time full kali linux 2018.4 64-bit.

The script worked, but my adapter still isn't. Here is the result:

root@kali:~/Desktop# bash ./wlan.sh
Hit:1 http://ftp2.nluug.nl/os/Linux/distr/kali kali-rolling InRelease
Reading package lists... Done
Reading package lists... Done
Building dependency tree       
Reading state information... Done
dkms is already the newest version (2.6.1-1).
The following packages were automatically installed and are no longer required:
  libbind9-160 libdns1102 libirs160 libisc169 libisccc160 libisccfg160
  liblwres160 libpoppler74 libprotobuf-lite10 libprotobuf10 libradare2-2.9
  libunbound2 python-anyjson python-backports.ssl-match-hostname
  python-couchdbkit python-http-parser python-jwt python-restkit
  python-socketpool
Use 'apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.
rm: cannot remove 'rtl8812AU-4.3.22/': No such file or directory
Cloning into 'rtl8812au'...
remote: Enumerating objects: 829, done.
remote: Total 829 (delta 0), reused 0 (delta 0), pack-reused 829
Receiving objects: 100% (829/829), 2.76 MiB | 1.05 MiB/s, done.
Resolving deltas: 100% (412/412), done.
make ARCH=x86_64 CROSS_COMPILE= -C /lib/modules/4.18.0-kali2-amd64/build M=/usr/src/rtl8812au  modules
make[1]: Entering directory '/usr/src/linux-headers-4.18.0-kali2-amd64'
  CC [M]  /usr/src/rtl8812au/core/rtw_cmd.o
  CC [M]  /usr/src/rtl8812au/core/rtw_security.o
  CC [M]  /usr/src/rtl8812au/core/rtw_debug.o
  CC [M]  /usr/src/rtl8812au/core/rtw_io.o
  CC [M]  /usr/src/rtl8812au/core/rtw_ioctl_query.o
  CC [M]  /usr/src/rtl8812au/core/rtw_ioctl_set.o
  CC [M]  /usr/src/rtl8812au/core/rtw_ieee80211.o
  CC [M]  /usr/src/rtl8812au/core/rtw_mlme.o
  CC [M]  /usr/src/rtl8812au/core/rtw_mlme_ext.o
  CC [M]  /usr/src/rtl8812au/core/rtw_mi.o
  CC [M]  /usr/src/rtl8812au/core/rtw_wlan_util.o
  CC [M]  /usr/src/rtl8812au/core/rtw_vht.o
  CC [M]  /usr/src/rtl8812au/core/rtw_pwrctrl.o
  CC [M]  /usr/src/rtl8812au/core/rtw_rf.o
  CC [M]  /usr/src/rtl8812au/core/rtw_recv.o
  CC [M]  /usr/src/rtl8812au/core/rtw_sta_mgt.o
  CC [M]  /usr/src/rtl8812au/core/rtw_ap.o
  CC [M]  /usr/src/rtl8812au/core/rtw_xmit.o
  CC [M]  /usr/src/rtl8812au/core/rtw_p2p.o
  CC [M]  /usr/src/rtl8812au/core/rtw_rson.o
  CC [M]  /usr/src/rtl8812au/core/rtw_tdls.o
  CC [M]  /usr/src/rtl8812au/core/rtw_br_ext.o
  CC [M]  /usr/src/rtl8812au/core/rtw_iol.o
  CC [M]  /usr/src/rtl8812au/core/rtw_sreset.o
  CC [M]  /usr/src/rtl8812au/core/rtw_btcoex_wifionly.o
  CC [M]  /usr/src/rtl8812au/core/rtw_btcoex.o
  CC [M]  /usr/src/rtl8812au/core/rtw_beamforming.o
  CC [M]  /usr/src/rtl8812au/core/rtw_odm.o
  CC [M]  /usr/src/rtl8812au/core/efuse/rtw_efuse.o
  CC [M]  /usr/src/rtl8812au/os_dep/osdep_service.o
  CC [M]  /usr/src/rtl8812au/os_dep/linux/os_intfs.o
  CC [M]  /usr/src/rtl8812au/os_dep/linux/usb_intf.o
  CC [M]  /usr/src/rtl8812au/os_dep/linux/usb_ops_linux.o
  CC [M]  /usr/src/rtl8812au/os_dep/linux/ioctl_linux.o
  CC [M]  /usr/src/rtl8812au/os_dep/linux/xmit_linux.o
  CC [M]  /usr/src/rtl8812au/os_dep/linux/mlme_linux.o
  CC [M]  /usr/src/rtl8812au/os_dep/linux/recv_linux.o
  CC [M]  /usr/src/rtl8812au/os_dep/linux/ioctl_cfg80211.o
  CC [M]  /usr/src/rtl8812au/os_dep/linux/rtw_cfgvendor.o
  CC [M]  /usr/src/rtl8812au/os_dep/linux/wifi_regd.o
  CC [M]  /usr/src/rtl8812au/os_dep/linux/rtw_android.o
  CC [M]  /usr/src/rtl8812au/os_dep/linux/rtw_proc.o
  CC [M]  /usr/src/rtl8812au/os_dep/linux/ioctl_mp.o
  CC [M]  /usr/src/rtl8812au/hal/hal_intf.o
  CC [M]  /usr/src/rtl8812au/hal/hal_com.o
  CC [M]  /usr/src/rtl8812au/hal/hal_com_phycfg.o
  CC [M]  /usr/src/rtl8812au/hal/hal_phy.o
  CC [M]  /usr/src/rtl8812au/hal/hal_dm.o
  CC [M]  /usr/src/rtl8812au/hal/hal_dm_acs.o
  CC [M]  /usr/src/rtl8812au/hal/hal_btcoex_wifionly.o
  CC [M]  /usr/src/rtl8812au/hal/hal_btcoex.o
  CC [M]  /usr/src/rtl8812au/hal/hal_mp.o
  CC [M]  /usr/src/rtl8812au/hal/hal_mcc.o
  CC [M]  /usr/src/rtl8812au/hal/hal_hci/hal_usb.o
  CC [M]  /usr/src/rtl8812au/hal/led/hal_usb_led.o
  CC [M]  /usr/src/rtl8812au/hal/HalPwrSeqCmd.o
  CC [M]  /usr/src/rtl8812au/hal/rtl8812a/Hal8812PwrSeq.o
  CC [M]  /usr/src/rtl8812au/hal/rtl8812a/Hal8821APwrSeq.o
  CC [M]  /usr/src/rtl8812au/hal/rtl8812a/rtl8812a_xmit.o
  CC [M]  /usr/src/rtl8812au/hal/rtl8812a/rtl8812a_sreset.o
  CC [M]  /usr/src/rtl8812au/hal/rtl8812a/rtl8812a_hal_init.o
  CC [M]  /usr/src/rtl8812au/hal/rtl8812a/rtl8812a_phycfg.o
  CC [M]  /usr/src/rtl8812au/hal/rtl8812a/rtl8812a_rf6052.o
  CC [M]  /usr/src/rtl8812au/hal/rtl8812a/rtl8812a_dm.o
  CC [M]  /usr/src/rtl8812au/hal/rtl8812a/rtl8812a_rxdesc.o
  CC [M]  /usr/src/rtl8812au/hal/rtl8812a/rtl8812a_cmd.o
  CC [M]  /usr/src/rtl8812au/hal/rtl8812a/usb/usb_halinit.o
  CC [M]  /usr/src/rtl8812au/hal/rtl8812a/usb/rtl8812au_led.o
  CC [M]  /usr/src/rtl8812au/hal/rtl8812a/usb/rtl8812au_xmit.o
  CC [M]  /usr/src/rtl8812au/hal/rtl8812a/usb/rtl8812au_recv.o
  CC [M]  /usr/src/rtl8812au/hal/rtl8812a/usb/usb_ops_linux.o
  CC [M]  /usr/src/rtl8812au/hal/efuse/rtl8812a/HalEfuseMask8812A_USB.o
  CC [M]  /usr/src/rtl8812au/hal/rtl8812a/hal8812a_fw.o
  CC [M]  /usr/src/rtl8812au/hal/phydm/phydm_debug.o
  CC [M]  /usr/src/rtl8812au/hal/phydm/phydm_antdiv.o
  CC [M]  /usr/src/rtl8812au/hal/phydm/phydm_soml.o
  CC [M]  /usr/src/rtl8812au/hal/phydm/phydm_smt_ant.o
  CC [M]  /usr/src/rtl8812au/hal/phydm/phydm_antdect.o
  CC [M]  /usr/src/rtl8812au/hal/phydm/phydm_interface.o
  CC [M]  /usr/src/rtl8812au/hal/phydm/phydm_phystatus.o
  CC [M]  /usr/src/rtl8812au/hal/phydm/phydm_hwconfig.o
  CC [M]  /usr/src/rtl8812au/hal/phydm/phydm.o
  CC [M]  /usr/src/rtl8812au/hal/phydm/phydm_dig.o
  CC [M]  /usr/src/rtl8812au/hal/phydm/phydm_pathdiv.o
  CC [M]  /usr/src/rtl8812au/hal/phydm/phydm_rainfo.o
  CC [M]  /usr/src/rtl8812au/hal/phydm/phydm_dynamictxpower.o
  CC [M]  /usr/src/rtl8812au/hal/phydm/phydm_adaptivity.o
  CC [M]  /usr/src/rtl8812au/hal/phydm/phydm_cfotracking.o
  CC [M]  /usr/src/rtl8812au/hal/phydm/phydm_noisemonitor.o
  CC [M]  /usr/src/rtl8812au/hal/phydm/phydm_acs.o
  CC [M]  /usr/src/rtl8812au/hal/phydm/phydm_beamforming.o
  CC [M]  /usr/src/rtl8812au/hal/phydm/phydm_dfs.o
  CC [M]  /usr/src/rtl8812au/hal/phydm/txbf/halcomtxbf.o
  CC [M]  /usr/src/rtl8812au/hal/phydm/txbf/haltxbfinterface.o
  CC [M]  /usr/src/rtl8812au/hal/phydm/txbf/phydm_hal_txbf_api.o
  CC [M]  /usr/src/rtl8812au/hal/phydm/phydm_adc_sampling.o
  CC [M]  /usr/src/rtl8812au/hal/phydm/phydm_ccx.o
  CC [M]  /usr/src/rtl8812au/hal/phydm/phydm_psd.o
  CC [M]  /usr/src/rtl8812au/hal/phydm/phydm_primary_cca.o
  CC [M]  /usr/src/rtl8812au/hal/phydm/phydm_cck_pd.o
  CC [M]  /usr/src/rtl8812au/hal/phydm/phydm_rssi_monitor.o
  CC [M]  /usr/src/rtl8812au/hal/phydm/phydm_auto_dbg.o
  CC [M]  /usr/src/rtl8812au/hal/phydm/phydm_math_lib.o
  CC [M]  /usr/src/rtl8812au/hal/phydm/phydm_api.o
  CC [M]  /usr/src/rtl8812au/hal/phydm/phydm_pow_train.o
  CC [M]  /usr/src/rtl8812au/hal/phydm/halrf/halrf.o
  CC [M]  /usr/src/rtl8812au/hal/phydm/halrf/halphyrf_ce.o
  CC [M]  /usr/src/rtl8812au/hal/phydm/halrf/halrf_powertracking_ce.o
  CC [M]  /usr/src/rtl8812au/hal/phydm/halrf/halrf_powertracking.o
  CC [M]  /usr/src/rtl8812au/hal/phydm/halrf/halrf_kfree.o
  CC [M]  /usr/src/rtl8812au/hal/phydm/rtl8812a/halhwimg8812a_mac.o
  CC [M]  /usr/src/rtl8812au/hal/phydm/rtl8812a/halhwimg8812a_bb.o
  CC [M]  /usr/src/rtl8812au/hal/phydm/rtl8812a/halhwimg8812a_rf.o
  CC [M]  /usr/src/rtl8812au/hal/phydm/halrf/rtl8812a/halrf_8812a_ce.o
  CC [M]  /usr/src/rtl8812au/hal/phydm/rtl8812a/phydm_regconfig8812a.o
  CC [M]  /usr/src/rtl8812au/hal/phydm/rtl8812a/phydm_rtl8812a.o
  CC [M]  /usr/src/rtl8812au/hal/phydm/txbf/haltxbfjaguar.o
  CC [M]  /usr/src/rtl8812au/hal/btc/halbtc8723bwifionly.o
  CC [M]  /usr/src/rtl8812au/hal/btc/halbtc8822bwifionly.o
  CC [M]  /usr/src/rtl8812au/hal/btc/halbtc8821cwifionly.o
  CC [M]  /usr/src/rtl8812au/platform/platform_ops.o
  CC [M]  /usr/src/rtl8812au/core/rtw_mp.o
  LD [M]  /usr/src/rtl8812au/8812au.o
  Building modules, stage 2.
  MODPOST 1 modules
  CC      /usr/src/rtl8812au/8812au.mod.o
  LD [M]  /usr/src/rtl8812au/8812au.ko
make[1]: Leaving directory '/usr/src/linux-headers-4.18.0-kali2-amd64'
realtek-rtl88xxau, 5.2.20.2~20180812, 4.18.0-kali2-amd64, x86_64: installed
rtl8812au, 5.2.20, 4.18.0-kali2-amd64, x86_64: installed
Error! DKMS tree already contains: rtl8812au-5.2.20
You cannot add the same module/version combo more than once.
Module rtl8812au/5.2.20 already built for kernel 4.18.0-kali2-amd64/4
Module rtl8812au/5.2.20 already installed on kernel 4.18.0-kali2-amd64/x86_64
Module                  Size  Used by
8812au               1622016  0
cfg80211              778240  1 8812au
rfkill                 28672  2 cfg80211
fuse                  122880  5
intel_powerclamp       16384  0
intel_rapl_perf        16384  0
binfmt_misc            20480  1
joydev                 24576  0
snd_intel8x0           45056  4
vboxvideo              45056  3
snd_ac97_codec        143360  1 snd_intel8x0
ac97_bus               16384  1 snd_ac97_codec
evdev                  28672  17
snd_pcm               118784  2 snd_intel8x0,snd_ac97_codec
snd_timer              36864  1 snd_pcm
ttm                   131072  1 vboxvideo
drm_kms_helper        196608  1 vboxvideo
pcspkr                 16384  0
serio_raw              16384  0
snd                    94208  12 snd_intel8x0,snd_timer,snd_ac97_codec,snd_pcm
soundcore              16384  1 snd
vboxguest              45056  0
drm                   471040  6 drm_kms_helper,vboxvideo,ttm
sg                     36864  0
ac                     16384  0
video                  45056  0
button                 16384  0
ip_tables              28672  0
x_tables               45056  1 ip_tables
autofs4                49152  2
ext4                  741376  1
crc16                  16384  1 ext4
mbcache                16384  1 ext4
jbd2                  118784  1 ext4
crc32c_generic         16384  0
fscrypto               32768  1 ext4
ecb                    16384  0
hid_generic            16384  0
usbhid                 57344  0
hid                   135168  2 usbhid,hid_generic
sd_mod                 53248  3
sr_mod                 28672  0
cdrom                  69632  1 sr_mod
ata_generic            16384  0
crct10dif_pclmul       16384  0
crc32_pclmul           16384  0
crc32c_intel           24576  2
ghash_clmulni_intel    16384  0
pcbc                   16384  0
aesni_intel           200704  0
ata_piix               36864  2
xhci_pci               16384  0
aes_x86_64             20480  1 aesni_intel
crypto_simd            16384  1 aesni_intel
cryptd                 28672  3 crypto_simd,ghash_clmulni_intel,aesni_intel
glue_helper            16384  1 aesni_intel
xhci_hcd              270336  1 xhci_pci
psmouse               172032  0
usbcore               290816  4 xhci_hcd,usbhid,8812au,xhci_pci
usb_common             16384  1 usbcore
i2c_piix4              24576  0
e1000                 155648  0
libata                278528  2 ata_piix,ata_generic
scsi_mod              253952  4 sd_mod,libata,sg,sr_mod
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP mode DEFAULT group default qlen 1000
    link/ether 08:00:27:1b:24:6e brd ff:ff:ff:ff:ff:ff
root@kali:~/Desktop# 

If I go to the top bar of my Vitrual Machine, I see my Devices, USB, Realtek 802.11n NIC but it hasnt got a blue check mark which it should have. Id I click it I get;

"Het is niet gelukt USB-apparaat Realtek 802.11n NIC te koppelen aan virtuale machine Kali Linux" (which says "failed to connect Realtek bla bla bla).

In Windows10 Pro 64 the adapter works fine, the moment I start my VM the adapters Blue LED turns off and the device shows no longer hotspots in Windows.

Please help guys, I`m desperate and Alfa stopped supporting.

 

Share this post


Link to post
Share on other sites

Didi you set up virtual machine correctly? Take a look.

You need to add support for it in the installation.

Share this post


Link to post
Share on other sites

Yes I did but thanks for pointing out.

I also posted my issue on the Oracle forums. People say its not possible to share a USB between the host and the VM. The send me a link

 but I already created a filter. The filer is what is causing the issue. When I remove the filer my wifi adpater keeps working (blue led on), the moment I go to the top and select USB, Realink, the LED goes off again. As far as my english goes, these are the two steps (approaches) from the link right?

Share this post


Link to post
Share on other sites

This worked great on my Ubuntu 18.04.  For putting the 036ACH card into monitor mode, it *was* necessary to use:

ifconfig wlan1 down                       (actually wlx00c0caa51645 instead of wlan1)
iwconfig wlan1 mode monitor
ifconfig wlan1 up

 

Now to see if these instructions are compatible with the other laptop running Parrot Home on a "Dell Inspiron 11 3000."

Share this post


Link to post
Share on other sites

Thanks for this installation guide.

I finally got my Alfa awaus036ach connected to my wireless network on a Kali Linux 2018.4 virtual machine on VirtualBox 6.0 and working - both monitor mode and packet injection.

However, I can't use the adapter with airgeddon when the adapter is installed as per the installation guide above. When I install the drivers using apt-get install realrek-rtl88xxau-dkms, I'm able to use the adapter with airgeddon but with the "Activation of network connection failed" error. Please advise if there is a fix to use airgeddon with the installation guide above.

  • Upvote 1

Share this post


Link to post
Share on other sites

Hi, i have been having troubles with my AWUS036ACH drivers both on kali and parrot os on Virtual Box... at first it worked for a wile until i hear the device disconnection sound on windows... plus the blue LED was always off... i have followed this script to install the drivers:

I´ve seen the LED work for the first time ever and it doesnt disconnect anymore, Airodump works and Wifite as well...

the problem now is that Airgeddon doesn´t:

***************************** airgeddon main menu ****************************** 
There is a problem with the selected interface. Redirecting you to script exit 
Press [Enter] key to continue...
 The ideia is to perform Evil Twin attacks with my old Tplink 722N( Always worked great)

 

Share this post


Link to post
Share on other sites

Hi, i have been having troubles with my AWUS036ACH drivers both on kali and parrot os on Virtual Box... at first it worked for a wile until i hear the device disconnection sound on windows... plus the blue LED wasa always off... i have followed this script to install the drivers

I´ve seen the LED work for the first time ever and it doesnt disconnect anymore, Airodump works and Wifite as well...

the problem now is that Airgeddon doesn´t:

***************************** airgeddon main menu ****************************** 
There is a problem with the selected interface. Redirecting you to script exit 
Press [Enter] key to continue...
 The ideia is to perform Evil Twin attacks with my old Tplink 722N( Always worked great)

Share this post


Link to post
Share on other sites

I'm having real trouble setting this up - it fails at the build stage - below is the error I get in /var/lib/dkms/rtl8812au/5.2.20/build/make.log:

DKMS make.log for rtl8812au-5.2.20 for kernel 4.14.93-Re4son-v7+ (armv7l)
Fri Apr 12 16:00:17 BST 2019
/bin/sh: 1: bc: not found
make ARCH=armv7l CROSS_COMPILE= -C /lib/modules/4.14.93-Re4son-v7+/build M=/var$
make[1]: Entering directory '/usr/src/linux-headers-4.14.93-Re4son-v7+'
Makefile:646: arch/armv7l/Makefile: No such file or directory
make[1]: *** No rule to make target 'arch/armv7l/Makefile'.  Stop.
make[1]: Leaving directory '/usr/src/linux-headers-4.14.93-Re4son-v7+'
make: *** [Makefile:1851: modules] Error 2
 

I'm using Raspberry Pi 3B+ with a Re4son kernel.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...