Jump to content

orrin

Active Members
  • Content Count

    43
  • Joined

  • Last visited

Everything posted by orrin

  1. This worked great on my Ubuntu 18.04. For putting the 036ACH card into monitor mode, it *was* necessary to use: ifconfig wlan1 down (actually wlx00c0caa51645 instead of wlan1) iwconfig wlan1 mode monitor ifconfig wlan1 up Now to see if these instructions are compatible with the other laptop running Parrot Home on a "Dell Inspiron 11 3000."
  2. My Nano behaves this way also. Sometimes wlan2 connects to my home router, and sometimes it doesn't (and gets a 172-address instead). So for now i've moved on, by just learning other functions of the Pineapple, and not relying on it to connect to my home router.
  3. On 10/16/2018 at 8:32 AM, Foxtrot said: Is the access point you're trying to connect to via wlan2 an open AP? It sounds like you are man in the middling yourself. You should add the MAC of the wlan2 card to the filters "Deny" list. So i did that, and rebooted, and all is fine. But earlier today "all was fine" even before i did this. Wlan2 has been connecting to my home wifi automatically today. So, on to the next challenge, until/if this problem pops up again.
  4. No, the AP i'm trying to connect to via wlan2 is not an open AP. It is my home router, which requires a password. Not an open AP. Today wlan2 *did* automatically connect to my home router & got a 192-address. Twice. So the behavior is not consistent. I'm still baffled. When wlan2 *doesn't* auto connect to my home router, i make it connect by changing its MAC to a random MAC, then hit refresh. Would adding its MAC to the Deny list "do" anything? Could wlan2 be sometimes connecting to the Nano's OpenAP? That would be strange. Is that what people mean by "MITM-myself"? Meanwhile i'm learning other functions of the Nano. Today i tethered to an android for the first time.
  5. Has anyone gotten a Samsung Chromebook 3, with crouton installing Kali or Ubuntu, to recognize an external wifi adapter? I keep doing searches and come up with posts from 2014 and 2015 saying that the Chromebook is not capable of recognizing external wifi adapters. Specifically I have an Alfa AWUS036NHA i'd like to use. If i can't resolve this by Nov 1 (2018) i'm just going to buy a "traditional" Win10 PC with a non-eMMC spinning 500GB drive. I've had no problem making those dual-boot. There is so much negative information about (1) making machines with eMMC (SSHD) dual boot or booting up off USB, and (2) Chromebooks not recognizing external wifi adapters. Maybe i need to wait 2-3 yrs for Chromebooks to become more versatile? ... Thanks for comments.
  6. So now this is my workaround: (1) I manage the Nano initially via the 172 address, use the USB cable. Most of the time, wlan2 does *not* come up with a 192 address. (2) In Networkiing, i then change the MAC addr of wlan2 to a random MAC. Then hit REFRESH over at "WiFi Client Mode." This pretty consistently makes wlan2 take on a 192 address (from my home router), and this is reflected in the routing table at the top of the Networking screen. But: This still means i have to run the Nano with the USB cable, because i can't rely on wlan2 getting a 192 address initially from my router. After i get wlan2 to take a 192-address, my OpenAP works and gives internet access to clients (for testing, the client is my android phone). Other functions seem to work well, i can deauth the devices in my apartment (and detect this with an RPi running an Alfa and Kismet). So, making progress in learning the Nano. The problem remains: wlan2 won't take on a 192-address until i change its MAC to a random MAC and then hit Refresh. ... Thanks for any comments. --orrin
  7. Hay muchos ajustes para que los clientes se conecten, y yo no soy el experto, todavia aprendiendo. Pero aqui son unos ajustes: Pagina "Networking": "Access Points": Open SSID: (un nombre que das a tu OpenAP, que los clientes podran ver), Hide Open SSID: no, y entonces clique on "Update Access Points" Pagina "Networking": "WiFi Client Mode": Interface: wlan2 (hay que comprar un dongle USB como el Ralink RT5370), es para que clientes tengan acceso al internet). SSID: el 'router' en tu casa, IP: dado a wlan2 por el router, y clique en 'Refresh.' Pagina "PineAP": "Allow Associations": si, "PineAP Daemon": enabled, "Log PineAP Events": si, "Client Connect Notifications": si, "Capture SSIDs to Pool": si, y clique en "Save PineAP Settings." Pagina "Filters": "Deny Listed MACs" y "Deny Listed SSIDs" -- esto permite a *todos* conectarse -- ten cuidado con esto -- es bastante 'ruidoso' Perdone la falta de acentos aqui, este teclado no tiene los acentos. (Mi android tiene teclados multilingues, pero no seria facil en el laptop aqui.) Si alguien encuentre errores en lo que he escrito, avisenos... Experts please correct errors, since i'm a Bungling Beginner still. --orrin.
  8. Thanks for response! ... The AP i'm trying to connect to via wlan2 is my home router, which is not an open AP. It requires a password. In Networking under "WiFi Client Mode" i scan for APs, see my own (it appears twice but only one of them has the correct MAC, idk why, maybe someone in the neighborhood is faking my SSID?), choose that, enter my router password, try to connect. I think it doesn't connect. All i get for wlan2 is a 172 address. I then added the MAC of the wlan2 device (an Alfa, overkill) to the Deny MAC list of Filters. Reboot. Wlan2 still has a 172 address. I then turned on PineAP, no change. Under "WiFi Client Mode" i tried Refresh, no result, try to connect to my router again, refresh, no result. (So then i removed that MAC from DENY list.) The only way i can get wlan2 to have a 192 address, is then to set the MAC of wlan2 to a new random MAC, then hit the Refresh button. SUCCESS. But this means i can't start the Nano without it being connected via USB. Can't start it in what i'm calling 'standalone mode.' I don't know if i'm "man in the middling" myself, because i don't know how to even set up a MITM scenario yet. This: I was working on the assumption that connecting wlan2 to my home router would allow any clients connecting to my Open SSID, to get internet access thru my Nano. That is the stage of learning i'm at now. And it's true: if i connect my smartphone to my Open-SSID 'yellow' i can get into the internet. So that is working. I just can't get the Nano to boot up so that wlan2 is automatically connecting to my router, to get a 192 address for wlan2. I have to intervene: (1) try to connect to my router & fail, (2) change the MAC of the wlan2 to something random, (3) hit Refresh under "WiFi Client Mode," voila. Then & only then will Fing (on my phone e.g.) show the device that is attached to wlan2, connected to my home router. Hope this makes sense. Thanks for any comments. --orrin
  9. Did more testing & trying to write down each step: 1. Had wlan2 working with a 192 address for hours. Then, under WiFi ClientMode, i disconnected. After a minute, on the list appeared wlan2, wlan1mon. 2. I chose wlan2, tried to sign in to my router. Not success, wlan2 is 172. Try again, no success. Tried to update routing table wlan2 192.168.0.1. No result. 3. Change MAC of wlan2 to random. Try to connect to router. No success. Still 172. Try to update router table to 192. Still 172. 4. Connect to my neighbor's router. (I have permission.) Refresh the entire page (screen). SUCCESS. Then disconnect from neighbor's router. 5. Try to connect to my own router. No luck, still coming up as 172. Try to update router table. No. 6. Change MAC of wlan2 to random. Hit Refresh under WiFi Client Mode. SUCCESS. Refresh entire page (screen). All then appears updated. I realize that not everything i've tried here has to be cause-and-effect. Due to my lack of experience/knowledge, i am stumbling around trying this & that. Maybe step 6 here is "it" but i don't know for sure yet. Happy Sunday/Monday tuya Sebkinne. --orrin
  10. Are you Pineappling yourself? Mr Seb, maybe you can tell me if i'm "Pineappling myself." (reading off the settings right now): (1) Did a recon but it's not running right now. (2) On the Clients tab, no clients listed at the moment. From last night's overnight run, i picked up one client, namely my smartphone. (3) Tracking List: nothing there (4) No Modules running (5) Filters: both set to Deny. I didn't put any MACs in there. (6) PineAP daemon enabled, Allow Associations, Log PineAP events, Client Connect Notifications, Client Disconnect Notifications, Capture SSIDs to Pool, but Beacon Response and Broadcast SSID Pool definitely unchecked, i didn't want to get intrusive. There are lots of entries in the SSID Pool, but i hope i'm not doing noisy stuff with all this. (7) Under Logging, i have Display Probes and Display (De)Associations checked. Remove Duplicates is not checked. (8) Reporting: I thought i'd set it to create reports in /root but i don't see those, i'm not concerned at this point. (9) Networking: As i describe above, but: Access Points: Management SSID is my home router, Mgmt AP not hidden. The Routing Table has my home router is the Default Gateway with Genmask 0.0.0.0 (idk what that means) IFace wlan2, with br-lan 172.16.42.0. (10) Further on Networking: br-lan 172.16.42.1, eth0 no ip, lo 127.0.0.1, wlan0 no ip, wlan0-1 no ip, wlan1mon no ip, wlan2 has the 192-address. (I basically know what these are. I just list them for info. At the moment things seem to be running okay. (11) Configuration: i haven't changed anything here. Haven't done "Landing Page." (12) Advanced: i could list some of the stats if that would be helpful. SO: Any comments welcome. Both about the problems i am (or was) having with wlan2, and also i need to know if i am making a lot of noise and being intrusive in my neighborhood. I just want to monitor, not send them anything. --orrin
  11. My last reboot, with the Alfa, wlan2 got a 172-address, but i was able to disconnect and then connect to my home router to get a 192-address. One thing i did differently is, when i told the WiFi Client Mode to scan, i chose the *second* instance of my home router's ID in the list. Don't know why it would occur twice. Don't know if this is relevant.
  12. Hi folks, i am wrestling with wlan2 connection problems. Have spent maybe 8 hours on this and i have a tentative solution that works some of the time, but i don't understand what is happening really. (1) I had a little wiFi dongle (Cheng Hongjian, but i can't find the commercial brand name, it was mentioned in a forum here so i ordered one) plugged into the Nano, as wlan2, to provide "client internet access" and for my management. It did seem to be working, and then i didn't use the Nano for a few weeks. This was in "standalone" mode with no USB cables attached to the computer. (1a) I installed C2 and got it working. The rest of my points below are with C2 *not* in the mix. (2) Then, several days ago, i noticed that wlan2 got an IP addr(192-addr) from my home router, but a few minutes later it would lose the 192-addr and get a 172-addr which i couldn't get to (because i didn't have usb connection to computer). The blue light on the dongle was no longer lit. (Back when this was working, the little wiFi dongle was getting listed in Fing as Cheng Hongjian.) Reboot, cold reboot. After wlan2 lost the 192-addr, it would not get it back after reboots, disconnect & reconnect WiFi Client Mode, or trying to add 192.168.0.1 to the routing table manually. (2a) Power supply was a 28000mAH brick with the Y-cable. (3) I then connected the Nano via the Y-cable to the laptop via Y-cable to a powered usb hub. With the Cheng-Hongjian wiFi dongle in the wlan2 slot. Sometimes i could get a 192-addr for wlan2, but if i did, it would go away after a few minutes, and the blue light on the *dongle* would go out. (4) So i replaced the dongle with my Alfa 036NHA. Similar behavior, either unable to get a 192-addr or it would get it and then drop it and get a 172-addr (5) Late last night (!) tried something radical: i connected to my neighbor's router (for which i *def* have permission, but i don't abuse it or even need to do it much). The wlan2 with the Alfa got a 192-addr right away, tentative hopeful. (6) Disconnected from there, tried to reconnect Wi-Fi Client Mode to my home router,**but** i changed the MAC address of wlan2 to something random. This worked,and i ran Recon for 9 hrs till this morning using the Alfa on wlan2. (7) Cold reboot. The Cheng-Hongjijan dongle in wlan2. Would not get a 192-addr. Alfa in wlan2. Would not get a 192-addr. (8) A combination of (a) reboots, (b) change MAC addr on wlan2, (c) disconnect & reconnect WiFi Client Mode to my router (my router SSID was listed twice for some reason), and (d) try to manually add to the routing table on that screen -- this has resulted in a stable 192-addr for wlan2 now for the past 90 minutes, and it'll probably stay that way until i reboot again and try to track down further what is going on here. (Next shot at this, i'm taking down more notes on what i did each try.) (9) Tentatively i'm thinking that the Cheng-Hongjian dongle went bad, but the Alfa was behaving similarly. I'm going to keep the Alfa in there for further tests. It works fine with an R-Pi so i'm pretty sure it isn't hosed. Thanks for any comments. --orrin
  13. Aethernaut, Sebkinne, Darren & Florida Tech, thanks for all comments. The gist is: success! Details: I got the C2 dashboard running. Generated a device.config file for a Pineapple, and scp'd it over to the Pineapple /etc/ directory, and rebooted it. The Pineapple connected to my home router via wlan2, got an IP address from the router. But the Pineapple wasn't showing up on the C2. Then i did a "remove" a couple times on the Pineapple. No joy. Then i thought, well maybe i need to generate a new device.config file after removing and re-adding the device. That worked finally. Yay! Hope my experience helps a few more people too. I've been using Linux heavily for only a couple years, and only started watching Hak5 (and other sites) and decoding OOK (for example) in January 2018. I didn't know what SCP was until tonight.
  14. Sebkinne, you wrote, in part: It does run like that, okay. But do i understand you correctly that it won't connect to my Pineapple when run like that? If that is the case, could you give me an example of a command-line that *will* allow me to connect to the Pineapple? (C2 for dummies i guess.) Like " -hostname 192.168.0.10" (if .10 is my ubuntu box) or should it be my network-assigned IP for the Pineapple. ... Thank you.
  15. So, i missed seeing the token on first startup, but (as the suggestion just above yours says) i found "token XXXX-XXXX-XXXX-XXXX" at the tail end of the c2.db file. I used that and have gotten thru setup to the point where i see the "Devices - Clients - Landscape" screen. So is that an okay way to retrieve the token? From the tail end of the c2.db file? Or should i delete c2.db and start over? ... thanks
  16. Seb, i did "sudo ./c2_community-linux-64 -hostname localhost" and in the firefox browser "localhost:8080" and i get the setup screen, yay! but i couldn't find a "setup token" in or at my terminal. (I have my license key okay.) Then i did "cat c2.db" and near the end of that file was " == token" + 4 groups of 4 letters, so i used that as a token. Is that correct? Then, on the setup screen, for Username and Password, i just made up something new. Then, after i get the setup done, do i understand you to mean that " -hostname localhost" won't allow communicating with the Pineapple? If that is the case, what would be an example of a -hostname that *would* allow comms with a Pineapple? Thanks... i got to the "Devices - Clients - Landscape" screen so i am making progress. ... Thanks for help!
  17. Appreciate any comments. I'm sure i'm not"getting" the instructions above... i did the download, and i have c2_community-linux-64 in my home directory. I then constructed the following string which i'm sure is wrong: sudo ./c2_community-linux-64 -hostname 127.0.0.1 -https -listenip 127.0.0.1 and i get "Running Hak5 Cloud C2" And when i go to use Firefox, i enter: http://127.0.0.1:8080 and i get the error message: An error occurred during a connection to 127.0.0.1:8080. SSL received a record that exceeded the maximum permissible length. Error code: SSL_ERROR_RX_RECORD_TOO_LONG. The page you are trying to view cannot be shown because the authenticity of the received data could not be verified. I also tried it without the -https. Thanks for help! --orrin
  18. Ja, if this were an amateur radio transmitting for 10 minutes with no antenna, the RF finals would be fried. I just have no idea what the radios inside the Nano were 'experiencing' during ten minutes. I didn't do a "before and after" signal strength test, so it's hard to say if any damage was done. The unit is still functional.
  19. Just_a_User, thanks for reply... Your last comments caused me to look at Filters. When i set the Filters to Deny Mode, then i was able to get my android phone to connect to the Open AP named xxxx-wifi. Yay! On the phone i think i was able to see that the Nano was the only current internet access, then i used Termux to ping 8.8.8.8 so i guess it's working. I see from some threads that i could be noisy and unintentionally messing with my neighbors' wifi with the Deny Mode, so i did 'halt' and shut down for the day. One little step at a time i guess. Later tonight or tomorrow i will have to read up on the use of filters.
  20. Just_a_User, thanks for reply... I'm able to do 'management' both with the 172 addr and the 192 addr. OK. My problem now is this: I have the "Open AP" name set to (let's call it) xxxx-wifi. On my android phone, in the wifi i can see xxxx-wifi, but when i try to connect to it i get, after a few seconds, "authentication error." (I'm trying to behave like a client who sees xxxx-wifi and wants to check it out.) On the right side of the management page on the Nano, under "Wi Fi Client Mode," i have Interface set to wlan2 (my new wifi dongle). I'm connected to my ISP router that way. On the left side of the mgmt page, under "Access Points," i have the Management SSID set to a name, a password for it, but for this test i checked both boxes -- Hide Mgmt AP, and Disable Mgmt AP. Below that, i set a name for the Open SSID (xxxx-wifi) and i uncheck 'Hide Open SSID.' So then on my phone, i see xxxx-wifi but when i try to connect i get 'authentication error.' (Also, i still see my mgmt AP on my phone, even tho i thought i disabled it for the moment.) I'm doing google searches on this but so far i'm stuck. Thanks for any comments.
  21. Thanks to a Hak5 forum person's comments, i ordered the Ralink RT5370 wifi dongle, and it worked right away. But for management, i have to go to 192.168.0.25:1471 not the 172.16.42.1 address. So i am going thru my home ISP-type router. Do i have something set up wrong? When i use the usb cable, i *do* use the 172 address. Three dongles i had for my RPi3's did not work at all, but the Ralink did.
  22. Received my Nano yesterday, am busy discovering how to use it. Today, after connecting to it via wifi (with the antennas on it), for some reason i had the antennas off, and then plugged it into my laptop via the USB and was doing some learning... with no antennas for about 10 minutes. I realized after 10 minutes that my phone was picking up the broadcast ID for the management AP, duh! Which means the Nano had been transmitting (what, 10x per second?). So i wonder how much damage that did. I know from amateur radio, can't xmit without an antenna. ... I measured the Nano's signal strength by walking around with my phone and a wiFi signal strength app, and the Nano was putting out maybe 10dBm less than my ISP-router, and i went outside & i still got a signal thru 3 walls 60 ft away. So anyway, thanks for any comments. Harsh comments okay too. --orrin
×
×
  • Create New...