Jump to content

Updated WiFi Pineapple Connector app for Android


Recommended Posts

On 19 april 2016 at 6:29 PM, miner_tom said:


I came across your post as I am having some difficulty tethering my Novatel 5510L to my router using openwrt. Theoretically this should be little different than tethering it to any other linux system.

I believe that I only need some help with respect to the iprouting described at the end of the post.

iptables -t nat -A POSTROUTING -s -o eth1 -j MASQUERADE
iptables -A FORWARD -s -o eth1 -j ACCEPT
iptables -A FORWARD -d -m state --state ESTABLISHED,RELATED -i eth1 -j ACCEPT

I am not really that network savvy (61 year old hardware engineer) and would like some explanation regarding the ip addresses shown above. I expect that they would be different for my system but I am not at all sure of how to determine them. Yes, I an able to log into the 5510L (when attached to my fedora system) and see the advanced tab and see the DHCP range etc. I expect that the last two lines in the above relate to ip forwarding.

Thank You


Hi I have now tried everything to see me for pineapple mark v Android phone from the Internet, viu USB cable. but it does not work, the app continues to seek verbinding.als I hn from plug he asks if I have the USB ontkopeld so he sees hemwel.telefoon root is money, and works on laptop. it is a Sony E3

Link to comment
Share on other sites

On 28 april 2016 at 6:55 PM, Sebkinne said:

Hey everyone,





We have released an update the the Android app hopefully fixing the issues people were having before.



Because of a mess-up on our part, we are unable to publish an update to the Google Play Marketplace, so you are going to have to remove and re-download the previous connector app.






You can find the official app on the Play Store.









Best Regards,








O o? Therefore, it does not work, How should I then get to work? have tried without app but does not work. and why do they not app mark 5 ??? Is not weird?  someone has an Android phone that he is working with USB Tetering, mark v?  THx. 

Link to comment
Share on other sites

2 hours ago, Bouvier said:

I think I'm going to make a micro USB cable (Android) to Ethernet .then via smartphone to the Mark V try tethering. for gife it internet.

The app simply doesn't support the MK5. It may in the future update for the MK5, but not right now.

Link to comment
Share on other sites

  • 8 months later...

Hello all,

 So I just downloaded the WiFi pineapple connector app 4.4 for galaxy s7, has anyone found a fix for the "waiting for connection" message?  Tethering is enabled, setup on my Kali Linux machine works fine, just this s7 connection issue.


Link to comment
Share on other sites

  • 1 year later...
  • 3 years later...


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...