Jump to content

Reaver "AP rate limiting detected" and automatic mdk3 solution


LexMichdeappel
 Share

Recommended Posts

Hello. Can someone help me? After running the ReVdK3-r1.sh script, I loose access to opening desktop files, or files from everywhere. I am able to still work within the terminal, and settings, basically everything else works, but I cannot open my files. I have to restart the computer to regain access. Is there something Im doing wrong, or a workaround for this? Thanks for your help.

Link to comment
Share on other sites

  • 2 months later...

has anyone tried to use the script with the new updates to airmon-ng it seems the interface is no longer monX it is wlanXmon and the script does not recognize the wlanXmon as a valid interface any ideas on how to get it working again?

Link to comment
Share on other sites

  • 1 month later...

Hello guys,

First congratulations for ReVdK3, it's usefull, nice job.

I would like to know how it'd be possible to modify the mdk3 commands the script launches

because none of the 3 that ReVdK3 offers works for me.

The AP doesn't reset with them but well with this one

mdk3 wlan0mon a -i XX:XX:XX:XX:XX:XX -m -s 1024

Link to comment
Share on other sites

I may take a crack at this in python. I remember this being a question on the reaver systems forum (or a feature request) for the Reaver Pro II, but iirc he said there was an issue incorporating it.

https://forums.reaversystems.com/index.php?threads/macchanger-automatic-macchanging.165/ that's the thread.

Keep in mind it's a private fork of reaver for the Reaver Pro II hardware.

Link to comment
Share on other sites

Thanks for your answer but I don't really get the point of the thread.

Anyway I tried to modify the script in ReVdK3, I changed

the lines that contain "a -a $MAC -s 200" which refers to Authentication DoS Flood Attack (option 1)

by "a -i $MAC -m -s 1024"

Unfortunately it doesn't work, when it launches the attack, after the selection of all parameters, it gives me the reaver's description of the arguments, like if the reaver command was uncomplete. Then when I try to quit the bash by ctrl + c, it writes

"cat: /etc/aireplay_tmp.txt: No such file or directory"
It's strange because I didn't modify nothing about reaver commands and aireplay is not involved in this attack...

Link to comment
Share on other sites

Well after messing around with Musket Teams VMR-MDK script and poking around in ReVdk, it honestly seems like the issue is the new way you put your wireless card into monitor mode with airmon-ng changing.

It looks like the scripts just need to be updated to the:

airmon-ng check kill
airmon-ng start wlan1

method and ensure they use the wlan1mon instead of mon1 bits.

Link to comment
Share on other sites

Has anyone managed to get RevDk3-r2 working on Kali Sana? This AP Rate limiting thing is getting old. Seriously considering downgrading to Kali 1.9

Seems like a lot of scripts are still pending updates at this point.

My issue in ReVDk3-r2

Which wireless interface you will be using? e. wlan1,wlan2 etc:

"You input a wireless interface that doesn't exist!"

Link to comment
Share on other sites

  • 1 month later...

hi masters :)

sorry to dig this topic, but the script can't recognize my wifi device in mon mode or normal mode, killed all services that can be problematic, no success

iwconfig:
eth0 no wireless extensions.
wlan0 IEEE 802.11bgn Mode:Monitor Frequency:2.447 GHz Tx-Power=20 dBm
Retry short limit:7 RTS thr:off Fragment thr:off
Power Management:off
lo no wireless extensions.
after script run:
*****************************************************
* Welcome: I need to verify your wireless interface *
******************************************************
Which wireless interface you will be using? e.g wlan1, wlan2 etc:wlan0
You input a wireless interface that doesn't exist!
any clue?
Link to comment
Share on other sites

I don't know this script you're using so I might very well be talking outta my ass here, but you could try to bring down the interface first:

ifconfig wlan0 down

Try again after that.

Link to comment
Share on other sites

I don't know this script you're using so I might very well be talking outta my ass here, but you could try to bring down the interface first:

ifconfig wlan0 down

Try again after that.

i'm using ReVdK3-rW.sh posted earlier on this topic

I already ifconfig down wlan0

after that put wlan0 on monitor mode, but the script can't detect the iface.. strange

Link to comment
Share on other sites

The -rW version was a modification to the original -r1 script made to get it to run within OpenWRT. Looking at the differences between -r1 and -rW I don't see anything there that would account for it not being able to find the interface.

There was however also a -r2 version posted by repzeroworld which is almost twice as long. Maybe it works better in pointing out what the actual problem might be?

See this post by repzeroworld for the -r2 version of the script.

Edit:

Looked closer at the actual script and the -r2 won't change anything since the check performed is identical.

The command the script uses to verify the interface is this:

read -p "Which wireless interface you will be using? e.g wlan1, wlan2 etc": WLAN;
EXISTENCE_OF_WLAN=`airmon-ng|grep ''"$WLAN"|cut -f1`;
while [   -z "$WLAN" -o "$EXISTENCE_OF_WLAN" != "$WLAN" ]; do
    echo -e "\e[31m\e[1mYou input a wireless interface that doesn't exist!\e[0m";
    echo ;
    read -p "Which wireless interface you will be using? e.g wlan1, wlan2 etc": WLAN;
    EXISTENCE_OF_WLAN=`airmon-ng|grep ''"$WLAN"|cut -f1`;
done

And as a quick aside, this would've been a cleaner version of that code:

while true
do      read -p "Which wireless interface you will be using? e.g wlan1, wlan2 etc": WLAN

        EXISTENCE_OF_WLAN=`airmon-ng|grep ''"$WLAN"|cut -f1`

        if [  -z "$WLAN" -o "$EXISTENCE_OF_WLAN" != "$WLAN" ]
        then    echo -e "\e[31m\e[1mYou input a wireless interface that doesn't exist!\e[0m"
        else    break
        fi
done

As you can see, the core check performed here is that the "EXISTENCE_OF_WLAN" variable needs to end up being identical to the value in "WLAN" which is the input you provided.

EXISTENCE_OF_WLAN gets it value from this command:

airmon-ng|grep ''"$WLAN"|cut -f1

Where, again, $WLAN is the interface name you entered.

The first part is just invoking airmon-ng without parameters. I don't have it installed here, but according to the documentation here it simply outputs a list of wireless interfaces it knows about. Take a good look at the output for that usage example - there are a number of columns, the first being "PHY" and the second being "Interface". This output is passed on to the grep program which filters out all lines that don't contain the interface you provided, so if you provided an existing interface you should get just that one line with several columns, the first being the PHY and the second the interface.

This single line is then provided to the cut program with a parameter of "-f1" meaning to eliminate everything but the first field. That first field is the PHY and even in the example output it's never identical to the interface. So the problem you're having is that the script isolates the wrong field to compare against.

The fix is simple - replace "cut -f1" with "cut -f2".

The cause of this is either that new Kali has a newer airmon-ng which suddenly adds a PHY field to its output which it never did before, or your kernel now supports the PHY interface of devices (it can be config'd out) and airmon-ng dutifully reports it, which is something the script doesn't expect.

Edited by cooper
Link to comment
Share on other sites

The -rW version was a modification to the original -r1 script made to get it to run within OpenWRT. Looking at the differences between -r1 and -rW I don't see anything there that would account for it not being able to find the interface.

There was however also a -r2 version posted by repzeroworld which is almost twice as long. Maybe it works better in pointing out what the actual problem might be?

See this post by repzeroworld for the -r2 version of the script.

Edit:

Looked closer at the actual script and the -r2 won't change anything since the check performed is identical.

The command the script uses to verify the interface is this:

read -p "Which wireless interface you will be using? e.g wlan1, wlan2 etc": WLAN;
EXISTENCE_OF_WLAN=`airmon-ng|grep ''"$WLAN"|cut -f1`;
while [   -z "$WLAN" -o "$EXISTENCE_OF_WLAN" != "$WLAN" ]; do
    echo -e "\e[31m\e[1mYou input a wireless interface that doesn't exist!\e[0m";
    echo ;
    read -p "Which wireless interface you will be using? e.g wlan1, wlan2 etc": WLAN;
    EXISTENCE_OF_WLAN=`airmon-ng|grep ''"$WLAN"|cut -f1`;
done

And as a quick aside, this would've been a cleaner version of that code:

while true
do      read -p "Which wireless interface you will be using? e.g wlan1, wlan2 etc": WLAN

        EXISTENCE_OF_WLAN=`airmon-ng|grep ''"$WLAN"|cut -f1`

        if [  -z "$WLAN" -o "$EXISTENCE_OF_WLAN" != "$WLAN" ]
        then    echo -e "\e[31m\e[1mYou input a wireless interface that doesn't exist!\e[0m"
        else    break
        fi
done

As you can see, the core check performed here is that the "EXISTENCE_OF_WLAN" variable needs to end up being identical to the value in "WLAN" which is the input you provided.

EXISTENCE_OF_WLAN gets it value from this command:

airmon-ng|grep ''"$WLAN"|cut -f1

Where, again, $WLAN is the interface name you entered.

The first part is just invoking airmon-ng without parameters. I don't have it installed here, but according to the documentation here it simply outputs a list of wireless interfaces it knows about. Take a good look at the output for that usage example - there are a number of columns, the first being "PHY" and the second being "Interface". This output is passed on to the grep program which filters out all lines that don't contain the interface you provided, so if you provided an existing interface you should get just that one line with several columns, the first being the PHY and the second the interface.

This single line is then provided to the cut program with a parameter of "-f1" meaning to eliminate everything but the first field. That first field is the PHY and even in the example output it's never identical to the interface. So the problem you're having is that the script isolates the wrong field to compare against.

The fix is simple - replace "cut -f1" with "cut -f2".

The cause of this is either that new Kali has a newer airmon-ng which suddenly adds a PHY field to its output which it never did before, or your kernel now supports the PHY interface of devices (it can be config'd out) and airmon-ng dutifully reports it, which is something the script doesn't expect.

Perfect explanation, thank you very much, it worked.

thanks

Link to comment
Share on other sites

  • 2 weeks later...

****************ReVdK3-r2 (Revision 2)********************************

Download Link

http://www56.zippyshare.com/v/UZrMxTtZ/file.html

I have revised the script for those who prefer to use bully wps pin cracker. Now you have two options for pin cracking either reaver 1.4 or bully

Dependency checks:

the program checks to see if you have the following are installed so that the script can function well

[1] reaver

[2] bully (if you are using)

[3] mdk3

[4] aireplay-ng

[5] gnome-terminal

[5] timeout

Possbily the last revision of the script since new access points are getting invulnerable to the attacks...however i will experiment new attacks and see if they are effective for rebooting APs biggrin.png..best of luck ReVdK3 users!..biggrin.png

Credit to my friend WaLkZ and others who prefer bully wps pin cracker

Hi,

I subscribed to download the script and thank you repzeroworld,

Cheers mate!

Link to comment
Share on other sites

  • 4 weeks later...

Please help me! I have been trying to change like you have written.

The fix is simple - replace "cut -f1" with "cut -f2".

But i dont know how to do it.

When i start mdk3 it don recognize when i write wlan0 . Only recognize phy0.

But with phy0 i cant get the interfirense recognized so it dont work.

Plese write me down which command lines i have to write to The fix is simple - replace "cut -f1" with "cut -f2"..

You have to write line by line because i am not an expert.

Plese help me changing this so i can start using mdk3.

Thank you so much

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...