Jump to content

Infinitynull

Active Members
  • Content Count

    20
  • Joined

  • Last visited

About Infinitynull

  • Rank
    Hak5 Fan

Profile Information

  • Gender
    Male

Recent Profile Visitors

431 profile views
  1. Experimental Solution Hey Metasploit, I apologize for this delay. The only way I found to "fix" it was to change "/etc/Networkmanager/Networkmanager.conf" to the code below. But even then it causes problems. I just manually change my "/etc/dhcp/dhclient.conf" to the code below. Listen though, if you change your "Networkmanager.conf" to managed as the code below shows. You will not be able to manually set your "dhclient.conf" as I suggest you to do for the whole solution to DNS leaks. The code for the VPN payload on the Packet-Squirrel is only able to rewrite the "resolv.conf" if you have "ifupdown" in manged mode. But I still get DNS leaks even if it is able to rewrite it, so I would only use the recommend solution below. [main] plugins=ifupdown,keyfile [ifupdown] managed=true Recommend Solution So to make all that above, in a short answer. Only change your DNS settings manually through the "dhclient.conf" located at "etc/dhcp/dhclient.conf" that way it stays permanently. Right below this is the line that you will have to change. Be sure to add more than one DNS server, these two are Googles public DNS servers I think. Then type "service network-manager restart" this will update the "resolv.conf" file automatically. prepend domain-name-servers 8.8.8.8, 8.8.4.4; *** I am talking about changing these files on my Linux System (Kali) not the Packet Squirrel. ***
  2. Thank-you for that, I think I figured it out.
  3. I've already tried this, I can manually do this through the dhcp file on my linux machine. But I want to automate this through the Packet Squirrel, I am using the configuration above and it is still not working.
  4. Okay, I have fought with this all last night and today. I watched that video you posted Metasploit. I changed the "FOR_CLIENTS", I also copied the configuration file from NordVPN trying both their UDP and TCP files for many different US nodes. I changed the "auth-user-pass auth.txt" and put my credentials username on one line and password on the second line, and made the "auth.txt" file in the same directory as the configuration and payload.sh. I even tried using this configuration through Kali Linux. It worked and automatically connected and worked. BUT when I tried to automated this with the default switch3 payload on the Packet Squirrel, it will not give me internet access or sometimes it does but doesn't change my IP. Below I posted my configuration file, does anyone know what I am doing wrong? EDIT: APPARENTLY I was wrong, I was googling "what is my ip" It was showing my original IP. Though I tried IP chicken and it changed correctly, then I tried a DNS leak test and it also showed the VPN IP correctly. But I still have a problem, the DNS server isn't changing, I have even tried using different DNS servers. So ignore what was said above these sentences but I still have a problem, my DNS isn't changing to google's DNS server what do I do? Is there a way to add multiple DNS servers in case one fails? #!/bin/bash # OpenVPN payload # Set to 1 to allow clients to use the VPN FOR_CLIENTS=1 DNS_SERVER="8.8.8.8" # Cheap hack to set the DNS server function setdns() { while true do [[ ! $(grep -q "$DNS_SERVER" /tmp/resolv.conf) ]] && { echo -e "search lan\nnameserver $DNS_SERVER" > /tmp/resolv.conf } sleep 5 done } function start() { LED SETUP DIR=$(cd "$(dirname "${BASH_SOURCE[0]}")" && pwd) # Set NETMODE to BRIDGE and wait 3 seconds # to ensure that things can settle [[ "$FOR_CLIENTS" == "1" ]] && { /usr/bin/NETMODE VPN } || { /usr/bin/NETMODE BRIDGE } sleep 3 # Make OpenVPN use the local configuration uci set openvpn.vpn.config="${DIR}/config.ovpn" uci commit # Start the OpenVPN server in the background /etc/init.d/openvpn start # Start SSH Server /etc/init.d/sshd start & # Set DNS server setdns & LED ATTACK } # Start the payload start &
  5. Oh that's perfect, thank you Ulrich Fuchs
  6. Hey guys, I am new to the whole forum thing. I am curious on how to use the VPN payload with my packet-squirrel. I bought NordVPN a while ago, they offer the following files to connect ".crt with .key" and ".opvn". Though I am clueless on how to use these files, I tried copying the ".opvn" to the configuration file. I am sure I am doing this wrong, but I want to learn. I know how to use these files on Linux but not so much with the Packet-squirrel, what should I do? Edit: I have read the documentation, before that comes up thanks.
  7. Yes I did, and it was the same. I just don't think I got it in the root directory. I used the file system through Kali. It was in the same directory as the loot and payloads were in.
  8. I am having the same problem. Another problem the Bunny itself is very hot. I've contacted Hak5 support. This is ridiculous, I own almost every Hak5 product and this has never happened and it seems a hand full of people are having the same problem with no solution.
  9. Another problem the Bunny itself is very hot. I've contacted Hak5 support. This is ridiculous, I own almost every Hak5 product and this has never happened and it seems a hand full of people are having the same problem with no solution.
  10. Apparently I've tried to update to 1.1 incorrectly. It has a solid green on startup then it turns blank. After three times it goes into recovery mode I am assuming. Then once there it blinks red for a while. Then it turns blank again. I've waited ten minutes tried to replug it in assuming something went wrong it it was done. But it never blinks or goes solid green or blue after the red blinking. But just now It was blinking red then started to alternate red to blue. Now it's blank again, I will wait another fifteen minutes before I try anything else. What exactly is going on? I am assuming it's either trying to recover then flash. I moved the upgrade contents to the root file system. I don't know exactly what went wrong. Easier way to understand the problem: Plug In > Solid Green > Blank LED ........ Ten minutes has passed.... Replug In > Solid Green > Blank LED ....... Ten minutes has passed.... Replug In > Solid Green Blank LED ...... Ten minutes has passed.... Replug In > Blinking Red > Couple of Minutes Passed > Blinking Red . Blinking Blue . Blinking Red > Couple of Minutes Passed > Blinking Red > Couple of Minutes Passed > BLANK LED!!!! Ten minutes has passed... Replug In > Solid Green > Blank LED Every time it tries to recover then it will try to boot three times and try to recover again. It will never fully boot up nor will Kali recognize the file system or that it's plugged in.
  11. I'm also interested in this question.
  12. Darren you are the man! I was on and off the forums waiting on the new script. It works like a charm exactly what I needed, looks like you were up pretty late thank you!
  13. Alright, first of all. Adding the route gave me access to the Internet again through my wlan0 device. But even without the route this happened below, I tried manually and entered randomly to show the error. As it did not give me a list at all. I know you said he was working on the script. I thought maybe this would just be helpful. I can access the browser GUI for Pineapple. Though it has no Internet access as the bulletin can not load. I can also access the Pineapple through wireless if I disconnect the USB and power it with the Juice. What do I do? What is ether? I am not trying to be a problem child. I just really want to learn how to use and fix this. root@NKAL:~/Downloads# ./wp6.sh _ ___ _______ ____ _ __ | | / (_) ____(_) / __ \(_)___ ___ ____ _____ ____ / /__ | | /| / / / /_ / / / /_/ / / __ \/ _ \/ __ '/ __ \/ __ \/ / _ \ | |/ |/ / / __/ / / / ____/ / / / / __/ /_/ / /_/ / /_/ / / __/ |__/|__/_/_/ /_/ /_/ /_/_/ /_/\___/\__,_/ .___/ .___/_/\___/ /_/ /_/ v6.3 _ . ___ \||/ Internet: wlan0 192.168.1.1 ( _ )_ <--> [___] <--> ,<><>, Pineapple: ether 172.16.42.42 (_ _(_ ,) \___\ '<><>' Network: 172.16.42.0/24 Connect using saved settings [Y/n]? n Autodetect network configuration [Y/n]? y WiFi Pineapple Interface: ether Internet Interface: wlan0 Default Gateway: 192.168.1.1 Use above autodetected settings [Y/n]? n Select WiFi Pineapple Interface: > Response must be a listed numeric option Select WiFi Pineapple Interface: > Response must be a listed numeric option Select WiFi Pineapple Interface: > 1 Select Internet Interface: > 1 Usage: grep [OPTION]... PATTERN [FILE]... Try 'grep --help' for more information. Kernel IP routing table Destination Gateway Genmask Flags MSS Window irtt Iface 0.0.0.0 192.168.1.1 0.0.0.0 UG 0 0 0 wlan0 0.0.0.0 172.16.42.1 0.0.0.0 UG 0 0 0 eth1 0.0.0.0 192.168.1.1 0.0.0.0 UG 0 0 0 wlan0 172.16.42.0 0.0.0.0 255.255.255.0 U 0 0 0 eth1 192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 wlan0 No Gateway available for selected Internet Interface. And the route -n output EDIT: Wrong output Kernel IP routing table Destination Gateway Genmask Flags Metric Ref Use Iface 0.0.0.0 192.168.1.1 0.0.0.0 UG 0 0 0 wlan0 0.0.0.0 172.16.42.1 0.0.0.0 UG 100 0 0 eth1 0.0.0.0 192.168.1.1 0.0.0.0 UG 600 0 0 wlan0 172.16.42.0 0.0.0.0 255.255.255.0 U 100 0 0 eth1 192.168.1.0 0.0.0.0 255.255.255.0 U 600 0 0 wlan0
  14. Alright I will re post in a minute or two with results. Why can I only post three times a day, have I done something wrong? I bought a lot from Hak5, or is this a anti-spam method?
  15. I need help with this, I can't even use the script. It won't detect that I am using wireless. When manually configuring the interfaces it won't even come up with a list for any option including the default gateway. What do I do? I'm using the nano pineapple and Kali Linux 2.0. The videos don't help me at all.
×
×
  • Create New...