Jump to content

Search the Community

Showing results for tags 'bunny'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Talk
    • Everything Else
    • Gaming
    • Questions
    • Business and Enterprise IT
    • Security
    • Hacks & Mods
    • Applications & Coding
    • Trading Post
  • WiFi Pineapple
    • WiFi Pineapple TETRA
    • WiFi Pineapple NANO
    • WiFi Pineapple Mark V
    • WiFi Pineapple Mark IV
    • Pineapple Modules
    • WiFi Pineapple University
    • WiFi Pineapples Mark I, II, III
  • Hak5 Gear
    • Hak5 Cloud C²
    • Bash Bunny
    • Packet Squirrel
    • LAN Turtle
    • USB Rubber Ducky
    • Plunder Bug
  • Hak5 Shows
    • Hak5
    • HakTip
    • Metasploit Minute
    • Threatwire
  • Community
    • Forums and Wiki
    • #Hak5
  • Projects
    • SDR - Software Defined Radio
    • Community Projects
    • Interceptor
    • USB Hacks
    • USB Multipass
    • Pandora Timeshifting

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests


Enter a five letter word.

Found 20 results

  1. Hallo!! This is my payload, just a python smb server thats points to the switch folder. PROBLEM: it creates the share, but i cant access the files, because the /root/udisk is not mounted. If i boot the bunny in RNDIS, goto the console and do "udisk mount" i can access the files, but I cant mount udisk from inside a payload Any ideas? Is there anything I'm missing. Thx, and keep on developing!! :) #!/bin/bash LED SETUP GET SWITCH_POSITION SWITCHDIR=/root/udisk/payloads/$SWITCH_POSITION LOOTDIR=$SWITCHDIR/loot LED STAGE1 ATTACKMODE RNDIS_ETHERNET udisk mount python /tools/impacket/examples/smbserver.py e $SWITCHDIR & LED FINISH
  2. Hello Guys! I've just received my Bash Bunny and need some Help. I've updated it already and want to use the Document Exfiltration. Can someone explain it step by step, what I've to do? I want to exfiltrate PDFs and .docx from a computer and/or from a USB stick plugged in a computer. Is this possible? Please HELP
  3. Hi. I connected with Putty. OS is Debian. and I want to update it and I want to install android -tools-adb android-tools-fastboot. But I cant. Cause, happening some errors. I changed sources list. But same error. What's problem?
  4. Just some pics for fun. Its beginning to look more like a black scorpion :) They currently operate individually but together. Pineapple grabs the clients optionally with evil portal etc, bashbunny can run metasploit etc against those clients and the packet squirrel is my gateway to wwan (I normally use a mr3020). I was trying to get FAT support on the squirrel too so it could maybe dump the session to the sd card storage of the modem. When you think it's controlled via a few terminal screens on a phone and it can fit in a bag its reasonably stealthy. Not NANO stealthy but still. I normally run this with 12V 2A battery but for the pics I used the USB battery.
  5. Firmware flasher for the Bashbunny, able to flash firmware from 1.1 to 1.5. XXX THIS IS NOT AN OFFICIAL FIRMWARE FLASHER SO USE AT OWN RISK! XXX 1 Drag and drop the .exe file anyware on your computer. 2 Put in your BashBunny. 3 Open the .ps1, and follow the steps on screen. https://github.com/CIPH3R0/BashBunny/tree/master/BunnyFlasher Tell me what you think, any new features you want to see added? for bugs: message me!
  6. Hi, I was looking on making a purchase with devices including the Rubber Ducky but I was also interested to buying the Bash Bunny as well but I've also read on a Reddit forum that it's better to have the Ducky and Turtle together than the Bunny alone. My question is which one should I pair with the Ducky? The Bunny or Turtle? What can they offer me that the other can't? Thanks
  7. I received my replacement bashbunny yesterday and this new one will not perform the firmware update. Here is what I have tried so far: I have the sha checksum verified 1.4 firmware update file on the root of the storage partition and have plugged it into 2 different PCs (one linux and one windows); but it just mounts the storage and boots into arming mode normally. It totally skips the firmware update. I tried the f/w update on a third PC (windows) and it failed to start as well. I even tried the unbricking reset steps provided by Seb. The unbricking reset will not even start. I get no "police" flashing at all. Whenever the bunny is plugged in all it does is mount the storage partition. No reset or firmware update procedures ever begin. I tried to flash the 1.3 firmware as well to make sure it wasn't an issue with the firmware file itself. It just boots normally into arming mode completely bypassing the expected firmware update as it does with the 1.4 version. I also tried running the bunnyupdater version 1.0 and the newer 1.1; no change :(
  8. I have been troubleshooting issues with the bashbunny for as long as it has been available. I got mine as soon as it was released; and it has been nothing but problematic from day one; which is a shame. The device, in theory, is probably the best thing Hak5 has ever come out with; but it practice, it has been the least usable in my experience. Many payloads will not run consistently; if they run properly at all. Every payload that makes use of the USB partition (the one thing that should really allow us to accomplish truly amazing feats) is problematic for many of its customers. The bashbunny forum is littered with threads full of people who cannot get any credential payloads to work because USB writing fails; among other problems. Simple ducky payloads that execute fine on the ducky or on nethunter's duckhunter will not inject properly a fair percentage of the time on the bashbunny. I see mixed character case issues where they shouldn't be and other anomalies. I am really hoping the USB corruption issues and the bizarre injection problems I am having is due solely to the fact that I adopted so early and the rest of the devices are not plagued with these issues; as they make the device unusable. I am pleading with Hak5 support here to please provide me with a replacement. I and my friends have poured countless hours of time and ulcers into trying to get this device to work; with, very little and, no lasting success. Anything we get to to work once or twice is quickly broken by yet another USB corruption issue or other strange injection anomaly. Please help me. I have gone through every unbricking, reflashing, updating, and udisk reformatting operation that support has given and have tried every firmware available. Nothing seems to be able to salvage this bunny. Help me technolust-ken-obee. You're my only hope...
  9. What's the purpose of the undercover bunny payload all it does is make a wifi ap out of a target machine. It is in the remote access section so does it have any other purpose other than use img someone else's machine for Internet?
  10. Has anyone had any success with the jackrabbit payload? It seems to be exactly what I'm looking for; except it's not working at all. It creates the sub-folder for the target in the loot directory; but it doesn't put any data in the folder. Also, it leaves many of its powershell windows open with all of the bashbunny code just sitting there out in the open. It doesn't eject properly either. So, it's not closing its windows, writing any of the target info to the loot folder, or ejecting properly.
  11. I am having trouble using GET TARGET_ID in payloads. To verify it's this specific command causing the trouble, I set up this short script: ATTACKMODE RNDIS_ETHERNET LED STAGE3 Q DELAY 3000 GET TARGET_IP # Check target IP address. If unset, blink slow red. if [ -z "${TARGET_IP}" ]; then LED FAIL2 exit fi LED FINISH and indeed it ends up blinking red. Firmware is 1.3. Any idea? Or is there something wrong in the script? Thanks!
  12. Hi, I was wondering if it was possible to use the bash bunny as a wifi adapter(you plug it into a PC that has ethernet connection and then you can access the connection via wifi).
  13. Im having some issues updating the bash bunny to the most recent firmware. I am currently on the base firmware from when I have purchased the device and have run apt-get update && apt-get upgrade after getting internet with my linux machine. I then download the firmware .tar file from the downloads area and copy the file to the / directory of the bash bunny. I then safely eject the device in arming mode and plug it back in expecting to see a red blinking light. Unfortunately it does nothing and boots to the regular storage mode and nothing has changed. I have searched the forums for help but I can't seem to figure out why this is happening. Can someone help me out with this issue?
  14. So I just got my BashBunny this week and I already love it, but I apparently don't have bunny_helpers.sh after I upgraded my BashBunny from firmware version 1.0 to 1.1. Is there any way I can get it back? I see it isn't in the Git Repository :/
  15. Apparently I've tried to update to 1.1 incorrectly. It has a solid green on startup then it turns blank. After three times it goes into recovery mode I am assuming. Then once there it blinks red for a while. Then it turns blank again. I've waited ten minutes tried to replug it in assuming something went wrong it it was done. But it never blinks or goes solid green or blue after the red blinking. But just now It was blinking red then started to alternate red to blue. Now it's blank again, I will wait another fifteen minutes before I try anything else. What exactly is going on? I am assuming it's either trying to recover then flash. I moved the upgrade contents to the root file system. I don't know exactly what went wrong. Easier way to understand the problem: Plug In > Solid Green > Blank LED ........ Ten minutes has passed.... Replug In > Solid Green > Blank LED ....... Ten minutes has passed.... Replug In > Solid Green Blank LED ...... Ten minutes has passed.... Replug In > Blinking Red > Couple of Minutes Passed > Blinking Red . Blinking Blue . Blinking Red > Couple of Minutes Passed > Blinking Red > Couple of Minutes Passed > BLANK LED!!!! Ten minutes has passed... Replug In > Solid Green > Blank LED Every time it tries to recover then it will try to boot three times and try to recover again. It will never fully boot up nor will Kali recognize the file system or that it's plugged in.
  16. Hey guys? I have been trying the executable installer and usb exfiltrator for bash bunny but it's not working. The only payload that is working is the quickcreds payload. Is it because I installed the tools that the executable installer and usb exfiltrator are not working? I made sure that the "d.cmd", "e.cmd" and "i.vbs" files are in the ROOT of the the bashbunny and the "payload.txt" is in the "switch1" of the Bash Bunny. What is going on? Please help.
  17. Hello, At the moment I'm writing an extension which give some debug information during a payload run. The function START_DEBUG "tail " the /var/log/syslog to /tmp/log.txt (I won't create a extra file because syslog give al lot of more useful information in background.) During payload run I can output some information to syslog with logger With STOP_DEBUG I stop the "tail", test if the /dev/nandf is mounted. If so I Copy /tmp/log.txt to /root/disk/loot. /If not I mount the /dev/nandf to /root/udisk, copy the file, do a sync and unmount the /dev/nandf. Now the Problem. It happens often that when I look in the loot file there is no log file and the FS is corrupted. This happens even I do a sync; sleep 1; sync after copy the file and befor unmounting the FS It seems tha the FS is not unmunted correctly. Sometimes the dirty bit is set. Have somebody any idea? payload.txt debug.sh
  18. Basically up until the 1.1 release update the ducky commands were working perfectly. But now the only language which it can use is US (which is a problem as i live in UK). I have tried everything and looked everywhere on the forums but no luck. As I said it worked before the update so there probably is an easy fix, but any help would be appreciated....
  19. Basically up until the 1.1 release update the ducky commands were working perfectly. But now the only language which it can use is US (which is a problem as i live in UK). I have tried everything and looked everywhere on the forums but no luck. As I said it worked before the update so there probably is an easy fix, but any help would be appreciated....
  20. is it possible to mount say a ntfs (windows) from your computer through say the serial connection? this is what i get with lsblk through serial console or maybe a way to directly boot into the linux distro at startup without putting another distro on the storage..?
×
×
  • Create New...