Jump to content

FreeNAS Problem


mike86
 Share

Recommended Posts

I built my FreeNAS box but it won't seem to boot from the CF card which was inserted into a IDE to CF adapter.  The BIOS doesn't recognize that there's anything in the IDE slot.  I changed the boot order for booting from Hard Drive first, but it still doesn't work.  Any ideas?

Link to comment
Share on other sites

Things to try:

Test the adaper in another computer.

Try it with a known good IDE cable.

test the CF card.

Try another CF card.

This is likely to be a hardware issue. The only way it could be a software issue is if your BIOS just doesn't 'like' the CF adapter.

Link to comment
Share on other sites

Hi Sparda:

Thanks for the quick response.  I have already tested the adapter in another computer and didn't have an issue with it working, it worked fine.  And I tried a IDE cable that I knew was good, hoping that it just wanted to be connected through a cable, but no such luck.  I used the CF in another situation and it worked fine.  I did however swap out my CF card from my digital camera and tested it and I have same result.  Not working. 

Here's the dedicated computer's specs:

Intel Pentium D 2.66 GHz Processor

1 GB DDR2 PC3200 Memory

x4 500 GB Seagate SATA 7200 RPM Hard Drives

Syba IDE to CF Adapter

Kingston 512 MB CF Card

600 Watt Power Supply

All the parts were purchased through NewEgg for this project.  All parts are new. 

When I originally installed FreeNAS, I booted the computer to the CD drive and installed the FreeNAS OS to the CF card.  So I know the computer sees the CF card.  The problem is the BIOS doesn't seem to recognize it to boot from.  I checked all the cables and all are secured.  I also reformatted the CF card and installed FreeNAS using the tool within Windows and it still won't boot.

When I boot up I get the following message:

Intel Boot Agent v4.1.17

PXE-E61: Media Test failure, check cable.

PXE-MOF: Exiting Intel Boot Agent.

My Current Boot Order:

1) Hard Drive

2) Ethernet

3) CD Drive

4) Floppy Drive

I have already tried removing all SATA drives and then booting without success. 

Any ideas?

Thanks,

Mike

Link to comment
Share on other sites

Hi VaKo:

Yes, I forgot to include that.  I went to Intel's site and updated the BIOS by downloading a ISO and booting from the CD drive.  And the BIOS update was successful.  Thanks for the comment on the post.  I'm just trying to get this issue resolved and wanted to give you all the information I had. 

Any Ideas?

Thanks,

Mike

Link to comment
Share on other sites

a little off topic, but that is the most overkill NAS box i have ever seen.

also you said hard drive boot didnt work, was that a sata harddrive that you tried to boot from, or an IDE?

and seriously, if you actually bought this box, i can understand the needing a modern mobo for sata, but you dont need a pentium D, that is overkill, celeron would be better, also ram is a little high for what you need. if this is soley for storage, your money shouldnt go into proccessor and ram, it should go into storage subsystem.

Link to comment
Share on other sites

I wonder why you'd want to boot off of a CF card in a NAS, but anyways.

According to the manual the card, when used like this, should be detected on boot as a harddisk, and bootable. The only thing I can think of is that the jumpers are set wrong, resulting in the card not getting the power it needs. Would be weird though as the card can ben seen once an OS is loaded.

Does your bios detect the 'drive' on boot?

Link to comment
Share on other sites

check for intel's compatability

because they sometimes require a specific format on a harddrive

so try putting the cf card into a different computer and format it using ntfs

dont know if it will work but its worth the try(it wont ruin your card)

if it still doesnt work, just give up and install freenas on one of the HDD it doesnt take much space and it is simple if you use partitions

Link to comment
Share on other sites

Guest requiemnoise

Why FREENAS? I know it is BSD, but go Ubuntu! Another apt-get fan. I can apt-get 35 packages for 35 servers within few seconds... scp configs to my desktop, grep out and pipe in the configs I need than scp back and wham! restart services! APT-GET POWER! You can also download webmin if you want a web interface. Click and click and you are done. I haven't tried FreeNAS, but I heard many codes were borrowed from Monowall firewall which is the best simplest live cd firewall out there. I kind of don't understand why you need to boot off from a small CF if you are planning this machine to store gigs of data.

Link to comment
Share on other sites

That has to be the best 2nd post I've seen in a long time.

without meaning to interrupt the thread, I have to agree, I was gonna say so before I say you post ;)

Nice one mike86, welcome to the community :)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...