Jump to content

Time zone not persisting


deleite
 Share

Recommended Posts

What I have noticed, is that it is persistent in all the places it should be except the WebUI.  I keeps showing that it goes back to UTC.  If you go to /etc and open up TZ it should be set for whatever timezone you set it up as.

Link to comment
Share on other sites

Confirmed, mine doesnt keep TZ over reboot on UI.

I did notice that if i cat /etc/TZ i get 'GMT-1' after a reboot and when i change the timezone without a reboot i get GMT-1.

Selection_026.png

If you wrap any time zone with ' ' then the GUI defaults to UTC.

On a seperate note - if you enter a custom time zone of say UTC+0100 the current timezone field displays UTC-0100. and vice versa. so it seems to reverse the +- thing.

Edited by Just_a_User
Link to comment
Share on other sites

2 hours ago, Sebkinne said:

Can you provide a screenshot of the UI after changing the time zone, and after a reboot?

Just the page where you can change the Timezone please.

Sure.

 

Before changing the TZ

 

T8YUp235NsPqHVrpmS7lhIB0AuA3yMV4iZCSn8RP

cNIhmIFpPnbXSssRWChi5P1XGpB5TKDjzjyfkfDw0hZc68uzmsyH4-OHXUY2tiKF-k-gLPoRAVAakl_58Aa2veIyR2pG3Hn6lrkEt6qYIegpUkAiEjeSxmkDWf3yxIKcyKeT6-E5TXX7GRUVLUyZOLujluoA_XivsBYlDfuMJ8lm_1PkzKzLK4TCkCIatyohxPS8MuKmuip_8gZ7UYTFR7Coh5JBff7rR0xigf4-YTlqTEgNwOiUL1A8j3qTwMVfzNT0ZQhqBkHWXtXz3GnQ9-F4_m5eLIXr0dBx2yuQntUYLmjHY-yBEwLEvjCxraXog9AEhUxj54NzisDuI8AEn3iKRmVjnN1uOkXi2fZgNOb1t_e-Nvn6AlerV9yffuoyBtPhXlw3l68jY_-NaIsTwwrUgUMo_LuIgTk7j2TfLy_ELwycu0JORAKN59wwXQqQQx21kxoIF-YDiX7zfzs5eW_rh3iKsrgZVwL5PB2Z4rvdCNaCx_2ZcFt1o-EnmgwUv_CenYJEzPsfsYPdXsGpbgaouLYS5nKOgPRfck2INxzSXqgIP71vh6nvJwcm0pNYIQlmPa69rG0GQYliMFsqV13mOdE20IRblzgHJ8RZ=w1324-h908-no

 

 

After reboot. 

-dKCNXruSz5KyYx3lTbLYg8HgoPFgm7Y-46uCigC61_RNictKZfY0MeBDvGigKl96opSF69nmJhTX2uTvtgVzC15xFtF4cxpMSMtQzUS_8al_JRYe9uHeCuzTc-Lif8p86KQhsJB7mBX40ZZKq5pI6fyjYUs0upAWLyyuw3Q1cZVPMwRjByexqakGr4zAiSMvQ2ZJu7eufcf-oR-vdE0pygpbYfTEcPPgtq2-eoorvEnYBENSA_PXrQpOvJThhL1112eyJ3QenoE7nczQfqJreS9UHGsr9FMm44jHxWXwYO1a6m6R1YqE1YGiBct248NP2YLVxfN3XfXr5bWsCZc-HaQQGiFuq1eWBXgOerTsZ72WHAWwfQKjP6mpglQL3Tw9BDO1S1UPt5p5xaP_DThsN8BdU1RW71FAf_4TaPdU5yQ18cgWsfyT1V9pP4LFIlHNNgD8AFhmaj_4bqtgLuV7J1uHJgoB9zaLfk7GvY5e_of3Q2pJllJkMOD7YrB5PDwuzN2trC5thDtL6RcMO7CgC_av3Jg0XCcbBNNsLy7qhCDMR8oxfdwI8uvNND4q1pY2zCkyx5eLn2LXqqg3X3_8paDHV8IrDS1HKvNHYoK=w1334-h890-no

 

 

Link to comment
Share on other sites

11 hours ago, Sebkinne said:

Can you provide a screenshot of the UI after changing the time zone, and after a reboot?

Just the page where you can change the Timezone please.

+1 here for this issue. It doesnt phase me but could be a issue for those who like to log there audits. Same as above only a problem in the web interface. Thanks for your time 

Link to comment
Share on other sites

@deleite The images you've provided above seem to be broken on my end but I'm sure this is what they are, yes?

  • Before Changing Timezone: qAIct7x.png
  • After Changing the Timezone:wEuGWbv.png
  • After Reboot:
  • 8YOQZs9.png

Seems to be happening on my pineapple as well but I don't use logging as much as I should >.>

Link to comment
Share on other sites

On 6/13/2018 at 11:52 PM, _0NiTy said:

@deleite The images you've provided above seem to be broken on my end but I'm sure this is what they are, yes?

  • Before Changing Timezone: qAIct7x.png
  • After Changing the Timezone:wEuGWbv.png
  • After Reboot:
  • 8YOQZs9.png

Seems to be happening on my pineapple as well but I don't use logging as much as I should >.>

Yes, the exact same screens. 

Link to comment
Share on other sites

On 6/6/2018 at 8:12 PM, Just_a_User said:

Confirmed, mine doesnt keep TZ over reboot on UI.

I did notice that if i cat /etc/TZ i get 'GMT-1' after a reboot and when i change the timezone without a reboot i get GMT-1.

Selection_026.png

If you wrap any time zone with ' ' then the GUI defaults to UTC.

On a seperate note - if you enter a custom time zone of say UTC+0100 the current timezone field displays UTC-0100. and vice versa. so it seems to reverse the +- thing.

I have exact same issue: TZ not persistent in WebGUI (latest Firefox).

And also setting a Custom Timezone to GMT-2 sets it to GMT+2 and vice versa?! which is funny when you find that out ?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...