Jump to content

OpenVPN


Rainman_34
 Share

Recommended Posts

I am having a bit of an issue and I know everyone here can help me.  I am running a VPN server and want my pineapple to automatically connect to VPN server on startup.  I

installed openvpn on the pineapple and copied the .ovpn file to my sd card.

I then did chmod +x rc.local

I then edited the rc.local file and put the below command at the very top.

openvpn /etc/sd/openvpn/filename.ovpn  (this command works if I do it from the terminal)

However when I power on the pineapple the pineapple does not connect to the VPN.  Do I need to create a bash script and make it sleep for say 60 seconds after startup to give it time to be setup prior to running?

Link to comment
Share on other sites

8 hours ago, Lord_KamOS said:

it might breaks because its a verbose command, try it like this.

openvpn /etc/sd/openvpn/filename.ovpn > /dev/null 2>/dev/null &

I added something that will redirect the output to /dev/null (the void)

I tried that as well and it failed.  Still no connection on boot.

Link to comment
Share on other sites

Is there a repo I can add to get a newer openvpn-ssl package than the default one opkg finds (2.3.6)?

I'm trying to connect to my vpn provider from the nano, but it fails because my VPN provider offers IPv6, which the nano does not support and OpenVPN 2.3.6 exits with a fatal error if the provider offers it and the device doesn't support it. They added some bypass switches in 2.4, but I can't seem to find a openwrt compatible distribution.

Any pointers? Either to fix the IPv6 issue or update to a more compatible OpenVPN.

TIA

Edited by mikew
Link to comment
Share on other sites

  • 6 months later...
  • 1 year later...


Hello friends,

I have a pineapple Tetra I use this as my home server and wanted to connect this with openvpn when booting.

I am also frustrated because i did not make it after the first attempts.

But first please be very very careful with these autoboot directories /etc/init.d

you can cause a lot of damage that fixes only one factory reset and you lose valuable data the solution is very simple ...

 

1. Download the autologin file from your VPN Access server

2. Copy the client.ovpn to your pineapple.


          scp /root/Downloads/client.ovpn 172.16.42.1:/root


3. Connect with SSH with your pineapple


          ssh 172.16.42.1


4. Copy the client file into the ovpn path of the etc directory and change it as a configuration

 

          mv /root/client.ovpn /etc/openvpn/client.conf


5. Restart and see what happens

          reboot


Greetings from Germany !!!

 

Link to comment
Share on other sites

  • 2 years later...

how can I install packages via command line on the Mark 7 pineapple?

I'm trying to install openvpn on the new Mark 7 pineapple.

I've tried:

opkg install openvpn

and get:

Unknown package 'openvpn'.
Collected errors:
 * opkg_install_cmd: Cannot install package openvpn.

 

Link to comment
Share on other sites

Ask Mk7 questions in the Mk7 section of the forum...

always run "opkg update" before trying to install anything

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...