Jump to content

Can't access Bulletins via wlan0 but works fine on eth0


Recommended Posts

TL;DR WifiPineapple Nano works 100% if I use my Ethernet cable, but will not connect to the internet using the Wifi adapter on my Laptop.

Herewith the steps I have taken:


  • Using HP 9740 Laptop, LAN cable disconnected, eth0 down, on-board Wifi connected to my home AP
  • WifiPineapple Nano disconnected
  • Boot Kali Linux 2016.2
  • Run wp6.sh, select [G]
  • Default gateway identified as, select [Y]
  • Internet interface reported as wlan0, select [Y]
  • Detected WifiPineapple on interface eth1, select [Y}
  • Once the light is solid blue, select [C]
  • Detecting WifiPineapple......found.
  • Browse to
  • Log into the WifiPineapple successfully
  • Can browse to google.com, and the rest of the internet
  • Load bulletins and Get Modules doesn't work (as per many other reports in this forum)

Results of route -n:
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface         UG    0      0        0 wlan0   U     0      0        0 eth1   U     600    0        0 wlan0



  • LAN cable plugged in, wlan0 down, (same network as Wifi)
  • Exactly the same steps as above, except I am offered eth0 as the default gateway
  • EVERYTHING WORKS 100%, including loading bulletins and Get Modules

Results of route -n:

Destination     Gateway         Genmask         Flags Metric Ref    Use Iface         UG    0      0        0 eth0   U     0      0        0 eth1   U     100    0        0 eth0


I have attached a full comparison of ifconfig and route -n step by step throughout the process in the hope that someone can shed some light on why it works perfectly with a LAN cable plugged in, but on Wifi I can not get to the Internet from the Nano.

All suggestions greatly appreciated.


    Void Main()



Link to comment
Share on other sites

I am able to ping from both the Kali Linux box and from the WifiPineapple (after ssh'ing to

Both the Ethernet and WIFI configurations result in the same /etc/resolv.conf files:


They start as:

# Generated by NetworkManager

And then change to the text below when I run [C] in WP6.sh

# Generated by NetworkManager
search lan


I changed the /etc/resolv.conf file on the WifiPineapple to:

search lan



And it resolves names, Load Bulletins works, etc. However this is obviously a temporary solution since resolv.conf is overwritten every time the device restarts, or NetworkManager restarts.

I tried a few suggestions that I found on the forum like changing /etc/config/network, but no joy.


Thank you very much for the pointer to DNS being the issue. Any ideas on how to fix it?



Link to comment
Share on other sites

I'm not sure what the problem might be.:wacko:
What happens if you change /etc/resolv.conf to look like this?

search lan

Also try setting nameserver to: and report back :)

Edited by Zylla
Link to comment
Share on other sites

Unfortunately neither or in resolv.com work. 

It only works with


I was wondering if the "metric" of the connection had anything to do with it. I.e. the Pineapple Nano's connection (eth1) has a lower metric than the Wifi adapter (wlan0) which may route traffic to the interface with the lower metric?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...