Jump to content

wlan1 Client Mode Keeps connecting to wlan0


arclights
 Share

Recommended Posts

Hi guys,

I am having kind of a weird problem here. Basically I can't use wlan1 Client Mode to connect to any other AP than the wifi pineapple itself (wlan0). Karma being disabled of course.

I did a factory reset, did the "wifi detect + reboot" command and updated the Network tile. So I don't think there is any issue on that side.

I tried to connect to another AP (with encryption on) through the Network Tile "Client Mode" as well as the the wifi manager infusion with no luck. Each time wlan1 connects to wlan0 (Karma is off). Even if I disconnect wlan0 before trying to connect to the other AP, wlan0 comes back up again and wlan1 connects to it.

Another strange behaviour is that once I tried to connect to another AP and thus wlan1 connected to wlan0, each time I reboot the wifi pineapple wlan1 is automatically connected to wlan0 (both blue and red lights are solid on) even if I disabled wlan1 before rebooting.

I was hoping that some of you smart guys out there might have an idea what the problem might be. Thankx in advance for your help :-)

Cheers

PS: Some additional Input:

cat /etc/config/wireless

config wifi-device 'radio0'
option type 'mac80211'
option channel '11'
option hwmode '11ng'
option macaddr 'XX:XX:XX:XX:XX:XX'
option htmode 'HT20'
list ht_capab 'SHORT-GI-20'
list ht_capab 'SHORT-GI-40'
list ht_capab 'RX-STBC1'
list ht_capab 'DSSS_CCK-40'

config wifi-iface
option device 'radio0'
option network 'lan'
option mode 'ap'
option ssid 'Pineapple5_0950'
option encryption 'none'

config wifi-device 'radio1'
option type 'mac80211'
option channel '11'
option hwmode '11g'
option macaddr 'XX:XX:XX:XX:XX:XX'

config wifi-iface
option device 'radio1'
option mode 'sta'
option network 'wan'

iwconfig wlan0

wlan0 IEEE 802.11bgn Mode:Master Tx-Power=18 dBm
RTS thr:off Fragment thr:off
Power Management:off

iwconfig wlan1

wlan1 IEEE 802.11bg ESSID:"Pineapple5_0950"
Mode:Managed Frequency:2.462 GHz Access Point: XX:XX:XX:XX:XX:XX
Bit Rate=54 Mb/s Tx-Power=27 dBm
RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality=58/70 Signal level=-52 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:196 Invalid misc:0 Missed beacon:0

Edited by arclights
Link to comment
Share on other sites

Have you tried configuring wlan1 using the wireless manager infusion. I had similar problems (internet lag using ICS with wlan1), and determined the configuration set by the network tab had the encryption type and channel wrong. By adjusting the settings either by editing /etc/config/wireless, or using the wireless manager infusion, you might get better results. Good Luck

Edited by 514senica
Link to comment
Share on other sites

I tried to blacklist the MAC Address but it didn't work... and Karma was off anyway.

My /etc/config/wirless

config wifi-device 'radio0'
option type 'mac80211'
option channel '11'
option hwmode '11ng'
option macaddr '00:13:37:a5:09:50'
option htmode 'HT20'
list ht_capab 'SHORT-GI-20'
list ht_capab 'SHORT-GI-40'
list ht_capab 'RX-STBC1'
list ht_capab 'DSSS_CCK-40'

config wifi-iface
option device 'radio0'
option network 'lan'
option mode 'ap'
option ssid 'Pineapple5_0950'
option encryption 'none'

config wifi-device 'radio1'
option type 'mac80211'
option channel '11'
option hwmode '11g'
option macaddr '00:13:37:81:43:d6'

config wifi-iface
option device 'radio1'
option mode 'sta'
option network 'wan'

Link to comment
Share on other sites

Have you tried configuring wlan1 using the wireless manager infusion. I had similar problems (internet lag using ICS with wlan1), and determined the configuration set by the network tab had the encryption type and channel wrong. By adjusting the settings either by editing /etc/config/wireless, or using the wireless manager infusion, you might get better results. Good Luck

I tried to connect through the wifi manager infusion... Enter everything manually, channel, encryption type, etc... and bingo... it connected to wlan0 again :-)

I even tried it after disabling wlan0 beforehand. To no avail, wlan0 came back up and wlan1 connected to it

Link to comment
Share on other sites

arclights,

Your wireless file looks ok except it has no info on another access point for the pineapple to connect to on radio1. Which could lead to wlan1 connecting to what it knows. Which leads to the next issue. You are still broadcasting the default wlan0 AP name. Go into the Karma tile and change that to something other than the default. It shouldn't auto connect after that unless you tell it to.

And when you say you used the wifimanager infusion are you making the changes then hitting save then commit? If you are doing all that make sure to look at the wireless file after to ensure it sticks.

Edited by thesugarat
Link to comment
Share on other sites

The reason this is happening is because of a small bug with the disconnect function. If your interface is set to STA mode and there is no SSID, it will always connect to the default SSID - sorry.

Update your network tile through the pineapple bar to 1.2 (just released) and head over to the clientmode section. From there, you are able to hit disconnect and it will permanently disconnect you. You also will not see the connection to wlan0.

Best Regards,

Sebkinne

Link to comment
Share on other sites

Hi guys,

I managed to make it work... I am actually writing this post "through" the pineapple :-)

Thank you all for your feedback. Danke Dir vielmals Seb... I wish I had that kind of support from our partners at work :-) You are amazing. Thesugarat, saving before committing helped :-) Thankx for the hint.

The disconnect function works well now.

There still seems to be a bug however : The passphrase of my AP contains the character & and it seems this is a problem. I wasn't able to connect to my AP through the network tile at all and had to connect through the wifi manager infusion. When I entered my wifi passphrase through the wifi manager infusion, the passphrase was trunked in /etc/config/wireless. Everything coming after the & character, & included, was missing. I had to edit the /etc/config/wireless file manually to make it work. I suppose that this & character might also cause some problem when trying to connect the network tile.

Thankx again

Cheers all

Link to comment
Share on other sites

Hi guys,

I managed to make it work... I am actually writing this post "through" the pineapple :-)

Thank you all for your feedback. Danke Dir vielmals Seb... I wish I had that kind of support from our partners at work :-) You are amazing. Thesugarat, saving before committing helped :-) Thankx for the hint.

The disconnect function works well now.

There still seems to be a bug however : The passphrase of my AP contains the character & and it seems this is a problem. I wasn't able to connect to my AP through the network tile at all and had to connect through the wifi manager infusion. When I entered my wifi passphrase through the wifi manager infusion, the passphrase was trunked in /etc/config/wireless. Everything coming after the & character, & included, was missing. I had to edit the /etc/config/wireless file manually to make it work. I suppose that this & character might also cause some problem when trying to connect the network tile.

Thankx again

Cheers all

Ach, verdammt. Yeah, fixed and being pushed to the bar right now!

Danke!

Sebkinne

Link to comment
Share on other sites

"Ach, verdammt." i loled at this. and such a fast response time on the fixes. thanks Hak5 crew and contributors.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...