Jump to content

Running Wifi Pineapple With Mac Os X


dmoening
 Share

Recommended Posts

Did you find the OSX thread? The search function here on the forums seems to be broken for me :S In that thread it details how to change the IP address...

telot

Link to comment
Share on other sites

I think it got lost in the move. Here's the screenshots I took on my overloaded laptop though. Should help you guys out.

Can't link the pictures, so here's the links to my picasa...

https://picasaweb.google.com/lh/photo/Ja72Aaz1bvT5ctnd9snpEtMTjNZETYmyPJy0liipFm0?feat=directlink

https://picasaweb.google.com/lh/photo/p8AffkHDY2WnFgXdugVH9dMTjNZETYmyPJy0liipFm0?feat=directlink

Link to comment
Share on other sites

Barry, what firmware version are you running? I do not have a config.php page on mine. When manually typing this in on the URL it redirects me to 172.16.42.1/pineapple/redirect.php and sits in a loop. Going into the config page from the main 172.16.43.1/pineapple page only gives me options to mess with Karma config, DNS spoof, Language and CSS editor. I am running version 2.4.1, which came on the device.

Link to comment
Share on other sites

osx module would kickass! One press of a button and you can swap from osx settings to windows/linux settings would be extremely handy...

telot

Link to comment
Share on other sites

osx module would kickass! One press of a button and you can swap from osx settings to windows/linux settings would be extremely handy...

telot

When I get home I'll mod up the network settings config file. I didn't really bring the right stuff with me to do this at defcon... :rolleyes: (What do you mean I don't have an ethernet cable in my bag!) :lol:

Link to comment
Share on other sites

what about with a MKIII? I have both and My concern is locking myself out of the flash capability.

MK3 is flashed through the ethernet port when the bootloader is loading up, so I can't see any problems of not being able to re-flash in case of problem.

MK4 is flashed through the os when everything is loaded so diff storry if the os or settings are messed up. needs serial

Edited by petertfm
Link to comment
Share on other sites

osx module would kickass! One press of a button and you can swap from osx settings to windows/linux settings would be extremely handy...

telot

Could not agree more telot, A OSX Module would definatly take the Pineapple to the next level of userfriendlyness in theese Apple times.

Thetra

Link to comment
Share on other sites

Okay. Here's the skinny. Lion's ICS is locked to the 192.168.2.0/24 network. There's probably a way to edit some config file, but the only thing in my house that can run it is my wife's macbook air. This guy ain't messing her laptop up!!! Sooo, we edit the pineapple... :lol:

There are two files we need to change, /etc/config/network and /etc/config/dhcp . Configure your laptop to the pineapple network, 172.16.42.42 so we can ssh in and edit things. Cd over to /etc/config and do a;


cp dhcp dhcp.bak
cp network network.bak
[/CODE]

Now nano network and replace with this;

[CODE]
Copyright (C) 2006 OpenWrt.org
config interface loopback
option ifname lo
option proto static
option ipaddr 127.0.0.1
option netmask 255.0.0.0
config interface lan
option ifname eth0
option type bridge
option proto static
option ipaddr 192.168.2.254
option netmask 255.255.255.0
option gateway 192.168.2.1
option dns 8.8.8.8
config interface wan
option ifname eth1
option proto dhcp
config switch eth0
option enable_vlan 1
config switch_vlan
option device eth0
option vlan 1
option ports "0 1"
config interface usb
option ifname usb0
option proto dhcp
[/CODE]

Hit ctrl x to save.

Now nano dhcp and replace with this;

[CODE]
config 'dnsmasq'
option 'domainneeded' '1'
option 'boguspriv' '1'
option 'filterwin2k' '0'
option 'localise_queries' '1'
option 'rebind_protection' '1'
option 'rebind_localhost' '1'
option 'local' '/lan/'
option 'domain' 'lan'
option 'expandhosts' '1'
option 'nonegcache' '0'
option 'authoritative' '1'
option 'readethers' '1'
option 'leasefile' '/tmp/dhcp.leases'
option 'resolvfile' '/tmp/resolv.conf.auto'
config 'dhcp' 'lan'
option 'interface' 'lan'
option 'start' '100'
option 'limit' '150'
option 'leasetime' '12h'
option 'ignore' '0'
list 'dhcp_option' '3,192.168.2.1'
list 'dhcp_option' '6,192.168.2.254,8.8.8.8'
#config 'dhcp' 'wan'
# option 'interface' 'wan'
# option 'ignore' '1'
# option 'start' '100'
# option 'limit' '150'
# option 'leasetime' '12h'
# list 'dhcp_option' '3,172.16.42.42'
# list 'dhcp_option' '6,172.16.42.1,8.8.8.8'
# list 'dhcp_option' '6,172.16.42.1,208.67.222.222'
[/CODE]

Ctrl x to save and exit.

Now go ahead and power cycle the pineapple and configure your ethernet adapter to look like my pic above. Make sure your gateway address is the same as your wifi adapter's address and you should be golden when you start up connection sharing.

Link to comment
Share on other sites

Sticky that shizz! ^^^^

Thanks barry99705!

telot

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...