Jump to content

Installing on the Fon+


Recommended Posts

This is the start of a howto on getting stuff working on the Fon+. I'm going to start it here and transfer it to the wiki once it is complete and can be done as a complete walk through. So, here goes...

These instructions are based on you using linux with a wired interface named eth1, obviously adapt them if you use a different interface. You need a tftp server running. I actually found this the second hardest thing to get running for some reason, it never seemed to start up when it should do. The best way to install this is to use your distro package manager and to follow any instructions in their wiki or howto guides. Once it is running it should be fine from then on.

To start with, grab the redboot.pl script and make sure you have all the dependancies installed, the quick way to test it is it just run it and see if it complains.

Grab the following files and put them in your tftp directory:

Fonera Firmware - this needs to be renamed openwrt-fonera.image

loader.bin

Power down the Fon and attach a network cable between eth1 and the black (LAN) port on the fon.

Set eth1 to 192.168.1.254 and start redboot by running

./redboot.pl 192.168.1.1

It should start complaining about network down.

Power on the Fon. After a second or two you should get a connection and a redboot prompt. If you haven't had one after 20 seconds you've done something wrong, check ip addresses and connections and try again.

At the redboot prompt run the following commands:

fis init
load -r -b 0x80100000 loader.bin

This will grab the file from the tftp server. If it doesn't work then check the server. Test it by trying to download a file on your local machine.

fis create loader

This will take a while (possibly 10 mins+)

fconfig boot_script_data

At this point you'll be given a second prompt, enter

fis load loader
exec

and hit a final return to enter a blank line, that should give you a question about updating redboot, hit y and enter. You'll then drop back to a redboot prompt.

load -r -b %{FREEMEMLO} openwrt-fonera.image

Again, load from tftp server

fis create image

This one is the biggy, it took over 30 mins on my machine. Have patience , you'll go back to a redboot prompt once it is finished. As Darren says, go eat some fruit (I had cherry pie).

After this you'll have a fon flashed with the latest firmware from fonera. This firmware is designed for the next model up from a fon+ so it has a load of extra stuff installed which takes up memory and processor. I'm looking at tidying up these to give a more streamlined device.

To access the fon it should be the same as the original Fon, there will be a WPA protected AP called MyPlace with the serial number as the key. Once on, get a dhcp address and you should be able to ssh in over the wireless. The password for the root user is admin.

As I said, I've started tidying it up but I've got quite a bit of work. I've published this now so that others can start doing the same, any one gets anything good let me know. The bigest problem I'm having is working out the network setup and how to decouple it all without locking myself out completely. There are a lot of firewall rules built in as well, I'm going to consult with Darren on those as they currently lock you out of wired access. I did manage to get wired access through the WAN port by using the web interface to set the Internet IP address to static on a 192.168.0.0 subnet then connecting it to my lan and accessing it from there, the only problem is that to do it I had to remove one of the firewall rules and I can't find which one it was!

A couple of little things I do know, if you do this

echo 1 > /etc/config/registered

the web interface will show you as registered, and I've ran these two sets of commands to remove unneeded start up scripts and modules:

cd /etc/rc.d
rm S39usb S50telnet S98usb_led S99pureftpd S99scanner
cd /etc/modules.d
rm 20-nls-base 20-scsi-core 20-usb-core 30-ppp 30-sound-core 40-scsi-core 50-usb2 60-usb-audio 60-usb-printer 60-usb-serial 60-usb-storage 60-video-core

To stop it from trying to call home, edit /bin/thinclient and put an exit statement on the like after

KEY=/etc/dropbear/key

Looking at what is there, I'm sure that I could easily remove half of it and still have a working system but, as I said earlier, I don't want to screw it up and lock myself out of it completely so I'm going to take it slowly, learn how it works and report back when I know more.

Link to comment
Share on other sites

Thanks!! I look forward to seeing the next steps -- Everything worked up to this point but I'm going to hold off on trying anything else. To contribute, here's an easy / tested / working way to get tftpd running on Ubuntu.

Stolen but slightly corrected from: http://www.davidsudjiman.info/2006/03/27/i...ftpd-in-ubuntu/ :

1. Install tftpd and related packages.

$ sudo apt-get install xinetd tftpd tftp

2. Create /etc/xinetd.d/tftp and put this entry (mind the whitespace):

service tftp
{
protocol        = udp
port            = 69
socket_type     = dgram
wait            = yes
user            = nobody
server          = /usr/sbin/in.tftpd
server_args     = -s /tftpboot
disable         = no
}

3. Make /tftpboot directory

$ sudo mkdir /tftpboot
$ sudo chmod -R 777 /tftpboot
$ sudo chown -R nobody /tftpboot

4. Start tftpd through xinetd

$ sudo /etc/init.d/xinetd start

Save the two files from the original post in /tftpboot and proceed with the first step in the install

Link to comment
Share on other sites

I have tftpd running using your method, also had it working using aftpd. I've tested it - tis fine.

I still cannot get to redboot on my damn Fon+. I've changed eth0 IP to 192.168.1.254. I've tried pinging 192.168.1.1 and it doesn't get a ping even once during the FON's startup.

I've tried on my desktop and my laptop. I'm begining to think there's something wrong with the FON. Can't all be down to my stupidity, as there's nothing really to do on the user-end.

I'd give up and just wait for my Fon-, but I don't like giving up on something that should be so simple o_0

Link to comment
Share on other sites

LordC - the only thing I can suggest is to get a serial cable and attach that, see what happens when it boots.

txx - that is about what I have but for some reason it didn't work for the first few attempts. I ended up with what I thought was the same as I started with but it all working. Who knows, computers are not always the logical things they are supposed to be!

Link to comment
Share on other sites

  • 2 weeks later...

I am new to ubuntu but I am learning a lot. Im running version 8.04. Im having trouble getting the TFTP server going. I followed txx's guide with no problems until I got to:

$ sudo /etc/init.d/xometd start

I get:

* Starting internet superserver xinetd [fail]

Any ideas would be great. thanks a lot guys.

Link to comment
Share on other sites

My fon has arrived, and i got refunded :o because ups lost it for like a week!

Anyone interested in me making a vid of all the steps?

As long as it is accurate then I think it will be ok. The only problem with things like this is that people searching find multiple slightly different ways to do things and so don't know which to trust. If you can stick to a particular script and reference that then it will tie things together.

If you can wait a few days I'll have v2 out and you can do the video on that.

Link to comment
Share on other sites

  • 1 month later...

fast question, what will be installed when using this image :-)

is this a unlocked version of the fonera firmware (ssh enabled) or a fully functional jasager image customized to work on fon+ ?

and if it is the fonera firmware image, why should someone want to first nstall this the doo all the steps again to install openwrt when it can be installed whithout fonera firmare previously installed...

im a bit confused now ;P

please help me interpreting this post correctly :-)

Link to comment
Share on other sites

My instructions here get you the latest fonera firmware which is a modified openwrt. Best you go for the instructions posted by "Rob". See page two of this forum for it.

nevermind, i already test flashed one of my fons so i found it out myself :-)

short question, i can install the following images:

DD-WRT

LEGENT (no eth0)

orginal fon image

this new fon image.

but always when i want to install open-wrt it does not come further then ca 2 seconds after the boot_timeout phase.

so the image is loaded then hangs.

any ideas?

Link to comment
Share on other sites

There is a striped down webif on the fon.

Here is all the packages installed on the fon v2 firmware

autofs - 4.1.4-1 - 
base-files-fonera - 13-r1719 - 
bridge - 1.4-1 - 
busybox - 1.11.1-1 - 
chat - 2.4.3-10 - 
comgt - 0.32-1 - 
coova - 4-1 - 
dnsmasq-fon - 2.45-1 - 
dropbear - 0.51-1 - 
ez-ipupdate - 3.0.11b8-3 - 
firewall - 1-1 - 
fonbase - 1 - 
foncheckrsa - 0.1-1 - 
fonsmcd - 1 - 
fonstate - 1 - 
fuse-utils - 2.7.3-1 - 
haserl-fon - 0.8.0-1 - 
hostapd - 0.6.4-1 - 
hotplug2 - 0.9+r102-2 - 
iptables - 1.4.0-1 - 
iptables-mod-conntrack - 1.4.0-1 - 
iptables-mod-extra - 1.4.0-1 - 
iptables-mod-filter - 1.4.0-1 - 
iptables-mod-imq - 1.4.0-1 - 
iptables-mod-ipopt - 1.4.0-1 - 
iptables-mod-nat - 1.4.0-1 - 
kernel - 2.6.26.2-fonera-1 - 
kmod-fs-ext2 - 2.6.26.2-fonera-1 - 
kmod-fs-ext3 - 2.6.26.2-fonera-1 - 
kmod-fs-vfat - 2.6.26.2-fonera-1 - 
kmod-fuse - 2.6.26.2+2.7.3-fonera-1 - 
kmod-gspca - 2.6.26.2-fonera-1 - 
kmod-input-core - 2.6.26.2-fonera-1 - 
kmod-input-evdev - 2.6.26.2-fonera-1 - 
kmod-ipt-conntrack - 2.6.26.2-fonera-1 - 
kmod-ipt-extra - 2.6.26.2-fonera-1 - 
kmod-ipt-filter - 2.6.26.2-fonera-1 - 
kmod-ipt-imq - 2.6.26.2-fonera-1 - 
kmod-ipt-ipopt - 2.6.26.2-fonera-1 - 
kmod-ipt-nat - 2.6.26.2-fonera-1 - 
kmod-ipt-nathelper - 2.6.26.2-fonera-1 - 
kmod-madwifi - 2.6.26.2+r3314-fonera-1 - 
kmod-nls-base - 2.6.26.2-fonera-1 - 
kmod-nls-cp437 - 2.6.26.2-fonera-1 - 
kmod-nls-iso8859-1 - 2.6.26.2-fonera-1 - 
kmod-nls-utf8 - 2.6.26.2-fonera-1 - 
kmod-ppp - 2.6.26.2-fonera-1 - 
kmod-pppoe - 2.6.26.2-fonera-1 - 
kmod-procgpio - 2.6.26.2+20070323-fonera-1 - 
kmod-sched - 2.6.26.2-fonera-1 - 
kmod-scsi-core - 2.6.26.2-fonera-1 - 
kmod-sound-core - 2.6.26.2-fonera-1 - 
kmod-tun - 2.6.26.2-fonera-1 - 
kmod-usb-audio - 2.6.26.2-fonera-1 - 
kmod-usb-core - 2.6.26.2-fonera-1 - 
kmod-usb-printer - 2.6.26.2-fonera-1 - 
kmod-usb-serial - 2.6.26.2-fonera-1 - 
kmod-usb-serial-sierrawireless - 2.6.26.2-fonera-1 - 
kmod-usb-storage - 2.6.26.2-fonera-1 - 
kmod-usb2 - 2.6.26.2-fonera-1 - 
kmod-video-core - 2.6.26.2-fonera-1 - 
kmod-video-uvc - 2.6.26.2+r215-fonera-1 - 
libdaemon - 0.12-1 - 
libelf - 0.8.10-1 - 
libfonrsa - 0.10-1 - 
libfuse - 2.7.3-1 - 
libgcc - 4.1.2-13 - 
libjpeg - 6b-1 - 
libopenssl - 0.9.8h-1 - 
libpthread - 0.9.29-13 - 
libuci - 0.6.2-1 - 
libusb - 0.1.12-1 - 
mjpg-streamer - r63-1 - 
mtd - 7 - 
ntfs-3g - 1.2531-1 - 
ntpclient - 2007_365-1 - 
p910nd - 0.92-1 - 
ppp - 2.4.3-10 - 
ppp-mod-pppoe - 2.4.3-10 - 
pure-ftpd - 1.0.21-1 - 
qos-scripts - 1.2.1-1 - 
samba3 - 3.0.24-1 - 
sane-backends - 1.0.19-1 - 
sane-libs - 1.0.19-1 - 
tc - 2.6.25-1 - 
uci - 0.6.2-1 - 
uclibc - 0.9.29-13 - 
udevtrigger - 106-1 - 
webif-fon - 0.2-1 - 
wireless-tools - 29-2 - 
zlib - 1.2.3-5 -

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...