Jump to content
Sign in to follow this  
DargFors

Out of space

Recommended Posts

I'm trying to install kismet to the sd card. I've reset my pineapple nano multiple times to see if that would clear space but I still get this error.

 * opkg_conf_write_status_files: Can't open status file //usr/lib/opkg/status: No space left on device.

Here is my disk space

root@Pineapple:~# df
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/root                13312     13312         0 100% /rom
tmpfs                    29784       680     29104   2% /tmp
/dev/mtdblock3            1280      1236        44  97% /overlay
overlayfs:/overlay        1280      1236        44  97% /
tmpfs                      512         0       512   0% /dev
/dev/sdcard/sd1       14102892    104984  13258480   1% /sd

This is right after another reset. Do these numbers look normal? Thank you!

Share this post


Link to post
Share on other sites

Thank you, I did use the --dest option. It installs to the sd card but seems there's some files that still need to be placed on the nano's memory.

Share this post


Link to post
Share on other sites
13 hours ago, DargFors said:

Thank you, I did use the --dest option. It installs to the sd card but seems there's some files that still need to be placed on the nano's memory.

Nano's memory? ........I take it you mean your onboard Nano micro SD?

Share this post


Link to post
Share on other sites

I'm less familiar with the nano over the tetra, but possibly try a firmware recovery to force a clean out of memory.  Might be something going on with the factory reset causing it to not do so.   Then reformat and install your SD card.

 

Share this post


Link to post
Share on other sites

you will need to install it to the sd and them symlink it to the nano.  Also kismet on its own will not run right on the nano, it doesnt have enough ram to support it.  it is best used as a remote capture device.  The same goes with the tetra, it does not have enough ram to run it to the fullest, it is also best if used as a remote capture device.

Share this post


Link to post
Share on other sites

@Infotrace I meant the onboard storage of the nano. @Cap_Sig I will try this and see if that fixes it. @b0N3z Yeah I spoke with Dragorn earlier this week on discord and he said the exact same thing. Luckily thats fine for my purpose, I'll run a full kismet server elsewhere. Thank you everyone for your support.

Share this post


Link to post
Share on other sites
12 hours ago, Cap_Sig said:

I'm less familiar with the nano over the tetra, but possibly try a firmware recovery to force a clean out of memory.  Might be something going on with the factory reset causing it to not do so.   Then reformat and install your SD card.

 

That worked! Here is my filesystem after flashing

Filesystem                Size      Used Available Use% Mounted on
/dev/root                13.0M     13.0M         0 100% /rom
tmpfs                    29.1M    156.0K     28.9M   1% /tmp
tmpfs                    29.1M     80.0K     29.0M   0% /tmp/root
tmpfs                   512.0K         0    512.0K   0% /dev
/dev/sdcard/sd1          13.5G     40.5M     12.7G   0% /sd
/dev/mtdblock3            1.3M    248.0K      1.1M  18% /overlay
overlayfs:/overlay        1.3M    248.0K      1.1M  18% /

Thanks again!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...