Jump to content

[RELEASE] WiFi Pineapple Firmware v2.4.0


Sebkinne
 Share

Recommended Posts

Hi everyone,

We just released firmware version 2.4.0 for the WiFi Pineapple, adding Hak5 Cloud C2 support!

Changelog:

  • Hak5 Cloud C2
  • PineAP
    • Various stability fixes and improvements

Download:
Over the air via your WiFi Pineapple's webinterface, or at  https://wifipineapple.com/downloads

  • Like 2
Link to comment
Share on other sites

  • Sebkinne pinned this topic
  • 1 month later...

is anyone else having issues with live continuous recon scans on tetra? Once stopped i can load the scans but i get nothing appear during the live continuous scan itself.

Also when trying to clone my enterprise network it says successful but i dont see it, it also doesnt seem to have generated a cert as im still being asked to enter details and generate. would it be possible to save the certs or list certs available, maybe import export?

Edited by Just_a_User
Link to comment
Share on other sites

30 minutes ago, Just_a_User said:

is anyone else having issues with live continuous recon scans on tetra? Once stopped i can load the scans but i get nothing appear during the live continuous scan itself.

Which browser are you using? It sounds like the WebSocket we use isn't being opened.

30 minutes ago, Just_a_User said:

Also when trying to clone my enterprise network it says successful but i dont see it, it also doesnt seem to have generated a cert as im still being asked to enter details and generate.

Are the certificates not staying around? You can verify that they were created in /etc/pineape/certs.

Link to comment
Share on other sites

1 minute ago, Foxtrot said:

Which browser are you using? It sounds like the WebSocket we use isn't being opened.

its firefox 63.0 (64-bit)

5 minutes ago, Foxtrot said:

Are the certificates not staying around? You can verify that they were created in /etc/pineape/certs.

Its looking like its not generating any. i only see the default certs

n8rn7WK.png

Also a socket thing?

Link to comment
Share on other sites

19 minutes ago, Foxtrot said:

So I just investigated both issues and couldn't reproduce either, using Firefox 63.0. Could you try a firmware reset?

just did, then latest update. havent installed anything - no modules, no opkg packages nothing. Im working through all addons disabling etc but no difference so far. I am working accross RJ45 via router atm if that makes a difference?

EDIT - @Foxtrot something via my router is kiling it. USB ETH is working for me.  I will have a poke about after some food.

Edited by Just_a_User
Link to comment
Share on other sites

 

38 minutes ago, Foxtrot said:

Make sure your router isn't blocking the WebSocket port. We use port 1337.

or the Pineapple firewall 🙂

added to /etc/config/firewall and works via the RJ45 and router.

config rule 'allowws'
	option name 'Allow-ws'
	option src 'wan'
	option proto 'tcp'
	option dest_port '1337'
	option target 'ACCEPT'
	option family 'ipv4'
	option enabled '1'

@Foxtrot maybe have both set enabled when allowing ui rule?

Edited by Just_a_User
Link to comment
Share on other sites

2 minutes ago, Just_a_User said:

 

or the Pineapple firewall 🙂

added to /etc/config/firewall and works via the RJ45 and router.


config rule 'allowws'
	option name 'Allow-ws'
	option src 'wan'
	option proto 'tcp'
	option dest_port '1337'
	option target 'ACCEPT'
	option family 'ipv4'
	option enabled '1'

@Foxtrot maybe have both set enabled when allowing ui rule?

Very nice find, thank you. It'll be included in the next firmware.

Link to comment
Share on other sites

@Foxtrot So thats the live thing sorted, but the WPA2E/cert clone doesnt seem to have worked still.

Are new certs overwritten or created new in the /etc/pineape/certs/ dir? perhaps named after the network SSID?

EDIT - Does the user need to set up a cert (any cert) before cloning a WPA2E?

EDIT EDIT - @Foxtrot  It looks like you do need to generate a cert (any) before the clone will work. I clicked generate on the default entry data (hak5) and once done it showed my WPA2E that I was attempting to clone. So maybe a check and warning instead of the successful message if attempted?

Anyway, I'm all good now. thanks for your help!

Edited by Just_a_User
Link to comment
Share on other sites

Brand new flash but having issues detecting my TP-722Nv1 - picks up in dmesg but no wlan2 populated. Anyone lese?

[ 4122.450000] usb 1-1: ath9k_htc: USB layer deinitialized
[ 4133.960000] usb 1-1: new high-speed USB device number 5 using ehci-platform
[ 4134.130000] usb 1-1: ath9k_htc: Firmware ath9k_htc/htc_9271-1.4.0.fw requested
[ 4134.430000] usb 1-1: ath9k_htc: Transferred FW: ath9k_htc/htc_9271-1.4.0.fw, size: 51008
[ 4134.680000] ath9k_htc 1-1:1.0: ath9k_htc: HTC initialized with 33 credits
[ 4134.940000] ath9k_htc 1-1:1.0: ath9k_htc: FW Version: 1.4
[ 4134.940000] ath9k_htc 1-1:1.0: FW RMW support: On
[ 4134.950000] ath: EEPROM regdomain: 0x809c
[ 4134.950000] ath: EEPROM indicates we should expect a country code
[ 4134.950000] ath: doing EEPROM country->regdmn map search
[ 4134.950000] ath: country maps to regdmn code: 0x52
[ 4134.950000] ath: Country alpha2 being used: CN
[ 4134.950000] ath: Regpair used: 0x52
[ 4134.980000] ieee80211 phy5: Atheros AR9271 Rev:1

No probs with my Alfa using a Realtek driver so will use that for now.

Edited by Just_a_User
Link to comment
Share on other sites

  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...