Jump to content

Sound problem in linux


G-Stress
 Share

Recommended Posts

Anybody ever get an error like this when running alsamixer

function snd_ctl_open failed for default: No such device

What happened was I was following a ndiswrapper tutorial and for some reason part of it was recompiling the kernel and since I did that now I get that error when running alsamixer.

I've tried messing around in the sound system section if the control center with no luck. I would appreciate it if someone might be able to help me get audio back. I searched and searched for even just a way to restore the kernel to a previous state with no luck:(

Link to comment
Share on other sites

Thanks guys, sorry, again I forget to mention the distro and card and I always try to be as specific as possible.

Anyway I'm using BackTrack a bootable Network Security/Auditing Suite, but I do have it installed to the drive so i'm dual booting.

My card is Realtek AC97 running of a VIA chipset. I just find it weird that after I followed the tutorial it would cause so many problems.

Link to comment
Share on other sites

Well there are drivers available, have you tried running the alsa setup program as root? i can't remember the command (alsasetup or alsaconfig, if i remember rightly) it comes with most distros and will setup your sound in seconds.

I often find this program works even when my distros setup tool fails, if you don’t have it, download it. (try googling for 'alsatools' or 'alsa')

Link to comment
Share on other sites

I did forget to mention, yea I have tried the alsaconfig program, and it doesn't detect my sound card, so it does appear to be a driver issue, just weird how re-compiling the kernel could do that. I guess I will search for driver's for it and see what I can find.

Umm then I'm just not sure exactly how to install/apply the drivers it being linux. Would it just be something like

make && install ?

Link to comment
Share on other sites

When you recompile the kernel, use 'make menuconfig', find the driver for your sound card in there and activate it.

I think Alsa prefers modules, but both modules and compiled-in drivers should work.

Link to comment
Share on other sites

@ Cooper

I tried "make menuconfig" and got the error about no rule or makefile something like that. It's like something was missing so I viewed the man page for make and tried a few things, but could not figure it out. I'm tempted to just format and re-install, but I'm determined to troubleshoot this issue.

@ K1u

is there any good active linux forum you would recommend. I usually only post on pretty active forums.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...