Jump to content

sslstrip not redirect


codeforge
 Share

Recommended Posts

Hi,

i'm using a pineapple wifi V and i cannot use sslstrip working correctly.

When i start karma all is working well and if i connect to a fake wifi that pineapple make i can navigate to internet through it. But if i start sslstrip i cannot navigate to any site. Just loading.... I check /proc/sys/net/ipv4/ip_forwarding and it's set to 1.

I use wlan1 to connect to a wifi in client mode and wlan0 with karma to make fake access point.

Anyone can help me?

When i start sslstrip my output is line in image i attached

post-45754-0-44162400-1388150921_thumb.j

Link to comment
Share on other sites

Sorry to sideswipe, but I have the same issue.....

-Boot Pineapple

-Start Karma - Connect my laptop to Pineapple AP

-Can browse web on laptop fine

-Start sslstrip - Browsing is VERY intermittent

When I start browsing I get "this page cannot be displayed", however, if I refresh the page it appears, but this doesn't always work! and when it does it doesn't strip the ssl. However, it does occasionally work, but this is rare.

Any help would be appreciated

Thanks

Link to comment
Share on other sites

Hi Sebby,

I'm on the latest firmware, and have re-flashed the pineapple. The sslstripping just doesn't work - Now more than often it doesn't do any stripping what so ever :( - Just goes to the webpage as https.

Not sure where to go from here.....

Link to comment
Share on other sites

  • 4 weeks later...

Chrome and firefox have implented a protection against SSLstrip. It's called HSTS

https://www.owasp.org/index.php/HTTP_Strict_Transport_Security

It's automatically redirect certain website to https. Preventing the use of sslstrip.

It might be your problem.

This is true.

But it depends also if the website has implemented the HSTS headers on its side.

Link to comment
Share on other sites

  • 4 weeks later...

I'm having the same problem. Mark V, latest firmware and tried re-flash.

It's only a problem on some websites like facebook or i.e. hak5 forums where https is used, it keeps loading the webpages forever.

This renders the function pretty useless to me.

I've got the same problem. Tried updates, re-flashing, ect. It like SSL strip never starts correctly i.e. I don't get any output from the SSLstip module when running it.

Link to comment
Share on other sites

  • 3 weeks later...
  • 1 month later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...