Jump to content

Unable To Use Wifi


condor
 Share

Recommended Posts

I have suddenly lost the ability to connect to mkiv using wifi. I was using 2.3.1 @ the time I began having problems. I have upgraded and tried 2.4.0 as well as 2.5.0 to see if this resolves the issue. It does not.

I had just stuffed the pineapple and an isound battery pack into a leather travel case (to test for stealth). I moved about the house with this set-up, used it and everything. Later that night I began having the connection issues.

I have noticed that it still sends beacons. It responds to probe requests, however I get back an 'unable to get IP' error message when using wicd network manager in bt5. iPhones are unable to connect as well as android, blackberry, and windows. I have also attempted using alternate antennae on both the pineapple and an awus036h. Sometimes after a reboot(of pineapple) I am able to use the external 036h on my netbook to connect, but once I try with my internal wifi card, all hopes are lost for any device. This is very disheartening. I want to cry, lol. It is the second pineapple I have been through...

*I can use ethernet and dig around using ssh, I think I am pretty adept at ifconfig, iw, and related commands, but I am still very new to config files and the such. PLEASE HELP!

Link to comment
Share on other sites

Have you checked the config files for correct DHCP config?

And what is your setup? Running it standalone?

I have not yet checked anything dhcp related, however I think (hope) this is the source of the issue, as if it is hardware related, I'm probably f*cked.

I almost always use it standalone. ZTE MF591 for 3G and reverse autossh. I have at times set it up using the WAN port with my home router, but this is just for testing and tweaking.

Please provide step by step what you have tried to do.

If you reflash to 2.5.0 with no other modifications does it work?

I just got home from work, have to go pay for kids school and meet w/ teachers. $3750 + $300(school supplies) and they still have a 'fee-night' ? =( I want another pineapple, not to spend 5k at church!

I will most certainly do another test. And I will document it for your viewing pleasure. Thank you both for replying.

Link to comment
Share on other sites

Hey Condor,

First of all, sorry that you are having difficulties.

In my eyes there are two possible causes for your issues, hardware or software.

In terms of hardware, make sure to check the rp sma (pigtail) connector. How is the signal strength?

Has it dropped? If not, It seems software related.

If it is indeed software related, it could have resulted from an unclean flash. There is a (very) small chance that flashes and upgrade can go wrong.

I recommend you re-flash 2.5.0 again. Doing so should eliminate some possible causes. I realize you upgraded and the problem persisted but I would still advise it.

If all that fails, you should try to perform a clean flash over serial. That should get rid of any issues.

Let me us know what you come up with.

Best Regards,

Sebkinne

Link to comment
Share on other sites

I have similar issues when i boot the MarkIV with an alfa awus036h. If I cold-boot the device then plug in the alfa, everything works fine... but if i cold-boot with the alfa plugged in, the MarkIV's radio doesnt seem to work properly.

I haven't done much troubleshooting though. I will post logs later, if I get a chance.

Thanks

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...