Jump to content

I need help with linux


silentknight329
 Share

Recommended Posts

ok so i installed ubuntu 8.04 on my u90, but i am having many troubles... i dont know how to 'install' my drivers they give a how-to thing but i'm still totally lost... i dont know how to do anything in the terminal nothing... so if you guys/gals wanna give me a hand on tackling the linux thing i need all the help i can get

~silent

Link to comment
Share on other sites

Maybe a link to this how to thing?

Also have you tried any Redhat based distros? 8-)

I'm not a big fan of Debian.

Link to comment
Share on other sites

sorry for the uber late reply... i'm trying to install my wifi drivers... cant remeber the exact name of the file... its the realtek one.... i'll post an copy of its "instructions" tomorrow...

The first thing to check with Ubuntu is to go to (*fires up the remote VM to double-check where*) System|Administration|Hardware Drivers, and check if Ubuntu can install them for you (not sure about Realtek, but it's usually pretty good about that sort of thing, although they are sometimes out of date). If it can't, then please post a link to the file you downloaded, as well as the tutorial, and I'm sure either myself, or whoever gets to it first can help you out.

If you found a source tarball (e.g. *.tar.gz or *.tar.bz2), then here's the gist of what you'll be doing. Most drivers (modules) are packaged with the kernel. However, due to licensing, some aren't allowed to be packaged and distributed that way. In some cases (e.g. ATI), they have a nice binary that you download, and it packages them up for you. In other cases, you have to take the module source, and compile it against your running kernel version. This involves downloading the kernel header files (or occasionally the full sources), and doing some console-fu. It's not all that hard (if things go well), but you have to know what you're doing. In either case, I'm sure we can walk you through it.

P.S. learn to love the console, and it will become your best friend :D

-Jeff

Link to comment
Share on other sites

First thing to do is plug your computer into an ethernet network, presuming your computer has recognised ethernet drivers (I've never been in a situation where it hasn't auto-recognised Ethernet in Ubuntu).

Open terminal and run:

sudo su

<enter password at prompt>

<you are now a super user>

apt-get update

<runs commands & gets updated librarys>

apt-get upgrade

<runs commands and gets latest drivers & software>

This should locate your hardware drivers, if not.. post back.

Link to comment
Share on other sites

The first thing to check with Ubuntu is to go to (*fires up the remote VM to double-check where*) System|Administration|Hardware Drivers, and check if Ubuntu can install them for you (not sure about Realtek, but it's usually pretty good about that sort of thing, although they are sometimes out of date). If it can't, then please post a link to the file you downloaded, as well as the tutorial, and I'm sure either myself, or whoever gets to it first can help you out.

If you found a source tarball (e.g. *.tar.gz or *.tar.bz2), then here's the gist of what you'll be doing. Most drivers (modules) are packaged with the kernel. However, due to licensing, some aren't allowed to be packaged and distributed that way. In some cases (e.g. ATI), they have a nice binary that you download, and it packages them up for you. In other cases, you have to take the module source, and compile it against your running kernel version. This involves downloading the kernel header files (or occasionally the full sources), and doing some console-fu. It's not all that hard (if things go well), but you have to know what you're doing. In either case, I'm sure we can walk you through it.

P.S. learn to love the console, and it will become your best friend :D

-Jeff

yah i got a .tar.gz file thats also where i got the "instruction" thing from which i didnt understand

First thing to do is plug your computer into an ethernet network, presuming your computer has recognised ethernet drivers (I've never been in a situation where it hasn't auto-recognised Ethernet in Ubuntu).

Open terminal and run:

sudo su

<enter password at prompt>

<you are now a super user>

apt-get update

<runs commands & gets updated librarys>

apt-get upgrade

<runs commands and gets latest drivers & software>

This should locate your hardware drivers, if not.. post back.

there were no hardware drivers detected

Have you tried 8.10?

there was no updates

no i have not tried 8.10 could you please give me a link to the usb version thanx

and here is the package i downloaded

rtl8187se_linux_26.1022.0904.2008_Release.tar.gz

it gives me a readme but it makes no sense to me

RTL8187SE Linux Driver v1000.1220.2007 for linux kernel 2.6

  - Support Client mode for either infrastructure or adhoc mode
  - Support WEP and WPA/WPA2 PSK connection
  - Support WMM

================================================================================
===============
&lt; Component &gt;
The driver is composed of several parts:

    (1)Script ot build the modules
        makedrv

    (2)Script to load/unload modules
        wlan0up
        wlan0down

    (3)Script and configuration for DHCP
    wlan0dhcp
        ifcfg-wlan0

    (4)Supplicant source code
    wpa_supplicant-0.5.3.tar.gz
        
    (5)Example of supplicant configuration file
    wpa1.conf




&lt; Installation &gt;
Running the scripts can finish all operations of building up modules from source code and start the nic:

    (1)Build up the driver from the source code
             ./makedrv

        (2)Load the driver module to kernel and start up nic
            ./wlan0up
           (if "insmod: error inserting 'r8180.ko': -File exists." met,
            ./wlan0rmv
        ./wlan0down
        ./wlan0up
        should be OK.
       )
    (3)Refer to &lt; Set wireless lan MIBs &gt; to set Wireless LAN specific parameters.

&lt; Set wireless lan MIBs &gt;
This driver uses Wireless Extension as an interface allowing you to set
Wireless LAN specific parameters.

Current driver supports "iwlist" to show the device status of nic

        iwlist wlan0 [parameters]
where

        parameter explaination          [parameters]    
        -----------------------         -------------   
        Show available chan and freq    freq / channel  
        Show and Scan BSS and IBSS     scan[ning]          
        Show supported bit-rate         rate / bit[rate]        
        Show Power Management mode      power             

For example:

    iwlist wlan0 channel
    iwlist wlan0 scan
    iwlist wlan0 rate
    iwlist wlan0 power


Driver also supports "iwconfig", manipulate driver private ioctls, to set MIBs.

        iwconfig wlan0 [parameters] [val]
where

        parameter explaination      [parameters]            [val] constraints
        -----------------------     -------------           ------------------
        Connect to AP by address    ap                      [essid]
        Set the essid, join (I)BSS  essid                     [mac_addr]
        Set operation mode          mode                  {Managed|Ad-hoc}
        Set keys and security mode  key / enc[ryption]          {N|open|restricted|off}


For example:

    iwconfig wlan0 ap XX:XX:XX:XX:XX:XX
    iwconfig wlan0 essid "ap_name"
    iwconfig wlan0 mode Ad-hoc
    iwconfig wlan0 mode essid "name" mode Ad-hoc
    iwconfig wlan0 key 0123456789 [2] open
    iwconfig wlan0 key off
    iwconfig wlan0 key restricted [3] 0123456789

&lt; Getting IP address &gt;
After start up the nic, the network needs to obtain an IP address before transmit/receive data.
This can be done by setting the static IP via "ifconfig wlan0 IP_ADDRESS" command, or using DHCP.

If using DHCP, setting steps is as below:
    
    (1)connect to an AP via "iwconfig" settings
        iwconfig wlan0 essid [name]    or
        iwconfig wlan0 ap XX:XX:XX:XX:XX:XX

    (2)run the script which run the dhclient
        ./wlan0dhcp
           or 
        dhcpcd wlan0
                  (Some network admins require that you use the
                  hostname and domainname provided by the DHCP server.
                  In that case, use 
        dhcpcd -HD wlan0)



&lt; WPAPSK &gt;
WPA_SUPPLICANT help the network to communicate under the protection of WPAPSK mechanism
    
    (1)Unpack source code of WPA supplicant:
        tar -zxvf wpa_supplicant-0.4.9.tar.gz
        cd wpa_supplicant-0.4.9
    
    (2)Create .config file:
        cp defconfig .config
        
    (3)Edit .config file, uncomment the following line:
        #CONFIG_DRIVER_IPW=y.
        
    (4)Build WPA supplicant:
        make
        
    If make error for lack of &lt;include/md5.h&gt;, install the openssl lib:
     1. Install the openssl lib from corresponding installation disc:
        Fedora Core 2/3/4/5(openssl-0.9.71x-xx), Mandrake10.2/Mandriva10.2(openssl-0.9.7x-xmdk),
        Debian 3.1(libssl-dev), Suse 9.3/10.0/10.1(openssl_devl), Gentoo(dev-libs/openssl), etc.
     2. Download the openssl open source package from www.openssl.org, build and install it.
     
    (5)Edit wpa_supplicant.conf to set up SSID and its passphrase.
    For example, the following setting in "wpa1.conf" means SSID to join is "BufAG54_Ch6" 
    and its passphrase is "87654321".

        network={
            ssid="BufAG54_Ch6"
            proto=WPA
            key_mgmt=WPA-PSK
            pairwise=CCMP TKIP
            group=CCMP TKIP WEP104 WEP40
            psk="87654321"
            priority=2
        }
        Note: 1. proto=WPA for WPA, proto=RSN for WPA2.
              2. If you want to connect an AP which works under WPA2 mixed mode, you'd better
                 use Realtek customed wpa_supplicant package.


    (6)Execute WPA supplicant (Assume 8185 and related modules had been loaded):
        ./wpa_supplicant -D ipw -c wpa1.conf -i wlan0 &amp;

sorry for the extremely long post

Link to comment
Share on other sites

I'm not exactly sure where you got the tar package from, but I was able to find pre-compiled versions of the RTL8187SE wifi module for Ubuntu. Assuming that this is the module that corresponds to your wifi card, the easist way to get your wireless working would be to download the .deb package.

I found it here and according to the author's website the latest version of the package is this one.

There is a longer list of other packages, including for 8.04 here.

I'm pretty sure that it should install with

dpkg --install name-of-package.deb

If it tells you that there are unmet dependencies, try

apt-get install name-of-whatever-it-complains-about name-of-something-else

Hope that helps.

Also, should mention, I've never used it, but I believe that Linux Mint is basically Ubuntu made easy (which was supposed to be Debain made easy). You might want to try that.

Link to comment
Share on other sites

I'm not exactly sure where you got the tar package from, but I was able to find pre-compiled versions of the RTL8187SE wifi module for Ubuntu. Assuming that this is the module that corresponds to your wifi card, the easist way to get your wireless working would be to download the .deb package.

I found it here and according to the author's website the latest version of the package is this one.

There is a longer list of other packages, including for 8.04 here.

I'm pretty sure that it should install with

dpkg --install name-of-package.deb

If it tells you that there are unmet dependencies, try

apt-get install name-of-whatever-it-complains-about name-of-something-else

Hope that helps.

Also, should mention, I've never used it, but I believe that Linux Mint is basically Ubuntu made easy (which was supposed to be Debain made easy). You might want to try that.

mint linux is just as easy as regular ubuntu but mint is prettier.

Link to comment
Share on other sites

ok i downloaded the drivers for the 8.04 because i couldnt dl 8.10.. and it gave me this

dpkg - warning: downgrading linux-rtl8187se-modules from 1023.2@2.6.24.22.24 to 04coffee@2.6.27.10.13.
(Reading database ... 116836 files and directories currently installed.)
Preparing to replace linux-rtl8187se-modules 1023.2@2.6.24.22.24 (using test.deb) ...
Restoring previous drivers from backup.
Previous drivers restored.
Unpacking replacement linux-rtl8187se-modules ...
dpkg: dependency problems prevent configuration of linux-rtl8187se-modules:
 linux-rtl8187se-modules depends on linux-generic (&gt;= 2.6.27.10.13); however:
  Version of linux-generic on system is 2.6.27.9.13.
dpkg: error processing linux-rtl8187se-modules (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 linux-rtl8187se-modules

~silent

Link to comment
Share on other sites

have you tried aircrack-ng's driver? it always works for me :) including in ubuntu.

although i stopped using ubuntu when airodump-ng was showing 0 power on all AP's with the newer kernel and any driver/chipset i tried. except the built in intel 802.11b card.

ubuntu is a great starting OS. and also does well for the script kiddies lol. was building a nice little white hat hack box on ubuntu but gave up when having issues with drivers. had support for my laptops bluetooth, irda, modem and any wireless card i chucked in it. had most tools installed that backtrack had and it was prime but fail, hours of work down the drain.

Link to comment
Share on other sites

ok, so according to this, you already have the module installed. dpkg says that you're downgrading the module,

dpkg - warning: downgrading linux-rtl8187se-modules from 1023.2@2.6.24.22.24 to 04coffee@2.6.27.10.13.

however, i think that there is a mistake somewhere, or that the version of the newer driver is written in a way that causes dpkg to misinterpret the version number, because the one that you already have is version 2.6.24.22.24 and the newer one is 2.6.27.10.13

if you already have the module installed, then i would think that simply upgrading it will not do anything. It should already just work.

lines like this one mean that the package depends on other packages that are either absent, or present at too low a version.

linux-rtl8187se-modules depends on linux-generic (&gt;= 2.6.27.10.13); however:
  Version of linux-generic on system is 2.6.27.9.13.

the reason why this happend in your case, i'm guessing, is because you downloaded the version for 8.10, when you're using ubuntu 8.04. The version you have is already newer than the version for 8.04 on the website that i gave you

also, to be honest, i don't understand what the difference between these two drivers are

linux-rtl8187se-modules-04coffee@2.6.27.10.13.deb

linux-rtl8187se-modules-1023@2.6.27.10.13.deb

are you sure that the problem is not that you don't have the correct modules, but that you're just not configuring the network properly?

Link to comment
Share on other sites

mint linux is just as easy as regular ubuntu but mint is prettier.

YES, thats what i am using atm. The newer version(6 RC1) is great. Just do a dist-upgrade once installed and everything is fine. The new restricted driver manager works awesome, no more hunting for the hard to find drivers. It also comes preinstalled with the nvidia and ati driver manager software.. IMO if your new, try mint, and if your not love mint.

Link to comment
Share on other sites

also, to be honest, i don't understand what the difference between these two drivers are

linux-rtl8187se-modules-04coffee@2.6.27.10.13.deb

linux-rtl8187se-modules-1023@2.6.27.10.13.deb

ok, so i went and found out

there is an official release + a "coffee" fork (the guy who forked it has a name that sounds like coffee)

that's the difference between these two packages

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...