Jump to content

Setting up a SD Card on the NANO using Windows 10


Recommended Posts

Whats up everyone so Im somewhat new to the Wifi Nano and Command Prompt. So that being said I need help mounting a sd card on the Wifi Nano in Command Prompt or if there is a way to do on the Nano web interface. Any help would be great.

Link to comment
Share on other sites

This can't be right - and I'm definitely having problems generating consistent results.  Surely, I don't have to format the SD card every time I want to mount it, right?

I've got a 32GB uSD card in my nano - and have 'formatted' it multiple times - and, exactly ONE time, it then showed up (under the Resources window).  Then I went about downloading and installing modules onto it - and then rebooted, and... it's gone.

There's GOT to be a way to mount it (if not via the web console, then simply via the CLI with # mount /dev/sda1 or ...

I think I must be missing something as it pertains to fstab (and the "Save Fstab" button in the web console).  I'm happy to RTFM, if someone can point me in the right direction??


Happy Friday!

Link to comment
Share on other sites

Bizarre.  Now, it has showed up two times:  I pulled the uSD from the nano (after countless attempts to format it from the web console, and even trying my hand at this gist:


(for the record - it didn't work for me either).  I tried stepping through the commands, one at a time, by hand... and still no dice.

So, finally, I pull the card, put it in a reader and plug it into the Mac.  Mac declares it 'unreadable', opens disk utility, and allows me to format it (I selected MS-DOS (FAT), assuming this would provide the greatest interoperability).

Returned the SD card to the Nano, powered it up, and... Voila!  The SD card was there.  I did a 'Save Fstab' in the console UI, and then proceded to download and install a handful (okay, perhaps two handfuls) of modules and installed them to the SD card successfully.  Eventually powered down the device... and now, a few hours later - upon reboot... no /dev/sdb anymore??

I'm obviously doing something wrong - as this just can't be this hard!

Thanks for any assistance.

Link to comment
Share on other sites

  • 1 year later...

I have followed all of these similar stories....


I recently formatted a 32gb to MS-DOS, popped it into the nano and then went to Advanced, and format SD card. I'm not seeing a messag of failure or success. I try to download a module and I get the message that I need to install a SD card. I am goign to try another SD card, but is there anything else I need to do? Save the Fstab? 

Link to comment
Share on other sites

  • 3 years later...


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...