Jump to content

Troubles with FW upgrade


Recommended Posts

Hi guys,

I recently received the Packet Squirrel. The first thing I did was to try upgrading to the latest firmware. I've followed the guide, but the PS only boots and starts blinking with a blue light. I left it in for a good hour the first time, but nothing happened. I tried with both v. 1.1 and v. 1.2 with the same result. I also can't get the default payloads to work. I am able to login in Arming mode and I could confirm it's running FW 1.0. Any tips? I still haven't tried to do a Factory Reset.

  • Upvote 1
Link to comment
Share on other sites

Did you do a checksum check?

Let's assume you're trying to install 1.2, follow the below process:

- Download the upgrade file here (SHA-256: c1f2cbe2096fd04df3a91721b447573b1005894809592d0a76bf865992d16b7a)
- Verify checksum (if you're using Windows you should be able to right-click the file, select CRC SHA and then select SHA-256 and verify the output is the same as above)
- Copy the file to your NTFS USB without changing the name or anything like that. Make sure it's in the root of the USB, so not in any folders.
- Plug the USB into the PS and power on the PS while it's in arming mode
- The LEDs should follow this kind of combination:

  1. Green flashing – booting up
  2. Red/Blue alternating – beginning firmware flash
  3. Solid Red or Blue – firmware flash in progress
  4. Green flashing – rebooting
  5. Blue flashing – upgrade complete, arming mode ready

See how this goes. If there are still problems I would check the filename and verify the checksum (maybe Windows is playing around with the file as it copies it) again.

If there are STILL problems, I would suspect that the problem is to do with the PS missing the module that tells it to update if there's an upgrade.bin on the USB.

Link to comment
Share on other sites

  • 1 month later...

Any update or solution on this topic?  I'm having the same issue.  I have formatted my USB drive to spec and can get into the Squirrel via SSH, but when I copy either of the firmware .bin files(1.1 or 1.2) to the USB drive, insert it into the Squirrel and power up (with the switch to the far right) it boots up without upgrading the firmware.  I re-formatted the drive from the squirrel, but my windows box wouldn't recognize the drive after.  So, I assume the USB was found on the squirrel, but not formatted to a windows format.  Any help would be appreciated.  I have confirmed that I am currently on firmware 1.0.

Thank you,


Link to comment
Share on other sites

  • 8 months later...
  • 9 months later...
On 11/1/2018 at 1:56 PM, Ph0xy said:

@spencer6524@gmail.cpm format the drive via the packet squirrel's "reformat_usb" command, then move the upgrade file & try again. 

I ran into the same issue and this fixed it. 

+1 for this. Just got mine and trying to upgrade using 2 different flash drives formatted NTFS and EXT4 by two different computers (Windows and Kali/gparted) all failed. (followed directions and verified sha256sum after copy to drive, tried 2.0, 3.0, and 3.1 firmware files)

Put a drive in a used "reformat_usb", upgrade to 2.0 worked first time, then upgrade to 3.0 worked first time.  Seems like the device is particular about something about the filesystem. 

If others are having trouble (just boots into arming mode, seemingly ignoring the upgrade file on the flash drive), try this method. 

  • Like 1
Link to comment
Share on other sites

10 hours ago, Jtyle6 said:

It's bug with the ntfs and VFAT formatted USB storage. 

I had to sftp over the update file and do the pineapple manual firmware upgrade. 



I was upgrading from 1.0. I tried to upgrade to 2.0, 3.0, and 3.1. All failed until I formatted the drive using "reformat_usb". Is this bug known to exist in 1.0 firmware as well?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...