Jump to content

dpkg problem


Recommended Posts

guys my linux box is having a problem with dpkg i tried to do

apt-get -f install

still doesn't work it brings up:-

root@XXXX:/home/XXXXXXX# apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
libgtk2.0-dev libnids-dev
Suggested packages:
The following packages will be upgraded:
libgtk2.0-dev libnids-dev
2 upgraded, 0 newly installed, 0 to remove and 45 not upgraded.
2 not fully installed or removed.
Need to get 0 B/3,754 kB of archives.
After this operation, 5,941 kB of additional disk space will be used.
Do you want to continue [Y/n]? y
dpkg: dependency problems prevent configuration of libgtk2.0-dev:
libgtk2.0-dev depends on libgtk2.0-0 (= 2.20.1-2); however:
Version of libgtk2.0-0 on system is 2.24.10-0ubuntu6.1.
libgdk-pixbuf2.0-dev (2.26.1-1ubuntu1.1) breaks libgtk2.0-dev (<< 2.21.3) and is installed.
Version of libgtk2.0-dev to be configured is 2.20.1-2.
dpkg: error processing libgtk2.0-dev (--configure):
dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of libnids-dev:
libnids-dev depends on libnids1 (= 1.20-1); however:
Package libnids1 is not installed.
dpkg: error processing libnids-dev (--configure):
dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

so need help. :)

Link to comment
Share on other sites

try removing it first(with a purge, not just a remove, since this will remove configuration files as well), then apt-get update, upgrade and dist-upgrade, then apt-get install the file itself after its gone and cleaned out. If it gives errors, try the -f to fix(but most likely won't, since you need the dependencies, or the files you have installed it works with, themselves are damaged or not from the dev branch).

What distro are you running though? It may not work with your kernel or distro depending on the system and repos for the distro. Had similar issues trying to get flash working on my wife's ubuntu, but removing all of it and then finding the right development files got it fixed to latest version, even though they said 11 was last made for linux, we got flash 16 on linux working now(I think partially due to installing chrome which added missing libs needed since they use pepper version of flash, but it made it work) so something missing may be causing the errors or you need to update the dependencies with another source list from a development branch of files.

Link to comment
Share on other sites

While I usually use apt-get to install new packages, when I get dependency issues I find that aptitude can really help resolve them. Try doing your install with aptitude and see how you get on.

Link to comment
Share on other sites

aptitude is not installed in my box but when i try to install it still errorrrrrrrrrrrrrrrr.

root@XXXXXX:/home/XXXXX/XXXXXX/XXXXXX# apt-get install aptitude
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
aptitude : Depends: libboost-iostreams1.46.1 (>= 1.46.1-1) but it is not going to be installed
Depends: libcwidget3 but it is not going to be installed
Recommends: libparse-debianchangelog-perl but it is not going to be installed
libgdk-pixbuf2.0-dev : Breaks: libgtk2.0-dev (< 2.21.3) but 2.20.1-2 is to be installed
libgtk2.0-dev : Depends: libgtk2.0-0 (= 2.20.1-2) but 2.24.10-0ubuntu6.1 is to be installed
libnids-dev : Depends: libnids1 (= 1.20-1) but it is not installable
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

Link to comment
Share on other sites

The branch of software you want is not compatible with your kernel and other libs and as Cooper pointed out, no installable, or you need to add the other source lib dependencies from the development branches if they have them for your flavor of linux. They may have other packages that will work, but they'll be specific for your distro and should have their own repos you need to add to get them to install if possible. Not all linux flavors are the same. If you ever worked with older Back Track, you would find that the kernel and drivers, were maintained from the Back Track team with their own repository for software that if you tried installing other debian versions, things would break because it was a specially modified version of linux for special tools made just for that distro, as I would suspect is the issue with BackBox.

In this instance, the question would be better asked here: https://forum.backbox.org/software-support/?PHPSESSIDBB=6242grko2k1ou73lqih5pbju16 since they maintain a specialized distro for pentesting, and as such, tools will need to be modified from source in a lot of instances to work with their kernel specifications and software libraries they maintain, which may vary deeply from mainstream say debian, ubuntu repositories.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...