Jump to content

Ubuntu 12.04 having issues with AWUS036NHA


haroo
 Share

Recommended Posts

I got my AWUS036NHA with the wifipineapple elite bundle and when i plug it into my ubuntu laptop i does not come up in ifconfig / iwconfig when i issue lsusb i shows up. has anyone seen this issue or does anyone know what i have to do to get it going. Thanks Haroo

troy@troy-M14xR2:~$ lsusb

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub

Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub

Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub

Bus 001 Device 003: ID 064e:8128 Suyin Corp.

Bus 002 Device 003: ID 187c:0521 Alienware Corporation

Bus 003 Device 002: ID 0cf3:9271 Atheros Communications, Inc. AR9271 802.11n <---- there it is

eth0 Link encap:Ethernet HWaddr xxxxxxxxxxxxxxxxxxxxxx

inet addr:172.16.42.42 Bcast:172.16.42.255 Mask:255.255.255.0

inet6 addr: fe80::d6be:d9ff:fe32:9098/64 Scope:Link

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1

RX packets:9142 errors:0 dropped:0 overruns:0 frame:0

TX packets:10057 errors:0 dropped:0 overruns:0 carrier:3

collisions:0 txqueuelen:1000

RX bytes:837956 (837.9 KB) TX bytes:8591079 (8.5 MB)

Interrupt:47

lo Link encap:Local Loopback

inet addr:127.0.0.1 Mask:255.0.0.0

inet6 addr: ::1/128 Scope:Host

UP LOOPBACK RUNNING MTU:16436 Metric:1

RX packets:1960 errors:0 dropped:0 overruns:0 frame:0

TX packets:1960 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:0

RX bytes:207215 (207.2 KB) TX bytes:207215 (207.2 KB)

wlan0 Link encap:Ethernet HWaddr xxxxxxxxxxxxxxxx

inet addr:192.168.0.135 Bcast:192.168.0.255 Mask:255.255.255.0

inet6 addr: fe80::6a5d:43ff:fe61:35b4/64 Scope:Link

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1

RX packets:80691 errors:0 dropped:0 overruns:0 frame:0

TX packets:66804 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:1000

RX bytes:106477816 (106.4 MB) TX bytes:5685382 (5.6 MB)

Link to comment
Share on other sites

Pluged in WUS036NHA and ran dmesg

[ 1251.976759] usb 3-4: ath9k_htc: Transferred FW: htc_9271.fw, size: 51272
[ 1251.976938] xhci_hcd 0000:00:14.0: ERROR no room on ep ring
[ 1251.979901] usb 3-4: ath9k_htc: Unable to allocate URBs
[ 1251.979942] ath9k_htc: probe of 3-4:1.0 failed with error -22

Link to comment
Share on other sites

Try powering the nha with a powered usb hub. Made the difference for me...

telot

Link to comment
Share on other sites

use the ac adaptor to power the hub instead of my usb power cable for it and it made no difference at all in ubuntu. it works fine in windows. just not in ubuntu 12.04. im going to download a different distro and try it but i really didnt want to.

Link to comment
Share on other sites

It works for me with a powered hub (plugged in) and backtrack 5 r3. Pops right up! You probably know this, but it hasn't been mentioned - run ifconfig wlanX up (wlan1 if you have an inbuilt wifi card, wlan0 if you don't).

telot

Link to comment
Share on other sites

You need to download and install the Compat Wireless drivers, it should work for your Ubuntu.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...