Jump to content

Internet Connectivity Issue from Hell -- a plea for help!


Recommended Posts

I am having the mysterious ghostly Internet connectivity issue from hell. Please help me. I am a dumb ignorant end user and you are the wise and noble gurus!! OK, maybe that last bit was over the top but I will be VERY grateful. Seriously, if you solve my problem and the problem doesn't return then I'll like give you an iTunes gift or something if you like.

I've been having trouble since I moved into a new apartment in a downtown urban area. I've spent countless hours trying to make my Internet connection work properly on my own and several more hours (like 12+) on the phone over the course of several months.

Core problem:

Every few minutes my WiFi Internet connectivity is lost, even though I'm still connected to the AP. There's a lot of variability but on average I'm online for about 4-6 minutes then offline for about 2-3 minutes. This problem persists for a long time despite tons of corrective steps, then it seems to be fixed and goes away for a while, only to come back in a day or two.

Hardware details:

Dell Laptop

Intel WiFi Link 1000 BGN

Apple Time Capsule router

Arris modem

2.4Ghz network

I'm sitting within 2 feet of the access point

Software details:

Windows 7

Lots of VPN software installed (once a suspected cause, but evidence is inconclusive - problem persisted after uninstalltion)

Windows Firewall


Steps taken:

powercycling everything billions of times, in all different orders

uninstalling/resinstalling TUN/TAP and VPN software -- it seemed like this worked at first, but then the problem came back anyway

Had the ISP change the IP

Refreshed caches

Renewed DHCP lease

Toggled NAT

Changed radio stations

Tried ethernet -- yes, that works

Tried using a Macbook -- sometimes the MacBook worked when the Dell didn't, but sometimes neither one had connectivity

Tried changing DNS servers (for a while that also seemed to work, must have been a co-incidence tho, the problem returned)

Tried verifying the permissions and repairing the disk

I'm at my wits end. Help me Hak 5 gurus, you're my only hope!

Link to comment
Share on other sites

One thing I did not see is if you checked your firewall. Your firewall maybe to blame. Could be your AP, though. Do you have another router you could test? That would eliminate the router issue, I believe.

One other thing; connect your PC via ethernet cable; open your browser of choice (mine is chrome); type; check the settings in there for static DNS... I ran into that issue a while back and had my router set to dynamic; opposed to static. Meaning, your AP should properly detect any changes made to your IP if it changes. I do believe I explained that right, but I know that I am just a fly on the wall compared to the Gurus. :)

Link to comment
Share on other sites

Thanks Pwnd2Pwnr. I did try toggling the firewall though, forgot to mention that :P

It's so annoying. Last night it seemed like the problem was gone for maybe 2 hours, but it came back and it's still here. Kill me.

I tried typing in with the ethernet cable plugged in but nothing happened. Is that supposed to be the address of my router? If so it's an Apple router so I think it's managed through the Airport Utility.I don't really see anything about static v. dynamic DNS. The DNS settings are under TCP/IP but it just ask the following settings:

Configure IPv4: Using DHCP

Subnet Mask: [some numbers]

Router Address: [ip]

DNS Server(s):

IPv6 DNS Servers: [none]

Domain Name: [none]

DHCP Client ID: [none]

Link to comment
Share on other sites

Are you using Linux or Windows; or... errp... Mac? There should be no reason your AP just cuts in and out. I put the ass in assumption; the 192.168.x.x is your local IP for your router; bust in there and I bet your issue can be resolved... but I know nothing of Apple routers; truthfully, I think you are the first person I know with one.

Your subnet will be

The DNS is for Google I do believe (

Sorry to see no one else is getting involved; there are some pretty sharp knives in the Hak5 toolset.

Link to comment
Share on other sites

Why not throw your router into WEP mode the next time it happens, fire up airodump and watch clients? It sounds like a deauth to me and if it is, at least you will be able to watch who is doing it for a minute when they run aireplay on you.

Scratch that. I read through too fast and didn't see that you were staying connected to your AP

Link to comment
Share on other sites

Thanks for the ideas guys. I hadn't even considered the possibility that someone might be hacking or something. But I kind of doubt just because they would have to be *so* persistent for such a long period of time and I don't really have any enemies that I know of or anything.

It's Windows 7. I also had a little trouble with my MacBook too, but I rarely use the Macbook anyway. I don't currently have any hacking / advanced WiFi tools on Windows just b/c if I want to do hacking then I run BackTrack or BackBox live. So it's not nmap that's causing it; could be something else to do with upnp, but I don't know what or how to check.

I can run any tool like nmap or the -ng suite if it would help though.

Hmmm any other thoughts? Thanks again for the ideas.

Edited by americanwhitehat
Link to comment
Share on other sites

Well, I can't think of any other software related things, but have you considered the hardware itself as the culprit? Do you have an option to swap out to a different wireless modem for an afternoon by begging a favour?

Link to comment
Share on other sites

Steps to start over. first, disconnect the apple time capsule. Test without it completely. 2, reload the firmware on your main router, start with a fresh config reset to factory settings, and then login, change default password. Disable remote administration from both wifi and the wan side. Disable uPnP, SSDP, and if possible tftp, or just port forward port 69, to a non working IP or out of range for your subnet. Change the IP subnet also, to limit the total number of devices needed for your network. You can use Subnet Calculator to help with that.http://www.subnet-calculator.com/

After thats done, disable WPS if your router has it, disable it. Manually connect all devices, don't use WPS, ever. Also, enable WPA2 if capable, or WPA at a minimum. Never use WEP or no enryption at all. If your devices allow 802.11N on the WIn7 box and Macbook, change the router, to only use N only, and change the routers radio to 5ghz and pick an upper channel. They wont be 1-11 like the 2.4ghz channels. they'll be in the 100's and up.

Once that is done, make sure to turn logging on in the router if it has the capabilities. Do all of the configurations over wired obviously. Also, change the default SSID for the wifi, and pick a new wifi password to be safe. You can also enable mac address filtering, and just white list only your home devices.

After you do all of that, test the wifi. Then if working, add back in the Apple Time Capsule router, and see what happens. Does the Time Capsule router offer wired connections, or only wifi? If only wifi, make sure its set to bridged mode(if capable) but if it has wired capabilities,use them only. Two wifi routers in the same room, can often cause all sorts of interference with one another.

Thats where I would start with things, then work from there to see whats happening, but those would be my first steps, starting fresh, with known firmware, and reset to factory, and setup everything a new via wired side, then setup the wifi, and later, introduce the Apple Router product after you isolate the normal router issues.

Edited by digip
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...