Jump to content

New Pineapple Owner Questions


bismark
 Share

Recommended Posts

Pineapple Hardware Version: Mark IV

Pineapple Software Version: 2.3.1

OS Used: Ultimately none, otherwise OS X & Backtrack

So I'm poking around the innards (software) of the Wifi and I have a few questions.

  1. What is the difference/benefit of the /www/pineapple/ssh/ AutoSSH connection script versus the built in one under /etc/init.d/autossh & /etc/config/autossh?
  2. Has anyone gotten the Ting 598U microsd storage to work reliably? I saw the post about mounting /dev/sda twice and then it would see it. I've found however that even it if sees it initially it will eventually disappear and then not come back until a reboot of the Pineapple.
  3. Network setup. Was looking to setup the WLAN (Karma) and LAN ports as pass through from the network connection given to the WAN. Basically bridging the connection and becoming a passthrough AP for the target network. Then using the 3G modem as the egress point for AutoSSH. Possible with the current hardware?

Link to comment
Share on other sites

  1. What is the difference/benefit of the /www/pineapple/ssh/ AutoSSH connection script versus the built in one under /etc/init.d/autossh & /etc/config/autossh?
  2. Has anyone gotten the Ting 598U microsd storage to work reliably? I saw the post about mounting /dev/sda twice and then it would see it. I've found however that even it if sees it initially it will eventually disappear and then not come back until a reboot of the Pineapple.
  3. Network setup. Was looking to setup the WLAN (Karma) and LAN ports as pass through from the network connection given to the WAN. Basically bridging the connection and becoming a passthrough AP for the target network. Then using the 3G modem as the egress point for AutoSSH. Possible with the current hardware?

1. The UI gives you a nice way to set it all up and create a persistent connection. Just makes it simple and easy for the user.

2. Sorry, I don't have it to try it out. WhistleMaster knows more about that modem.

3. All possible with the hardware, it just requires editing of routes and IPtables.

Best,

Sebkinne

Link to comment
Share on other sites

[*] Network setup. Was looking to setup the WLAN (Karma) and LAN ports as pass through from the network connection given to the WAN. Basically bridging the connection and becoming a passthrough AP for the target network. Then using the 3G modem as the egress point for AutoSSH. Possible with the current hardware?

If you're a whizz with IPTABLES and get this done successfully, please share your results on this forum bismark - this is something thats been on a lot of peoples wish lists for a while now. We've got a few iptables wizards around here, so if you have any questions, please feel free!

telot

Link to comment
Share on other sites

If you're a whizz with IPTABLES and get this done successfully, please share your results on this forum bismark - this is something thats been on a lot of peoples wish lists for a while now. We've got a few iptables wizards around here, so if you have any questions, please feel free!

telot

This kind of stuff will come into the "connections" UI which will be added soon.

It will have UI implementations to manage tethering and other connections.

Link to comment
Share on other sites

If you're a whizz with IPTABLES and get this done successfully, please share your results on this forum bismark - this is something thats been on a lot of peoples wish lists for a while now. We've got a few iptables wizards around here, so if you have any questions, please feel free!

telot

So far I have it sort of working without IPTABLES at all. Part of my issue is figuring out the format of the /etc/config/network. I can get it to bring up the default bridge (br-lan) on LAN/PoE and add wlan0 to it automatically but I have to manually add WAN (eth1)

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option ifname 'eth0'
        option type 'bridge'

config interface 'wan'
        option ifname 'eth1'

config switch 'eth0'
        option enable_vlan '1'

config switch_vlan
        option device 'eth0'
        option vlan '1'
        option ports '0 1 2'

Once the Pineapple starts up I then do the following

# brctl addif br-lan eth1

Which gives me the following

# brctl show
bridge name     bridge id                         STP enabled     interfaces
br-lan              8000.00c0ca632d08       no                    wlan0
                                                                                      eth0
                                                                                      eth1

# ifconfig
br-lan    Link encap:Ethernet  HWaddr 00:C0:CA:63:2D:08  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:15150 errors:0 dropped:1146 overruns:0 frame:0
          TX packets:129 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:1651368 (1.5 MiB)  TX bytes:14055 (13.7 KiB)

eth0      Link encap:Ethernet  HWaddr 00:C0:CA:63:2D:09  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:15440 errors:0 dropped:30 overruns:0 frame:0
          TX packets:157 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:1956748 (1.8 MiB)  TX bytes:17702 (17.2 KiB)
          Interrupt:5 

eth1      Link encap:Ethernet  HWaddr 00:C0:CA:63:2D:08  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:288 errors:0 dropped:9 overruns:0 frame:0
          TX packets:980 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:85937 (83.9 KiB)  TX bytes:145669 (142.2 KiB)
          Interrupt:4 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:73 errors:0 dropped:0 overruns:0 frame:0
          TX packets:73 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:3946 (3.8 KiB)  TX bytes:3946 (3.8 KiB)

mon.wlan0 Link encap:UNSPEC  HWaddr 00-C0-CA-63-2D-0A-00-48-00-00-00-00-00-00-00-00  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:31772 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:32 
          RX bytes:5070294 (4.8 MiB)  TX bytes:0 (0.0 B)

wlan0     Link encap:Ethernet  HWaddr 00:C0:CA:63:2D:0A  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:938 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:32 
          RX bytes:0 (0.0 B)  TX bytes:162034 (158.2 KiB)

# route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface

I'm connecting through the USB serial so there is no IP on the device as of right now (routing table blank). I connect a laptop up to the WAN port and it gets a DHCP lease just fine and can browse/ssh/apt-get/etc. just fine. My switch also doesn't notice the Pineapple as I have the basic NAC enabled on the port locked to the laptop's MAC address. Score!

I have the firewall disabled and only ip_forwarding enabled.

Next is trying to get the 3G modem to work, which the device itself (Ting's Sierra Wireless 598U) is giving me headaches as it's there then it's not. When it is there even though I have set the /www/pineapple/3g/3g.sh and /etc/config/network to NOT replace the default route it still becomes the default route and all traffic then goes through it... DOH.

I need to figure out how to get the 3G modem handle only 1 or 2 ip addresses and then everything else just gets tossed at the bridge.

Link to comment
Share on other sites

Pineapple Hardware Version: Mark IV

Pineapple Software Version: 2.3.1

OS Used: Ultimately none, otherwise OS X & Backtrack

So I'm poking around the innards (software) of the Wifi and I have a few questions.

  1. What is the difference/benefit of the /www/pineapple/ssh/ AutoSSH connection script versus the built in one under /etc/init.d/autossh & /etc/config/autossh?
  2. Has anyone gotten the Ting 598U microsd storage to work reliably? I saw the post about mounting /dev/sda twice and then it would see it. I've found however that even it if sees it initially it will eventually disappear and then not come back until a reboot of the Pineapple.
  3. Network setup. Was looking to setup the WLAN (Karma) and LAN ports as pass through from the network connection given to the WAN. Basically bridging the connection and becoming a passthrough AP for the target network. Then using the 3G modem as the egress point for AutoSSH. Possible with the current hardware?

on #2 You need to give it some more juice by using a Y usb cable to let the micro sd be stable and not un-mount or error out.

on #3 I get your point, you want to make a wifi tap and listen on it from the 3G, right?

Link to comment
Share on other sites

I need to figure out how to get the 3G modem handle only 1 or 2 ip addresses and then everything else just gets tossed at the bridge.

What about only allowing the ssh traffic, as I think you only want to use that connection(the 3g) for remote monitoring/administration thru autossh, right?

This has been my goal since I very first got the thing back in early march. I've even been through the troubles the the 598u. I switched to the tmobile ZTE mf591 because I can reliably deal with the sdCard.

Achieving our goal would make it the ultimate drop-box...

Link to comment
Share on other sites

What about only allowing the ssh traffic, as I think you only want to use that connection(the 3g) for remote monitoring/administration thru autossh, right?

This has been my goal since I very first got the thing back in early march. I've even been through the troubles the the 598u. I switched to the tmobile ZTE mf591 because I can reliably deal with the sdCard.

Achieving our goal would make it the ultimate drop-box...

Drop box anyone ?

2ikz2vl.jpg

2povdbo.jpg

16jj140.jpg

---

I think the pics can say what is involved, it was painful to get it working but it works now GREAT thanks to hak5, you guys and darren :)

Edited by Molotof
Link to comment
Share on other sites

Drop box anyone ?

---

I think the pics can say what is involved, it was painful to get it working but it works now GREAT thanks to hak5, you guys and darren :)

That looks great Molotof! I'm sure I'm not the only one who would love to read a full post about your comprehensive setup. If you care to make one it'd be greatly appreciated.

telot

Link to comment
Share on other sites

That looks great Molotof! I'm sure I'm not the only one who would love to read a full post about your comprehensive setup. If you care to make one it'd be greatly appreciated.

telot

Sure it looks like a mangled web but it is a fun pack to have lol, i don't want to hijack the thread so i am going to make a new post about it :)

Link to comment
Share on other sites

on #2 You need to give it some more juice by using a Y usb cable to let the micro sd be stable and not un-mount or error out.

Interesting, considering I'm using the wallwart right now for testing and I'm having problems with it. Here is a snippet from my logs overnight:

60318.640000] usbcore: deregistering interface driver usbserial_generic
[60318.640000] generic ttyUSB0: generic converter now disconnected from ttyUSB0
[60318.650000] generic ttyUSB1: generic converter now disconnected from ttyUSB1
[60318.660000] generic ttyUSB2: generic converter now disconnected from ttyUSB2
[60318.660000] generic ttyUSB3: generic converter now disconnected from ttyUSB3
[60318.670000] usbserial_generic 1-1.2:1.0: device disconnected
[60318.670000] USB Serial deregistering driver generic
[60318.680000] usbcore: deregistering interface driver usbserial
[60321.710000] usbcore: registered new interface driver usbserial
[60321.720000] USB Serial support registered for generic
[60321.720000] usbserial_generic 1-1.2:1.0: generic converter detected
[60321.730000] usb 1-1.2: generic converter now attached to ttyUSB0
[60321.730000] usb 1-1.2: generic converter now attached to ttyUSB1
[60321.740000] usb 1-1.2: generic converter now attached to ttyUSB2
[60321.740000] usb 1-1.2: generic converter now attached to ttyUSB3
[60321.750000] usbcore: registered new interface driver usbserial_generic
[60321.760000] usbserial: USB Serial Driver core
[61518.660000] usbcore: deregistering interface driver usbserial_generic
[61518.670000] generic ttyUSB0: generic converter now disconnected from ttyUSB0
[61518.670000] generic ttyUSB1: generic converter now disconnected from ttyUSB1
[61518.680000] generic ttyUSB2: generic converter now disconnected from ttyUSB2
[61518.690000] generic ttyUSB3: generic converter now disconnected from ttyUSB3
[61518.690000] usbserial_generic 1-1.2:1.0: device disconnected
[61518.700000] USB Serial deregistering driver generic
[61518.700000] usbcore: deregistering interface driver usbserial
[61521.740000] usbcore: registered new interface driver usbserial
[61521.740000] USB Serial support registered for generic
[61521.750000] usbserial_generic 1-1.2:1.0: generic converter detected
[61521.760000] usb 1-1.2: generic converter now attached to ttyUSB0
[61521.760000] usb 1-1.2: generic converter now attached to ttyUSB1
[61521.770000] usb 1-1.2: generic converter now attached to ttyUSB2
[61521.770000] usb 1-1.2: generic converter now attached to ttyUSB3
[61521.780000] usbcore: registered new interface driver usbserial_generic
[61521.780000] usbserial: USB Serial Driver core
[62718.680000] usbcore: deregistering interface driver usbserial_generic
[62718.690000] generic ttyUSB0: generic converter now disconnected from ttyUSB0
[62718.700000] generic ttyUSB1: generic converter now disconnected from ttyUSB1
[62718.700000] generic ttyUSB2: generic converter now disconnected from ttyUSB2
[62718.710000] generic ttyUSB3: generic converter now disconnected from ttyUSB3
[62718.720000] usbserial_generic 1-1.2:1.0: device disconnected
[62718.720000] USB Serial deregistering driver generic
[62718.730000] usbcore: deregistering interface driver usbserial
[62721.760000] usbcore: registered new interface driver usbserial
[62721.760000] USB Serial support registered for generic
[62721.770000] usbserial_generic 1-1.2:1.0: generic converter detected
[62721.780000] usb 1-1.2: generic converter now attached to ttyUSB0
[62721.780000] usb 1-1.2: generic converter now attached to ttyUSB1
[62721.790000] usb 1-1.2: generic converter now attached to ttyUSB2
[62721.790000] usb 1-1.2: generic converter now attached to ttyUSB3
[62721.800000] usbcore: registered new interface driver usbserial_generic
[62721.800000] usbserial: USB Serial Driver core

Hmmm crap, this is the only usb modem that Ting has too.

on #3 I get your point, you want to make a wifi tap and listen on it from the 3G, right?

Yes this is exactly what I want, I do not want any targets data going across the 3G link, I only want it going across the bridge and out eth0 (which hopefully would be plugged into a PoE port, say inline with an IP phone).

You bag setup looks awesome. I was planning on putting mine into a Pelican box or such but that bag is nice.

Edited by bismark
Link to comment
Share on other sites

From the log it shows that the pineapple is trying bring up the modem but the modem is making a fuss about it because the pineapple is not able to give it the required amperage to power up it's radio. what else do you have connected to the usb port on the pineapple?

Link to comment
Share on other sites

From the log it shows that the pineapple is trying bring up the modem but the modem is making a fuss about it because the pineapple is not able to give it the required amperage to power up it's radio. what else do you have connected to the usb port on the pineapple?

I have a 4 port usb "hub", actually I think it's this one specifically. Alone with the modem is a Sandisk Cruzer Fit 16GB, I was going to go with the 32GB but saw everyone using the 16GB and opted for it not knowing if there was an issue with the 32GB version.

Link to comment
Share on other sites

I have a 4 port usb "hub", actually I think it's this one specifically. Alone with the modem is a Sandisk Cruzer Fit 16GB, I was going to go with the 32GB but saw everyone using the 16GB and opted for it not knowing if there was an issue with the 32GB version.

This is the one i am using, notice it has power adapter to give it power, that might be what you need, good luck.

Link to comment
Share on other sites

This is the one i am using, notice it has power adapter to give it power, that might be what you need, good luck.

Are you taking power from that battery pack in your picture? Might I request a labeled picture so I can understand how you have that nice bag setup?

I'll try a powered USB hub tomorrow to see if that is the issue, it might be but I do know when I had the modem plugged straight into the Pineapple it was giving me troubles.

Link to comment
Share on other sites

Are you taking power from that battery pack in your picture? Might I request a labeled picture so I can understand how you have that nice bag setup?

I'll try a powered USB hub tomorrow to see if that is the issue, it might be but I do know when I had the modem plugged straight into the Pineapple it was giving me troubles.

I have my setup detailed in this thread, if the modem plugged in straight to the pineapple and it was giving you troubles thats a sign of the modem needing more amperage than the pineapple can provide.

Link to comment
Share on other sites

awesome this must be the one that is working great for you? I'll give this one a try?

THAT is for sure the one i was lucky with, as i ordered more stuff from hak5 and got the spyder usb hub too and it was nothing but trouble, so i went back to my trusty belkin and started building from there.

Link to comment
Share on other sites

I have my setup detailed in this thread, if the modem plugged in straight to the pineapple and it was giving you troubles thats a sign of the modem needing more amperage than the pineapple can provide.

Thanks, just found your other thread, posted before I looked.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...