Jump to content

HOWTO DDWRT to OpenWRT


Recommended Posts

Hi,

yesterday i have spent good time trying to find out how enable redboot on (Fon with DDWRT) to change it to openwrt

when i use "ap51-flash-fonera-gui-1.0-38" i get the following

mac address: ....

0.0.0.0 as the ip address

Telnet for Redboot is not Enabled

i bought Fon2100A/B/C already flashed with ddwrt v24sp1.

if fon have already ddwrt so i assume it is already enable for telnet on redboot!!! :blink:

please help me to make a guide for this case cause i have searched the net, the search did not led to thing :o

note: i found this

Original software

+PHY ID is 0022:5521

Ethernet eth0: MAC address xx:xx:xx:xx:xx

IP: 0.0.0.0/255.255.255.255, Gateway: 0.0.0.0

Default server: 0.0.0.0

wiki.openwrt.org

thanks,

Link to comment
Share on other sites

Are you in the UK by any chance? The UK fons come with redboot set to listen on 0.0.0.0 by default, maybe the seller used a cable to flash it but never bothered to set the redboot IP address to something useful afterwards.

Have a look at the guide in the wiki which goes over using mtd to write redboot configs and do flashing

Link to comment
Share on other sites

thank you very much for replying, BTW i am from UAE i bought my FON from ebay US ;)

login as: root
DD-WRT v24 std (c) 2008 NewMedia-NET GmbH
Release: 07/26/08 (SVN revision: 9994)
root@192.168.1.1's password:
==========================================================

 ____  ___    __        ______ _____         ____  _  _
 | _ \| _ \   \ \      / /  _ \_   _| __   _|___ \| || |
 || | || ||____\ \ /\ / /| |_) || |   \ \ / / __) | || |_
 ||_| ||_||_____\ V  V / |  _ < | |    \ V / / __/|__   _|
 |___/|___/      \_/\_/  |_| \_\|_|     \_/ |_____|  |_|

                       DD-WRT v24
                   http://www.dd-wrt.com

==========================================================


BusyBox v1.11.1 (2008-07-26 03:51:42 CEST) built-in shell (ash)
Enter 'help' for a list of built-in commands.

root@DD-WRT:~# cd ..
root@DD-WRT:/tmp# ls
cron.d
crontab
dnsmasq.conf
dnsmasq.leases
etc
hosts
igmpproxy.conf
loginprompt
nvram
oet
openwrt-ar531x-2.4-vmlinux-CAMICIA.lzma
out.hex
resolv.conf
resolv.dnsmasq
root
udhcpc
udhcpc.expires
var
www
root@DD-WRT:/tmp# mtd -e vmlinux.bin.l7 write openwrt-ar531x-2.4-vmlinux-CAMICIA
.lzma vmlinux.bin.l7
Could not open mtd device: vmlinux.bin.l7
Can't open device for writing!
root@DD-WRT:/tmp#

i tried the mtd command but the file vmlinux.bin.l7 not found ! :o maybe the file name changed on ddwrt.

note:

it is l7 (lowercase L then 7) for sure

thanks,

Link to comment
Share on other sites

Sorry, I'm not well up on the way mtd works, I may be plugging a fon in later on so can have a look but probably won't find much.

I'd suggest asking on the openwrt forum, just say you are trying to put openwrt on a previously dd-wrt device and can't get into redboot.

Link to comment
Share on other sites

Just a thought, have you tried just running one of the windows flash apps such as fon flash as suggested above? All that does is to install a firmware, it doesn't care what is currently on the device.

Link to comment
Share on other sites

right now i am able to log to Redboot loader using the COM port, now please help how enable telnet for redboot

note: i have tried this cmd

fconfig -i

Initialize non-volatile configuration - continue (y/n)? y

Run script at boot: false

Use BOOTP for network configuration: true

Default server IP address: 192.168.1.254

Console baud rate: 9600

GDB connection port: 9000

Force console for special debug messages: false

Network debug at boot time: false

Update RedBoot non-volatile configuration - continue (y/n)? y

********************************************************************

still could not telnet redboot port 9000

Link to comment
Share on other sites

i think i have to set BOOTP to false :huh:

Use BOOTP for network configuration: false

Gateway IP address:

Local IP address:

Local IP address mask:

Default server IP address:

Console baud rate: 9600

GDB connection port: 9000

so which one i have to set the redboot telnet server ip ? Gateway / Local IP / Default server

Link to comment
Share on other sites

it was Local IP ;)

i found this

hacking-the-la-fonera

i have used now both of the flash tools Freifunk Ap51 EasyFlash and Gargoyle Fon Flash and i can see both of them able to deteced the FON but now i can not access the Fon i can only do redboot telnet on port 9000 or redboot using serial.

please help what should i do !!! :o

i will try this recover

http://flash.fonera.be/

Link to comment
Share on other sites

Flash it with one of the openwrt firmwares then you'll be able to telnet to 192.168.1.1. Make sure your local machine has an IP on the same subnet.

Make sure the flashing finishes, it can take over 45 mins. You have to have the prompt back.

Also, check the start up settings. Have a look at my detailed walk through for installing the Interceptor (http://www.digininja.org/interceptor/install_walkthrough.php), you need to make sure you have this bit.

RedBoot> fconfig
Run script at boot: true
Boot script: 
Enter script, terminate with empty line
>> fis load -l vmlinux.bin.l7
>> exec
>>

Link to comment
Share on other sites

thanks,

i did flash my FON with openwrt firmware, still the same i am not getting the promot for more than 1:30hr :blink:

i used the following files

openwrt-atheros-2.6-root.squashfs

openwrt-atheros-2.6-vmlinux.lzma

help....

note: i am tried the TFTP way from

http://wiki.cuwin.net/index.php?title=Flas...ra_with_OpenWRT

RedBoot> ip_address -l 192.168.1.254/24 -h 192.168.1.166

IP: 192.168.1.254/255.255.255.0, Gateway: 0.0.0.0

Default server: 192.168.1.166

RedBoot> fis init

About to initialize [format] FLASH image system - continue (y/n)? y

*** Initialize FLASH Image System

... Erase from 0xa87e0000-0xa87f0000: .

... Program from 0x80ff0000-0x81000000 at 0xa87e0000: .

RedBoot> load -r -b 0x80041000 openwrt-atheros-2.6-root.squashfs

Using default protocol (TFTP)

Raw file loaded 0x80041000-0x80160fff, assumed entry at 0x80041000

RedBoot> fis create -l 0x06F0000 rootfs

... Erase from 0xa8030000-0xa8720000: ..........................................

.....................................................................

... Program from 0x80041000-0x80161000 at 0xa8030000: ..................

... Erase from 0xa87e0000-0xa87f0000: .

... Program from 0x80ff0000-0x81000000 at 0xa87e0000: .

RedBoot> load -r -b 0x80041000 openwrt-atheros-2.6-vmlinux.lzma

Using default protocol (TFTP)

Raw file loaded 0x80041000-0x80100fff, assumed entry at 0x80041000

RedBoot> fis create -r 0x80041000 -e 0x80041000 vmlinux.bin.l7

... Erase from 0xa8720000-0xa87e0000: ............

... Program from 0x80041000-0x80101000 at 0xa8720000: ............

... Erase from 0xa87e0000-0xa87f0000: .

... Program from 0x80ff0000-0x81000000 at 0xa87e0000: .

RedBoot> fis load -l vmlinux.bin.l7

Image loaded from 0x80041000-0x80290085

RedBoot> exec

still the same could not telnet to 192.168.1.1 BTW it took only 2 min. at

fis create -l 0x06F0000 rootfs not 20min.

i think the process not correctly completed

i repeated the steps again

lol it worked now able to telnet 192.168.1.1 :D :lol: i will try now to finish the reset thanks all

post-13574-1239648340_thumb.jpg

Link to comment
Share on other sites

  • 2 years later...

i am getting this error at present

stderr:non arp received make sure the device is connected directly

when trying to flash , what was your fix for this ?

the same setup i have when i get this worked as i flashed already.

Does it flash anyway?

I get the same error with an OM1P, but it still flashes after about 5-6 seconds. If it flashes I would not worry about it.

Best,

Seb

Link to comment
Share on other sites

Does it flash anyway?

I get the same error with an OM1P, but it still flashes after about 5-6 seconds. If it flashes I would not worry about it.

Best,

Seb

Hi seb,

No it doesn't flash it just hangs and closes the program. I did flash it before a few times so I know what to expect.

I wonder is something in a loop , it can't communicate. Nothing is sent from my computer to the fon it says that I.e sent and received info.

Any ideas ?

I have used other flash programs also it didn't do anything.

Is there a master reset , as the one underneath doesn't seem to do anything

Edited by fearanphoist
Link to comment
Share on other sites

No, there is no "master reset", but you could try running a ping to the router with it not having power. Then connect the power and see if you get any returned pings.

Make sure that you are on the same subnet.

If you do get a reply, you can manually use something like putty or if you are using linux the built in client to telnet to the routers IP.

I had that problem with the old Fon, I cant use any standard flash app for some reason, I can only do it by going into redboot myself.

Lastly there is always using a serial cable to access redboot, allowing you to flash and enable telnet listening.

Hope that helped a bit,

Seb

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...