Jump to content

DynDNS and TightVNC


Neondog82
 Share

Recommended Posts

Hello all. I have been messing around with DynDNS and TightVNC for a bit now, and I am not able to get it to work. I came here in hopes someone can help me. I have DynDNS all setup with the updater running, and I have TightVNC set up using the ports I want. Currently I can use TightVNC as long as I am on the network. My setup is a Modem to Router (via Ethernet) connection, then wireless and wired clients. I am unable to get to my TightVNC server from outside the network. Lets say my external IP is 123.111.222.123 and I have the VNC server Http port set to 440. Wen I try to connect to 123.111.222.3333:440 it always says connection failed. The port is forwarded from router to the client where the VNC server is. Any help would be much appreciated.

Link to comment
Share on other sites

Thank you for the help, but that is not what I am looking for. Basically I have a computer on my LAN that has services I wan't to be able to get to from outside my lan. Now I just need to figure out how DynDNS, my modem, and my router all work together so i can access the service. While on the network I can simply type the IP:Port of the machine hosting the service I want and get it. I was trying to use http://mydyndns.org:port to get the same thing but was not lucky. Is anyone in here familiar with this type of thing? If not do you know where I might be able to get some help?

Link to comment
Share on other sites

Again, thanxs for all the help. Maybe I am missing something in my network. I thought I understood port forwarding let me lay out my network:

Modem---(Ethernet)--->Linksys Powerline Adapter 1-----(House Power Grid)--->Linksys Powerline Adapter 2-------(Ethernet)--->Wireless Router------(Ethernet)------>Client 3

Say my IP's are as follows

Modem: 67.85.139.40 (External)

              192.168.5.1 (Internal)

Router: 192.168.7.4

Client 3 (Reserved DHCP) 192.168.7.103

Now Do I forward from the Modem, or from the Router? If its from the router I have the port of the service I want to use forward from the router to client 3. If I type in 192.168.7.103:4000 (4000 being the port of my VNC server) I can connect to that service. However if I type in 67.85.139.40:4000 then I get unable to connect. Now If I need to port forward from the modem to the router, and then from the router to the client I might have a small problem. When in the modem settings it only shows 192.168.5.3 in the connected client list. I can not connect to it, but I am guessing it is just the linksys powerline adapter. Any help would be helpfull.

Link to comment
Share on other sites

I think I know what your problem is

Although others may disagree, I have solved it in this manner before.

Your modem is most likely setup like a router, windstream recently did this, Replace the router with an Ethernet hub and all will be well.

This fix has worked for me on my home network, work network, and even my school.

It's a good bet there is conflict between the two routers.

Link to comment
Share on other sites

Thanks for the idea but I am not convinced that is the answer to my problem. Besides if i replace the modem with a ethernet hub then what will pass the ISP my credentials? Does anyone else have any ideas? If not do you know how I could walk myself through this process. I mean Utorrent port forwards just fine?

Link to comment
Share on other sites

Just wanted to say thank you for your help. I will probably move over to port forward.com and ask around there. I was going to try there next. Having someone on the outside of my network test it and resolve the problem is a great idea. But I dont think I would trust a single person on the Hak5 forums with my real IP and ports numbers. Again thank you!

Link to comment
Share on other sites

I think HSN might be on to something you know, when you say modem, i think about my NTL cable modem, which is just that. But companies such as BT sell 1 port routers, complete with NAT which to the untrained eye could be considered a modem. An easy way to test this would be to set your PC to DHCP, then plug it into the back of the modem. If you get an IP address of 192.168.*.*, 172.16.0.0-172.31.255.255 or 10.*.*.* then its a router, if its anything else its a regular modem. If it does turn out that your modem is a router, then just log into it, disable NAT and the firewall and it should work ok, you could just portforward but disabling NAT and the firewall would make more sense in the long run.

Link to comment
Share on other sites

Yes, I always knew it was a router as well as a modem. I had all ready gone into the modem and port forwarded the port I needed from the modem to My Wireless router, and then from the wireless router to the client. I turned off NAT and could not view any web pages, so I turned the NAT back on (in the modem, not my wireless router). The Firewall was never on. Thank you all very much for your help.

Link to comment
Share on other sites

  • 2 weeks later...

I'm just going to list some ideas for you to try. 

-Run a portscan on yourself (might need to setup a proxy to make sure you're looking at yourself as the outside world sees you.  TOR is a good way to do this).

-Disable NAT on your modem.  You'll have to google how to do this.  My modem is currently set to 'bridge' mode which means that the *only* thing it does is act as a translator between the coax cable and the ethernet cable.  My router is handling the sign-in, and if you ping me then you're actually pinging the router NOT the modem.  This ensures that the modem isn't doing any sort of NAT on your packets.

-As mentioned above, setting a static IP and forwarding the ports statically is a good thing.  Have you tried to VNC into your machine from within the network?  If this works then the problem lays with a firewall or NAT not being done properly. 

If none of these work feel free to PM me and I'll help you get this working.  Good luck!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...