Jump to content

[RELEASE] WiFi Pineapple 2.1.0


Dragorn
 Share

Recommended Posts

The WiFi Pineapple Mark VII 2.1.0 release is here!

This release focuses on speed boosts and some bug fixes after the 2.0.0 release, including:

 

  • UI
    • Fixed naming of SSID impersonation checkbox
    • Fixed display problems in advanced settings
    • Fixed CPU percentage (Enterprise)
    • Fixed client display for Evil WPA clients
    • Fixed client count for Evil WPA clients
  • PineAP
    • Add option for source randomization for impersonated APs
  • Recon
    • Significantly improved performance of recon in crowded environments
    • New recon access point and client views offering better visibility and significantly improved performance
    • Fixed cloning an Enterprise AP
  • Wifi
    • Fixed kicking clients off Evil WPA

 

Enjoy!

  • Like 1
Link to comment
Share on other sites

  • Dragorn featured and pinned this topic

Crashing my pineapple.  This morning came into the office and all my clients were disconnected.  Logged in and was presented with a flash error page. Went through recovery process, reloaded 2.1.0, and it came up with flash error again.   Loaded 1.1.1 FW and was able to compelete setup.  Loaded 2.1.0 and it came up with flash error once again.  

Link to comment
Share on other sites

Quoting dragorn from Discord (17th of July 2022)
"The 1.x firmware didn't check to see if the internal emmc (the larger storage flash) was working, and just kind of did it's best.  The 2.0 firmware checks to make sure the emmc is properly formatted, since the most common cause of it not being present is flashing it in the wrong order."

So, a flash check has been implemented in the 2.x firmware. A check that wasn't available in 1.x. Your device "successfully" runs 1.x since it won't check for flash errors and when trying to flash 2.x it produces the error since you most likely have some issues with your flash storage device  on the Pineapple.

Link to comment
Share on other sites

Well that sucks since the pineapple Mark VII was bought not to long ago and my old PineApple Tetra has been solid for years as well as the Packet Squirrel.   I swear I was running 2.0.0 on this Mark VII but this morning it stopped due to the Flash error.  😞    

I attempted to manually update to 2.0.0 through SSH and I did receive the flash error once again.  Reflashing and loading 1.1.1 brought it back up.  Looks like you may be right. 

 

SOOOOOooooo  HAK5 do you want to replace this one for me and I will send this one back???? Bought it off the site 

 

Link to comment
Share on other sites

On 8/9/2022 at 5:04 PM, Dragorn said:

The WiFi Pineapple Mark VII 2.1.0 release is here!

This release focuses on speed boosts and some bug fixes after the 2.0.0 release, including:

 

  • UI
    • Fixed naming of SSID impersonation checkbox
    • Fixed display problems in advanced settings
    • Fixed CPU percentage (Enterprise)
    • Fixed client display for Evil WPA clients
    • Fixed client count for Evil WPA clients
  • PineAP
    • Add option for source randomization for impersonated APs
  • Recon
    • Significantly improved performance of recon in crowded environments
    • New recon access point and client views offering better visibility and significantly improved performance
    • Fixed cloning an Enterprise AP
  • Wifi
    • Fixed kicking clients off Evil WPA

 

Enjoy!

Thanks

Link to comment
Share on other sites

Thank you very much for the updates!
Your efforts in these updates is what inspired me to buy a Coconut within hours of it dropping as well as the Newest Rubbery Duck!

Some Hak5 Companion "Pineapple Pocket Guide" and Pineapple eClass/Textbooks for $ Addons to the Pineapple Mark VII Upsell = I would buy!

What would you suggest as the best study guide for the Pineapple Mark VII?

Link to comment
Share on other sites

Are here more people having problems with the 2.1.0 update?
It doesn't work on my Mark VII ... Very annoying.
 

And if it is an internal problem, I also hope the support will exchange the broken one with a working one - even if the warrenty time is over.

Link to comment
Share on other sites

5 hours ago, dark_pyrro said:

You have to be more specific about what you are experiencing. Just saying it doesn't work won't make troubleshooting possible.

As I wrote, my question was, wether we can determine how many Mark VII may have this broken internal emmcs.
Maybe a whole series...? Only a few?

In fact I didn't bought one with the advertisement "Now (maybe) with corrupt chips inside" 🙂

When it is an internal problem due to an broken flash chip, I think troubleshooting should be to get an replacement.
Or do you think it is repairable by flashing with another firmware?

Link to comment
Share on other sites

Observation - running campaigns on 2.1.0 it would be nice to have the button go from "Run" to "Running" when there is an active campaign.  Right now it stays at "RUN".  This would create a better user experience.

  • Like 1
Link to comment
Share on other sites

  • Dragorn unfeatured and unpinned this topic

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...