Jump to content

Bash Bunny Issues :-(


Magneto417x
 Share

Recommended Posts

If you follow the direction from the wiki for Internet Connection Sharing, you shouldn't have much of a problem connecting to the Bash Bunny using PuTTY. Here's my revised instructed derived from the wiki.

  1. Configure a payload.txt for ATTACKMODE RNDIS_ETHERNET
  2. Boot Bash Bunny from RNDIS_ETHERNET configured payload on the host Windows PC
  3. Open Control Panel > Network Connections (Start > Run > "ncpa.cpl" > Enter)
  4. Right-click Internet interface (e.g. Ethernet, Wi-Fi, ...) and click Properties
  5. From the Sharing tab, check "Allow other network users to connect through this computer's Internet connection" and click OK
  6. Right-click Bash Bunny interface (labeled something like "IBM USB Remote NDIS...") and click Properties
  7. Select TCP/IPv4 and click Properties
  8. Set the IP address to 172.16.64.64. Leave Subnet mask as 255.255.255.0 and click OK on both properties windows. Internet Connection Sharing is complete

Then using PuTTY, connect to 172.16.64.1.

User: root

Password: hak5bunny

Note: These instructions I worked out using Windows 8.1.

  • Upvote 1
Link to comment
Share on other sites

38 minutes ago, Magneto417x said:

What about Serial? I've also tried to do the nmap payload now 4 times and it never seems to work. I'm experiencing many issues so far :-( Hope someone can tell me what I'm missing as I'm beating my head against the wall here :-(

Don't hurt your head! You'll get it!

When I first inserted the Bunny while in switch position 3, it showed as Storage, Great!

Then, I had to look in the Device Manager which showed a CDC Serial device that it could not find a driver for.  Choose to manually search for the driver, and it is on the BashBunny's Mass Storage!!  How nice was that!

I then checked the port in Device Manager, and mine was COM4.  I configured it as shown with the baud rate.  I then open Putty, chose a Serial connection, pointed to COM4 with the same baud settings and clicked connect.

Now, this next part stopped me a few times! The screen was blank! I pressed Enter (I think any key might work), and the login screen appears!  root:hak5bunny

Good luck.  Please post any screenshots of any steps that don't look like I (or the wiki) described.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...