Jump to content

Problems changing transmission power....


Boosted240
 Share

Recommended Posts

On the new firmware, I'm still having txpower issues. I have 3 radios, and I've put settings in the wireless config for each one.

radio 1 = 27dbm

radio 2 = 24dbm

radio 3 = 24dbm

After changing the config and rebooting, this is what I get:

root@Pineapple:~# iwconfig
wlan2     IEEE 802.11bgn  ESSID:off/any
          Mode:Managed  Access Point: Not-Associated   Tx-Power=20 dBm
          RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off


lo        no wireless extensions.


wlan1     IEEE 802.11bg  ESSID:off/any
          Mode:Managed  Access Point: Not-Associated   Tx-Power=30 dBm
          RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off


wlan0     IEEE 802.11bgn  Mode:Master  Tx-Power=18 dBm
          RTS thr:off   Fragment thr:off
          Power Management:off
Any ideas? I'll post my wireless config below...
config wifi-device  radio0
option type     mac80211
option channel  8
option hwmode 11ng
option macaddr 00:
option htmode HT20
list ht_capab SHORT-GI-20
list ht_capab SHORT-GI-40
list ht_capab RX-STBC1
list ht_capab DSSS_CCK-40
option country BO
option txpower 27dbm




config wifi-iface
option device   radio0
option network  lan
option mode     ap
option ssid     attwifi
option encryption none








config wifi-device  radio1
option type     mac80211
option channel  11
option hwmode 11g
option macaddr 00:
option country BO
option txpower 24dbm


config wifi-iface
option device   radio1
option network  lan
option mode     sta








config wifi-device  radio2
option type     mac80211
option channel  11
option hwmode 11ng
option macaddr 64:

option htmode HT20
list ht_capab SHORT-GI-20
list ht_capab SHORT-GI-40
list ht_capab RX-STBC1
list ht_capab DSSS_CCK-40
option country BO
option txpower 24dbm


config wifi-iface
option device   radio2
option network  lan
option mode     sta
Link to comment
Share on other sites

From my understanding this restriction with the Atheros chipset on wlan0 was to be lifted in the current new firmware

Yeah, I'm on the latest firmware.

Link to comment
Share on other sites

Yeah I don't have the room or battery power left to incorporate something like that into my Raspple Pie. Do these things actually work?

Link to comment
Share on other sites

  • 3 weeks later...

You likely have to do something like this:

http://blog.binaryfactory.ca/2012/09/setting-txpower-as-high-as-your-card-can-go/

I recently used that to turn my Alfa card up higher than the 20dbm it came "stuck" at out of the box.

You did this on the Pineapple? Or Kali linux?

The USB wifi cards I've tried to change work fine in Kali, just not the Pineapple. Its also odd that wlan1 with just jump to 27 or 30dbm no matter what command is issued.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...