Jump to content

DNSSpoof not redirecting

Recommended Posts

  • Pineapple Hardware Version (ex: Mark III, Mark IV, etc.): Mark IV
  • Pineapple Software Version (ex: 2.5.0, 2.6.4): 2.8.0
  • OS used to connect to the pineapple: CentOS 6
  • Network layout of how your setup is connected (including IP information): Pineapple is connected to laptop, Laptop is connected to wireless Internet. ICS is set up. The pineapple uses the standard address while the PC is on the 192.168.25.x network
  • Is the problem repeatable (Yes/No): yes
  • Steps taken which created the problem: Pasted custom HTML into the landing page box. If I browse to, I see the page. Turn on DNS spoof. Originally tried to go to a specific site and have it re-direct to Then I tried to send all webpages to using the entry * Nothing at all redirects.
  • Error Messages: None.

I can't get DNSspoof to work. I have it configured and running but nothing is redirecting to, but just goes to the actual site.

Link to comment
Share on other sites

Remember, if you set a custom DNS to be used on your device dnsspoof will not work.

Sorry been busy all day. I'm not sure if you mean a custom DNs on the client or on the MarkIV. The client primary DNS is which is the MarkIV. Secondary is opendns. I didn't set those so assume they are stock on the MarkIV.

I'm assuming that is correct since for it to work the MarkIV would need to be the DNS server.

I got it to work with a * in DNSspoof but obviously all items get redirected.

I can't get it to work with a single Address. So if I redirect google.com to, it won't work at all, just takes me straight to google.

Correct me if I'm wrong but the hosts table should read: www.google.com

Or something like *.google.com

Using a wild card.

If anyone has any ideas I'd appreciate it.

Edited by drbearsec
Link to comment
Share on other sites

Ill take a look. Anything on captive login portals? So when first joining the pineapple AP present with a wifi login page? I know some people were looking at creating modules but didnt find any out there.

Yes theres a post about something called nodogsplash.

http://forums.hak5.org/index.php?/topic/25543-captive-portal-on-the-mark-iii/ Idk if it will work as is with the mark IV but worth a shot.

Here I made a short video trying to explain how I got mine setup.

Edited by deathdealerxx
Link to comment
Share on other sites

Well I think there are several ways to hide those extensions. Could one of them be renaming a file from this example.com/filename.html to example.com/filename/index.html?

I don't know if that would work, or if there is a better way though, my pineapple is down for the moment.. waiting to get a usb to ttl cable to reflash. :(

But how do you hide the extensions from the browser?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...