Jump to content

Change Serial Speed


Sah5die
 Share

Recommended Posts

Hey Everybody,

is there anyway to change the Serial Speed on the MK IV ?

I tried stty, mgetty and setserial and none of them worked. (with /dev/ttyS01)

Need to use the serial port over a wireless(433Mhz) link that runs at max 19200 Baud, so default speed 115200 is way to fast ;)

Any Suggestions?

Cheers Max

Link to comment
Share on other sites

I know when you serial flash a mk4 you set it as one of the boot args

While true, it will not change it properly. I would need to change it for the firmware.

I would be happy to do that for you - let me know what baud rate you want.

The only issue is once you upgrade, this dissapears. I suggest you wait for 2.7.0 to hit and then I will make a stable version for you that has just that.

Best Regards,

Sebkinne

Link to comment
Share on other sites

Hey sebkinne....

That Sounds awesome...

I Need serial baudrate 19200

Please let me know When you have the Upgrade.bin ready

Thank you

I will have it ready soon. I just want to make sure you understand the two following points:

  1. This could brick your device. Soft OR hard. Don't hold me responsible, you have been warned ;).
    I don't see there being an issue, but it could require a UART serial adapter to fix.
  2. You are "stuck" on firmware version 2.7.0. If you up / downgrade, the baud rate will change back. I won't make a 19200 baud version for every release, I hope you understand that.

Actually, I would like you to try something first:

You will need to connect to the pineapple over serial first.

Follow the serial guide but change this


setenv bootargs "board=ALFA console=ttyATH0,115200 rootfstype=squashfs,jffs2 noinitrd"
[/CODE]

to

[CODE]
setenv bootargs "board=ALFA console=ttyATH0,19200 rootfstype=squashfs,jffs2 noinitrd"
[/CODE]

I overlooked how kernel arguments are passed with our new Kernel. It should work by telling uBoot.

After the above command, follow the guide normally and re-flash your pineapple. Note that this again could break your device.

Best Regards,

Sebkinne

Link to comment
Share on other sites

hey i tried your instructions...

but serial still operates at the 115200 BAUD

issued your u-boot commandfs with the different baud settings as kernel param. but no changes!

any suggestions?

can you send me the 2.7.0 upgrade.bin?(but the other option would be way better b/c of updating...)

cheers max

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...