Jump to content

Can't Navigate To 172.16.42.1/pineapple


pinecone
 Share

Recommended Posts

Just flashed an Alfa AP51 using ap51-flash-gui-1.0-42.

Device was set up with a static IP of 172.16.42.42 sub 255.255.255.0 as outlined in ththe AP51 flashing guide listed here:

http://forums.hak5.org/index.php?showannouncement=6&f=49

After flashing I can ping to the device. The next step in the tutorial says to navigate to 172.16.42.1/pineapple and login as root/pineapplesareyummy but I'm just getting a page error. I also cant SSH or telnet into it.

Anyone know why this might be?

Thanks!

Link to comment
Share on other sites

It takes a little while for it to finally let you hit the /pineapple page. I'd say let it sit for a bit running (5 minutes or so) and then give it a shot. Also make sure you don't have an open tab or previous failed connection open to it. I think it freaks out the browser.

Tried that - no luck. :unsure:

Link to comment
Share on other sites

Wait a minute - you said Device was setup with 172.16.42.42 on 255.255.255.0. You need your eth0 (or wired local area connection if on windows) to be on 172.16.42.42 and the pineapple to be 172.16.42.1

Unless I misunderstood your first post, this should clear up the problems.

telot

Link to comment
Share on other sites

i have a feeling they are connected at 192.168.0.0 and the pineapple is on 192.168.0.1 but that is my guess because thats what i ran into when i was trying to flash mine. if i remember right i had to change my static ip to 192.168.0.100 and reflash to get it to work right.

Link to comment
Share on other sites

i have a feeling they are connected at 192.168.0.0 and the pineapple is on 192.168.0.1 but that is my guess because thats what i ran into when i was trying to flash mine. if i remember right i had to change my static ip to 192.168.0.100 and reflash to get it to work right.

The IP address the pineapple has for it's default is a 192.168.x.x (bootloader) until the actual OS is booted and changes over to a 172.16.42.1 address.

Link to comment
Share on other sites

OP: I had a n00b problem because I essentially didn't RTFM. Once you enable ICS in windows 7, you have to go back and manually change the LAN IP even if you had already changed it.

Hope this helps...

Also, as Mr-Protocol said, give the pineapple a minute or so to fully boot

Edited by iamk3
Link to comment
Share on other sites

  • 1 year later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...