Jump to content

Jasager -> Mac


Recommended Posts

Hi,

I have flashed my Fon+ with the Jasager firmware (from Robin's website).

Installed webif and haserl by scp'ing them over.

Configured dhcp and webif.

I have connected a victim to the Jasager via Karma, the victim successfully gets an IP address, I can ping my Mac that is directly connected to the Fon+ from the victim.

So far the following is working:

Victim -> Jasager -> Mac

Now, I need to forward the traffic from my Mac ethernet (en0) to the wireless (en1) which is connected to the internet.

I need to get the following working:

Victim -> Jasager -> Mac -> Internet

All the guides I have seen are for Linux/Backtrack. I have tried pineapple.sh but this doesn't seem to work on Mac OS X.

Can anyone point me in the right direction on how to port forward traffic from en0 to en1 on my Mac?

Thank you,

Ryan

Edited by ethicalhack3r
Link to comment
Share on other sites

Thanks, all working once I put the Fon+ and my home network on separate networks.

Both interfaces look like the following on my Mac when working:

en0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500

ether c4:2c:03:0c:7f:d6

inet6 fe80::c62c:3ff:fe0c:7fd6%en0 prefixlen 64 scopeid 0x4

inet 10.110.0.1 netmask 0xffffff00 broadcast 10.110.0.255

inet 192.168.2.1 netmask 0xffffff00 broadcast 192.168.2.255

media: autoselect (100baseTX <full-duplex,flow-control>)

status: active

en1: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500

ether d8:a2:5e:8e:80:a8

inet6 fe80::daa2:5eff:fe8e:80a8%en1 prefixlen 64 scopeid 0x5

inet 192.168.1.103 netmask 0xffffff00 broadcast 192.168.1.255

media: autoselect

status: active

Edited by ethicalhack3r
Link to comment
Share on other sites

  • 2 weeks later...

I attempted to set the up on my mac. However, it seems like when ever I set up my ethernet adapter to have manual settings and enable internet sharing it completely stops my connection to the internet.

I have tried using wifi as an internet source and my tethered iPhone, no joy with either.

it seems like dhcp needs to be enabled in order to appropriately share an internet connection between two adapters.

can some one please share their system settings?

Thank you,

~napisani

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...