Jump to content

Mark Iii Url Snarfer & Ngrep Not Working


t3ll3z
 Share

Recommended Posts

Hello, I have had the mark III for quite some time now. However, not until recently ngrep as well as url snarfer stopped working on it. They still turn on and seem as if they are working but they are not outputting anything onto the PCC. I have checked the output logs of ngrep and url snarfer and they are not collecting any data since they are empty. Therefore, when this happened I went straight to the forums to see if anyone had had this issue before and found similar ones. So I did what worked for them and that was flashing the pineapple with the new 1.9 firmware. I had also updated the pineapple to version 1.02. But i still cannot seem to get it to work. Karma and dns spoofing are working flawlessly.

If any one could offer some tips on how to try and tackle this issue, it will be greatly appreciated. Thanks.

Link to comment
Share on other sites

I am confused by what you mean you flashed with 1.9 and updated 1.02.

You only need to flash with the 1.9 firmware and not rebuild with the 1.02 over that. Only the 1.9 firmware and things should work.

I flashed it first with the 1.9 firmware and check to see if ngrep and url snarfer were working but they still weren't. I updated it to 1.02 with the commands listed at wifipineapple.com because i noticed there were still "^M" in files such as the ngrep.sh script. After this update they still did not work.

Link to comment
Share on other sites

1.02 is not an update. Compiled firmware 1.9 is the most up-to-date.

I have flashed the 1.9 firmware once more but ngrep and urlsnarfer are still not outputting any data on the PCC. I also still find the "^M" in the redirect.php script located in www/

Link to comment
Share on other sites

I have also noticed that when try to stop ngrep it will come up with a blank page and url of "http://172.16.42.1/pineapple/stopngrep.php."

Thanks again for your help.

If you've got the ^M's going on in your config files - that will surely screw up your ngrep. I'm wondering if your firmware reflashes were not sucessful. Go into your ngrep files in /www/pineapple/ and remove all ^M's and see if it works then.

telot

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...