Jump to content

Mark Iii - Url Snarf + Other Questions


Ror
 Share

Recommended Posts

Hi,

I setup my Mark III v1.0.2. I have no problem grabbing devices. The first time I used it, I could see wifi associations being made (the network name the target was connecting to) and URL snarf was showing a little bit of data. But now those associations aren't being shown, however the devices are connecting to the pineapple.

URL Snarf was showing a device name and an http protocol, but no URL. The first time I used the device, URL snarf at least showed a device name and protocol, but now shows nothing. Yes, it is enabled. I have reset to factory too many times, to see if I could get a circumstance similar to the first time I booted it (this is when associations were being displayed and URL snarf kinda functioned)

Also, how does ngrep display its data? I assume through the log file, but my linux skills are crapolla. When I use an ls command I can see ngrep.log but I dunno how to view it mang? Help a dog out.

I tried using a fresh target device, and still no associations or URL snarfs.

Any advice?

Thx,

xtra crispy n00b

Edited by Ror
Link to comment
Share on other sites

Thanks for getting back to me Allison and Darren.

Allison, primarily I am using Win 7 SP1 to conduct activities. I mentioned Linux (BT5) because I thought I was trying to get at the log files via BT5. My linux skills blow.

Darren, after reading your advice… It was kinda funny actually. As soon I cleared the pineapple’s cache & opened up an incognito window, I started to see the URLs appear from a session the night before.

I thought well, he is on to something so I tried D’s advice with a fresh factory config.

1) reset pineapple to factory default

2) Clear pineapple cache (for kicks)

3) Cleared browser cache

4) Enabled Mk3

5) Enabled URLSnarf

6) Enabled Ngrep

After I do this factory default + reboot, I still see old snarfs with no urls. Even when i clear the pineapple cache, and incognito cache I still have ghost snarfs appearing??

These are the results I got (attached pic)

I'm back to where I was before ?! No URLs snarfing again?

In URLSnarf's module I see the PC named jglynni5 following the machine name, it reads PCHTTP. Even while I am browsing with jglynni5, I am not seeing any URLs appear, but I did a few days ago. Man I'm so confused.

Thanks dudes. Hope this message isn't too spastic. I'm actually having some of the same problems as whazupman. Although his message reads much clearer.

post-37421-0-56169700-1322505342_thumb.j

Edited by Ror
Link to comment
Share on other sites

After walking away from it, I fired it up. I had success using URL snarf.

The next thing I want to do is figure out how to extract the ngrep data. No that I can catch devices, and monitor the URLs. How can I take this further, like extract user/pass data using ngrep?

Link to comment
Share on other sites

  • 3 weeks later...

I saw this happen before in one of my first attempts at porting the firmware.

In my newest firmware urlsnarf works fine. I can try to dig out the change I made if that would help?

Best,

Seb

[/quot

hi seb

I was wondering if you could help me as you have also encountered this problem and managed to overcome it. When I first set up my pineapple mark 3 I could easily see my urlsnarf now I can no longer see my urlsnarf I have tried the following options:

1) reset pineapple to factory default

2) Clear pineapple cache (for kicks)

3) Cleared browser cache

4) Enabled Mk3

5) Enabled URLSnarf

6) Enabled Ngrep

After I do this factory default + reboot, I still see no urls. please help

thank you

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...